Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Newfangled Doom > Doom 3 General > Can you force Doom3 to load in a non-standard rez?
 
Author
All times are GMT. The time now is 08:51. Post New Thread    Post A Reply
aJynks
Newbie


Posts: 3
Registered: 05-10


Hi there...

I reinstalled doom3 recently as I love it.. and have played it often.. but for some reason when I installed it this time I can not get it to work.. and I am not sure why.

Basically I have always owned Nvidia Cards.. but I now have a new 5770 card. Anyway.. when ever I run doom 3 it always reverts to 640x480 settings.

I was wondering if you guys new a way I could edit the config files or something and set it up so everything it turned to ultra, anti aliasing and have a 1680x1050 resolution?


Thanks in advance

Old Post 05-04-10 23:04 #
aJynks is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Clonehunter
Forum Staple


Posts: 3845
Registered: 03-10


nvidia 5770? Doesnt Doom 3 use a 6800 or something like that? (For best performances), or am I wrong? (Which I probally am...)

Old Post 05-04-10 23:35 #
Clonehunter is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
kristus
Megablast!


Posts: 10626
Registered: 07-00


Add this to your config. Or simply write it in the console (minus the "seta" part) Just replace the height and width values with the ones you want to use.

seta r_customHeight "768"
seta r_customWidth "1366"
seta r_fullscreen "1"
seta r_mode "-1"

Old Post 05-04-10 23:42 #
kristus is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
Ahcruna
Junior Member


Posts: 169
Registered: 03-10



Clonehunter said:
nvidia 5770? Doesnt Doom 3 use a 6800 or something like that? (For best performances), or am I wrong? (Which I probally am...)


He said he used to have nVidia gpu's. The 5770 is a Radeon gpu =)

Whit the settings he wants it would be crazy to run Doom3 on an old Geforce FX.

Anyway, what Kristus just posted should do the trick. If you still get problems try updating to the last patch (if you alrady havent that is =)

Old Post 05-05-10 01:20 #
Ahcruna is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Quasar
Moderator


Posts: 6123
Registered: 08-00


Note you need the latest patch installed to use these commands.

You may also want to use this:

seta r_aspectRatio "x"

If your screen aspect ratio is 16:9, change the "x" to "1".
If your screen aspect ratio is 16:10 or 15:9, change the "x" to "2".

Otherwise the game may not look correct in widescreen modes.

Old Post 05-05-10 07:31 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
aJynks
Newbie


Posts: 3
Registered: 05-10


Thanks or the help guys... so I just edit the DOOMCONFIG.CFG and then save it and set to read only?

<--- Edit

OK.. I think this is working now guys thank you.... I opened DOOMCONFIG.CFG and edited it in a text file.... and set these values...

seta r_customHeight "1050"
seta r_customWidth "1680"
seta r_fullscreen "1"
seta r_mode "-1"
seta r_aspectRatio "2"

saved then set it to read only... and while in the "settings" in game it still reads 640x480 it is now running at the proper resolution.

What is the text command to enable x16 anti aliasing? Every time I change multiSamples "0" to multiSamples "16" then game then reverts back to 640x480... even with those other values plugged in and cfg file set to read only ?


<-- edit2

Also vertical Sync seams to be turned off... how can I turn that on to stop tearing?

Is there a website that has a lit of all the config commands and whet they mean?

<--- Edit 3
r_swapInterval ="1"

and I foudn this site with the config explained... http://www.techspot.com/tweaks/doom3/

I still can not get anti aliasing to work :(



<-- EDIT4

OMG there are so many options... lol.. I just wnat the best possible visuals.. as the computer and cards can handle it now... this is my current config...

DOOMCONFIG.CFG
code:
unbindall bind "TAB" "_impulse19" bind "ENTER" "_button2" bind "ESCAPE" "togglemenu" bind "SPACE" "_moveup" bind "/" "_impulse14" bind "0" "_impulse10" bind "1" "_impulse0" bind "2" "_impulse1" bind "3" "_impulse2" bind "4" "_impulse3" bind "5" "_impulse4" bind "6" "_impulse5" bind "7" "_impulse6" bind "8" "_impulse7" bind "9" "_impulse8" bind "[" "_impulse15" bind "\" "_mlook" bind "]" "_impulse14" bind "a" "_moveleft" bind "c" "_movedown" bind "d" "_moveright" bind "f" "_impulse11" bind "q" "_impulse9" bind "r" "_impulse13" bind "s" "_back" bind "t" "clientMessageMode" bind "w" "_forward" bind "y" "clientMessageMode 1" bind "z" "_zoom" bind "BACKSPACE" "clientDropWeapon" bind "PAUSE" "pause" bind "UPARROW" "_forward" bind "DOWNARROW" "_back" bind "LEFTARROW" "_left" bind "RIGHTARROW" "_right" bind "ALT" "_strafe" bind "CTRL" "_attack" bind "SHIFT" "_speed" bind "DEL" "_lookdown" bind "PGDN" "_lookup" bind "END" "_impulse18" bind "F1" "_impulse28" bind "F2" "_impulse29" bind "F3" "_impulse17" bind "F5" "savegame quick" bind "F6" "_impulse20" bind "F7" "_impulse22" bind "F9" "loadgame quick" bind "F12" "screenshot" bind "MOUSE1" "_attack" bind "MOUSE2" "_moveup" bind "MOUSE3" "_zoom" bind "MWHEELDOWN" "_impulse14" bind "MWHEELUP" "_impulse15" seta radiant_entityMode "0" seta gui_mediumFontLimit "0.60" seta gui_smallFontLimit "0.30" seta net_socksPassword "" seta net_socksUsername "" seta net_socksPort "1080" seta net_socksServer "" seta net_socksEnabled "0" seta win_ypos "22" seta win_xpos "3" seta sys_lang "english" seta s_decompressionLimit "6" seta s_useEAXReverb "0" seta s_useOpenAL "0" seta s_libOpenAL "openal32.dll" seta s_numberOfSpeakers "6" seta s_doorDistanceAdd "150" seta s_globalFraction "0.8" seta s_subFraction "0.75" seta s_playDefaultSound "1" seta s_volume_dB "0" seta s_meterTopTime "2000" seta s_reverse "0" seta s_spatializationDecay "2" seta s_maxSoundsPerShader "0" seta r_debugArrowStep "120" seta r_debugLineWidth "1" seta r_debugLineDepthTest "0" seta r_cgFragmentProfile "best" seta r_cgVertexProfile "best" seta r_forceLoadImages "0" seta r_shadows "1" seta r_skipBump "0" seta r_skipSpecular "0" seta r_skipNewAmbient "0" seta r_renderer "best" seta r_brightness "0.690476" seta r_gamma "1" seta r_swapInterval "1" seta r_useIndexBuffers "0" seta r_customHeight "720" seta r_customWidth "1280" seta r_fullscreen "1" seta r_mode "-1" seta r_multiSamples "0" seta image_downSizeLimit "256" seta image_ignoreHighQuality "0" seta image_downSizeBumpLimit "256" seta image_downSizeSpecularLimit "64" seta image_downSizeBump "0" seta image_downSizeSpecular "0" seta image_useCache "0" seta image_cacheMegs "20" seta image_cacheMinK "200" seta image_usePrecompressedTextures "1" seta image_useNormalCompression "2" seta image_useAllFormats "1" seta image_useCompression "1" seta image_preload "1" seta image_roundDown "1" seta image_forceDownSize "0" seta image_downSize "0" seta image_lodbias "-1.0" seta image_anisotropy "8" seta image_filter "GL_LINEAR_MIPMAP_LINEAR" seta gui_filter_game "0" seta gui_filter_idle "0" seta gui_filter_gameType "0" seta gui_filter_players "0" seta gui_filter_password "0" seta net_clientDownload "1" seta net_master4 "" seta net_master3 "" seta net_master2 "" seta net_master1 "" seta net_clientMaxRate "16000" seta net_serverMaxClientRate "16000" seta m_strafeSmooth "4" seta m_smooth "1" seta m_strafeScale "6.25" seta m_yaw "0.022" seta m_pitch "0.022" seta sensitivity "5" seta in_toggleZoom "0" seta in_toggleCrouch "0" seta in_toggleRun "0" seta in_alwaysRun "0" seta in_freeLook "1" seta in_anglespeedkey "1.5" seta in_pitchspeed "140" seta in_yawspeed "140" seta gui_configServerRate "0" seta com_guid "WWE8BwxWXVM" seta com_preloadDemos "0" seta com_compressDemos "1" seta com_product_lang_ext "1" seta sv_punkbuster "0" seta cl_punkbuster "0" seta com_videoRam "128" seta com_showFPS "0" seta com_purgeAll "0" seta com_machineSpec "1" seta g_decals "1" seta g_projectileLights "1" seta g_doubleVision "1" seta g_muzzleFlash "1" seta net_serverDlTable "" seta net_serverDlBaseURL "" seta net_serverDownload "0" seta mod_validSkins "skins/characters/player/marine_mp;skins/characters/player/marine_mp_green;skins/characters/player/marine_mp_blue;skins/characters/player/marine_mp_red;skins/characters/player/marine_mp_yellow" seta g_mapCycle "mapcycle" seta g_voteFlags "0" seta g_gameReviewPause "10" seta g_countDown "10" seta g_password "" seta g_showBrass "1" seta g_showProjectilePct "0" seta g_showHud "1" seta g_showPlayerShadow "1" seta g_showcamerainfo "0" seta g_healthTakeLimit "25" seta g_healthTakeAmt "5" seta g_healthTakeTime "5" seta g_useDynamicProtection "1" seta g_armorProtectionMP "0.6" seta g_armorProtection "0.2" seta g_damageScale "1" seta g_nightmare "0" seta g_bloodEffects "1" seta r_aspectRatio "0" seta ui_showGun "1" seta ui_autoReload "1" seta ui_autoSwitch "1" seta ui_team "Red" seta ui_skin "skins/characters/player/marine_mp" seta ui_name "Player" seta si_serverURL "" seta si_spectators "1" seta si_usePass "0" seta si_warmup "0" seta si_teamDamage "0" seta si_timeLimit "10" seta si_fragLimit "10" seta si_maxPlayers "4" seta si_map "game/mp/d3dm1" seta si_gameType "singleplayer" seta si_name "DOOM Server" seta g_spectatorChat "0" seta net_clientLagOMeter "1"


This is my current autoexec
code:
set image_rounddown "1" set r_shadows "1" set r_useOptimizedShadows "0" set r_useTurboShadow "0" set g_showplayershadow "1" set r_skipDynamicTextures "0" set r_skipBump "0" set r_swapInterval "1" set g_projectileLights "1" set r_skipTranslucent "0" set r_skipFogLights "0" set r_skipUpdates "0" set r_skipDiffuse "0" set r_skipParticles "0" set cm_backFaceCull "0" set r_skipPostProcess "0" set image_useAllFormats "1" set r_useDepthBoundsTest "0" set image_useCache "0" set r_mode "-1" set r_customWidth "1680" set r_customHeight "1050" set image_lodbias "-1.0" set image_anisotropy "8" set r_multiSamples "0" set pm_thirdperson "0" set pm_thirdPersonDeath "0" set ui_showGun "1" set g_showHud "1" set com_drawfps "0" set com_allowconsole "0" set s_showLevelMeter "0" set g_showProjectilePct "0" set g_doublevision "1" set g_muzzleFlash "1" set g_skipViewEffects "0" set g_skipFX "0" set g_bloodEffects "1" set g_decals "1" set g_showBrass "1" set r_fullscreen "1" set com_compressSaveGame "0" set s_numberOfSpeakers "6" set com_videoRam "128"



Also i thought it would be cool to enable 3rd person deaths.. but I can not see that option to work, if I enable it I also have to play in 3rd person


ANYWAY.... the set up I posted here seams to work... as in It loads at the correct res and also seams to look pretty good. if you have any suggestions please let me know. Still I know this thread is going on and on.. but I get the same problem when I run the Xpac... how can I get the config file to load when launching the Xpac?

Last edited by aJynks on 05-05-10 at 13:11

Old Post 05-05-10 10:18 #
aJynks is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
aJynks
Newbie


Posts: 3
Registered: 05-10


Thanks man.... ok... for my setup all had to do was make a txt file called autoexec.cfg and place it in the "..\Steam\steamapps\common\doom 3\base" dir. With the following codes...

code:
set com_machineSpec 3 set r_mode -1 set r_customWidth 1680 set r_customHeight 1050 set image_lodbias "-1.0" set image_anisotropy 8 set r_multiSamples 8 set r_aspectRatio 2


set com_machineSpec 3 = ULTRA VIDEO SETTINGS
set r_mode -1 = CUSTOM RESOLUTION
set r_customWidth 1680 = RESOLUTION WIDTH
set r_customHeight 1050 = RESOLUTION HIGHT
set image_lodbias "-1.0" = SHARPENS THE IMAGE A BIT (reduces blur)
set image_anisotropy 8 = ANISOTROPIC FILTERING X8 (texture sampling)
set r_multiSamples 8 = ANTI-ALIASING X8 (x16 crashed my system for some reason)
set r_aspectRatio 2 = CORRECT ASPECT RATIO FOR MY CHOSEN RESOLUTION

The autoexec.cfg if placed the the dir I said at the start, these setting will auto load and override whatever is in the default doomconfig.cfg that comes with doom for those same settings...

Thanks for the help.. for more details on the cfg file.. check that link that ]http://www.techspot.com/tweaks/doom3/

Thanks for all your help guys.

Old Post 05-12-10 04:24 #
aJynks is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 08:51. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Newfangled Doom > Doom 3 General > Can you force Doom3 to load in a non-standard rez?

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.