Doom Marine
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Newfangled Doom > Doom 3 General > What do i need to run it???
 
Author
All times are GMT. The time now is 13:00. Post New Thread    Post A Reply
White Knight
Newbie


Posts: 3
Registered: 05-10


Having trouble with running the game after I installed it. Gives this message... using XP 2

OOM 1.3.1.1304 win-x86 Jan 16 2007 15:36:51
1484 MHz AMD CPU with MMX & 3DNow! & SSE
1024 MB System Memory
128 MB Video Memory
Winsock Initialized
Found interface: {2A73A889-C68F-47AB-9F8C-DDEA881AC952} VIA Compatable Fast Ethernet Adapter - Packet Scheduler Miniport - 74.70.217.114/255.255.240.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files\Doom 3\base\game00.pk4 with checksum 0x7dafc4d4
Loaded pk4 C:\Program Files\Doom 3\base\game01.pk4 with checksum 0x51c6981f
Loaded pk4 C:\Program Files\Doom 3\base\game02.pk4 with checksum 0xf3ec6f7
Loaded pk4 C:\Program Files\Doom 3\base\game03.pk4 with checksum 0x5d4230ea
Loaded pk4 C:\Program Files\Doom 3\base\pak000.pk4 with checksum 0x28d208f1
Loaded pk4 C:\Program Files\Doom 3\base\pak001.pk4 with checksum 0x40244be0
Loaded pk4 C:\Program Files\Doom 3\base\pak002.pk4 with checksum 0xc51ecdcd
Loaded pk4 C:\Program Files\Doom 3\base\pak003.pk4 with checksum 0xcd79d028
Loaded pk4 C:\Program Files\Doom 3\base\pak004.pk4 with checksum 0x765e4f8b
Loaded pk4 C:\Program Files\Doom 3\base\pak005.pk4 with checksum 0x8ffc3621
Loaded pk4 C:\Program Files\Doom 3\base\pak006.pk4 with checksum 0x95b65ab
Loaded pk4 C:\Program Files\Doom 3\base\pak007.pk4 with checksum 0x666bdb3c
Loaded pk4 C:\Program Files\Doom 3\base\pak008.pk4 with checksum 0x23ae5993
Current search path:
C:\Program Files\Doom 3/base
C:\Program Files\Doom 3\base\pak008.pk4 (3 files)
C:\Program Files\Doom 3\base\pak007.pk4 (38 files)
C:\Program Files\Doom 3\base\pak006.pk4 (48 files)
C:\Program Files\Doom 3\base\pak005.pk4 (63 files)
C:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
C:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
C:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
C:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
C:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
C:\Program Files\Doom 3\base\game03.pk4 (2 files)
C:\Program Files\Doom 3\base\game02.pk4 (2 files)
C:\Program Files\Doom 3\base\game01.pk4 (2 files)
C:\Program Files\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5206 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
5206 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 7 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
X..GL_ARB_multitexture not found
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_texture_env_add not found
X..GL_ARB_texture_non_power_of_two not found
X..GL_ARB_texture_compression not found
X..GL_EXT_texture_filter_anisotropic not found
X..GL_EXT_texture_lod not found
X..GL_1.4_texture_lod_bias not found
X..GL_EXT_shared_texture_palette not found
X..GL_EXT_texture3D not found
X..GL_EXT_stencil_wrap not found
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
X..GL_ARB_vertex_program not found
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features.
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

Any Ideas?????????

Last edited by White Knight on 05-27-10 at 16:37

Old Post 05-27-10 16:27 #
White Knight is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
RazTK
Junior Member


Posts: 149
Registered: 10-05



White Knight said:
ERROR: The current video card / driver combination does not support the necessary features.
?

Old Post 05-27-10 17:53 #
RazTK is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
White Knight
Newbie


Posts: 3
Registered: 05-10


I figured it out. I downloaded the newest version for my nVidia. Works great

Old Post 05-27-10 18:45 #
White Knight is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
chungy
Senior Member


Posts: 1893
Registered: 06-05


Yeah, just a tip for future reference, drivers that come preinstalled on OEM computers sometimes don't support OpenGL for whatever reason (Intel seems to be an exception for this, probably because of all the support they put behind OpenGL...). Just downloading and installing the drivers from ATI or NVIDIA fixes this :-)

Old Post 05-27-10 22:31 #
chungy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
White Knight
Newbie


Posts: 3
Registered: 05-10


And so it did. Spent all afternoon killin those buggers. Thanks for the tip btw

Old Post 05-28-10 01:07 #
White Knight is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 13:00. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Newfangled Doom > Doom 3 General > What do i need to run it???

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.