Doom Comic
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Builder > Doom Builder on Windows Vista - How To
Pages (2): [1] 2 »  
Author
All times are GMT. The time now is 00:22. Post New Thread    Post A Reply
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Because Windows Vista is not so friendly to "classic" Windows applications, you need some manual changes to your Doom Builder installation to get it to work in Vista. Here they are, thanks to Mechadon.

1) Install Doom Builder in a directory OTHER than "Program Files".

2) Download this DLL file and unzip it to your Doom Builder directory.

3) Find Builder.exe where you installed Doom Builder, right-click it and choose "Properties". In the "Compatability" tab, check the box that says "Run this program in compatiblity mode for:" and choose "WinXP (SP2)" from the drop-down box.

4) For people experiencing an "Error 5 - Invalid procedure call or argument" error on Windows Vista, please read tannermann's solution.

Now you should be able to use Doom Builder on Windows Vista, enjoy.

Last edited by CodeImp on 12-27-07 at 20:40

Old Post 05-14-07 07:36 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
hardcore_gamer
Fáviti Member


Posts: 2343
Registered: 03-07


I don't need this know but i WILL in the future thanks!

Old Post 05-21-07 22:05 #
hardcore_gamer is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Doomguy0505
Mini-Member


Posts: 55
Registered: 03-07


Here's a mirror
http://enz.no-ip.org:9000/Other/Other/msvbvm50.dll

Old Post 06-11-07 00:49 #
Doomguy0505 is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Jonathan
I am not a leet hax0r :(


Posts: 743
Registered: 05-00


Did all of that, it still gives an error.

Last edited by Jonathan on 06-15-07 at 20:06

Old Post 06-15-07 19:54 #
Jonathan is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doomguy0505
Mini-Member


Posts: 55
Registered: 03-07


What error?

Old Post 06-16-07 05:19 #
Doomguy0505 is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Jonathan
I am not a leet hax0r :(


Posts: 743
Registered: 05-00


Run-time error '48':

File not found: 'msvbvm50.dll'

Old Post 06-16-07 11:58 #
Jonathan is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Then msvbvm50.dll is probably not in your System directory. Note that this directory is named slightly different on different versions of Windows. I believe in Windows XP it is C:\Windows\system32\, not sure what it is in Vista.

Old Post 06-16-07 12:51 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
TheDarkArchon
Senior Member


Posts: 2332
Registered: 08-04


C:\Windows\system32 is still there in Vista (Home Premium 32-bit, anyway)

__________________
* insert completely and utterly useless nonsense here that nobody will ever read ever *

Old Post 06-16-07 14:55 #
TheDarkArchon is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Jonathan
I am not a leet hax0r :(


Posts: 743
Registered: 05-00


I know where the system folder is, and I can assure you that that dll is in there, but it still gives an error...

Old Post 06-16-07 20:49 #
Jonathan is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15221
Registered: 04-02


Maybe you have to register the file for the OS to use it? With regsrv32, I mean (assuming that is still the name of the file in Vista).

Old Post 06-16-07 21:11 #
myk is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Catoptromancy
Forum Regular


Posts: 905
Registered: 08-06


This problem happens on any OS, not just Vista.
There was actually 2 DLLs I needed for Win2000 to work. Quick google of them fixed it.

Old Post 06-17-07 05:42 #
Catoptromancy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Planky
Senior Member


Posts: 1191
Registered: 12-02


Jonathan: Dumping the DLL in the Doom Builder directory should fix it.

Old Post 06-17-07 08:16 #
Planky is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Jonathan
I am not a leet hax0r :(


Posts: 743
Registered: 05-00


Cool, that worked.

Old Post 06-17-07 13:02 #
Jonathan is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Thanks Planky, I have updated my initial post accordingly.

Old Post 06-17-07 15:06 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Plonker
Junior Member


Posts: 105
Registered: 07-07


Thanks, I wish you wouldnt have the files stored where those really dodgy 'fix your registry free' type adverts are, Im sick of having to clean peoples computers after they click on those type of adverts

__________________
so long and thanks for all the fish

Old Post 07-11-07 15:32 #
Plonker is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Skeetz
Warming Up


Posts: 25
Registered: 03-07


Also, you might want to add that running it as Administrator might fix some problems as well.

Old Post 07-24-07 19:48 #
Skeetz is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
sausage
Forum Regular


Posts: 676
Registered: 05-05


Sadly, It didnt work. :(

Old Post 09-29-07 01:02 #
sausage is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Hellbent
Forum Bellend


Posts: 4782
Registered: 06-00


Thanks! It worked first try! Not sure why I never tried Doom Builder before, but this would be my first go at it. We'll see how it stacks up to DeepSea!

Thanks to those who put this little guide together.

Old Post 11-17-07 17:11 #
Hellbent is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Doomguy0505
Mini-Member


Posts: 55
Registered: 03-07


I've uploaded all of the libraries used at http://files.filefront.com/Doom+Bui...;/fileinfo.html in case any others are missing

Save this in the Doom Builder folder to get visual styles in vista (xp has drawing glitches)

Builder.exe.manifest
code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?> <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0"> <assemblyIdentity version="1.0.0.0" processorArchitecture="X86" name="ZDL.ZDL.ZDL" type="win32" /> <description>ZDL</description> <dependency> <dependentAssembly> <assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.0.0" processorArchitecture="X86" publicKeyToken="6595b64144ccf1df" language="*" /> </dependentAssembly> </dependency> </assembly>

Last edited by Doomguy0505 on 12-23-07 at 06:18

Old Post 12-23-07 05:59 #
Doomguy0505 is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
tannermann
Warming Up


Posts: 13
Registered: 12-07


Well i Released a Tutorial on one of the Problems that occours due to a Problem.

http://www.doomworld.com/vb/showthr...?threadid=42056

Very easy steps on making the Read Error 5 leave us the Fuck alone.

Old Post 12-27-07 04:34 #
tannermann is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Nice find! I have added it to the notes at the top.

Old Post 12-27-07 20:41 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
tannermann
Warming Up


Posts: 13
Registered: 12-07


You mean me? that would be awsome if he meant me ^_^

Old Post 12-29-07 10:21 #
tannermann is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Well you found that solution, didn't you?!

Old Post 12-29-07 11:30 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
K!r4
Senior Member


Posts: 1324
Registered: 05-07


It works fine, thanks !

Old Post 02-08-08 23:27 #
K!r4 is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
GhostlyDeath
Forum Retard


Posts: 1027
Registered: 08-05


Don't know if this thread is still alive but to get DB working in Vista w/ or w/o the UAC. (This is if you have it in the default install location)

Anything that requires admin rights should pop up a UAC box, if it's disabled then you may have to log in under an admin to adjust things.

1 - REQUIRES ADMIN RIGHTS) Right click properties on the Doom builder folder (defaults to C:\Program Files\Doom Builder) and go to the "Security" tab.
2 - REQUIRES ADMIN RIGHTS) Under the "Everyone" user or your username, Go to Change permissions or advanced and make sure all the checks except "Special Permissions" (it's grayed out anyway) are checked (so you have Read/Write/Execute permissions)

3 - REQUIRES ADMIN RIGHTS) Press OK and a box will ask you if you want to apply the permissions to just the folder or everything inside, choose everything inside and press OK

4) Download MSVBVM50.DLL and place it in the DB Folder or in C:\Windows\System32 (REQUIRES ADMIN RIGHTS) if you want it available to every app (Be sure to get one that matches your system/language!)

5 - OPTIONAL) if DB crashes for unknown reasons, right click Properties, go to the "Compatibility" tab and choose Windows XP Service Pack 2. Whenever I used DB in Vista, I never had any problems.

People who want to read this are:
1] People who do not want to Install Doom Builder in a directory OTHER than "Program Files"
2] People who just rapidly press "Next >" in the installation wizard
3] Union Aerospace Corporation Employes
4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!

btw the "Error 5 - Invalid procedure call or argument" is basically saying that you don't have the privs to save or modify files/registry entries.

Hope this helps!

Old Post 02-13-08 04:33 #
GhostlyDeath is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15221
Registered: 04-02



GhostlyDeath said:
4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!
Quite true; the real reason he's hacking into people's computers is because he's an UAC informer, and is on the lookout for people (especially among those mentioned in case 3 above) distributing secret UAC base plans in the form of wads!

Old Post 02-13-08 04:48 #
myk is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
esselfortium
A Major Doomworld Concern


Posts: 6514
Registered: 01-02


http://420.thrashbarg.net/user_account_control_uac_doomguy_windows_vista_uncyclopedia.png

__________________
essel.spork-chan.net - doom stuff, artwork, and music by esselfortium

Old Post 02-13-08 05:54 #
esselfortium is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03



GhostlyDeath said:
4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!

Shhh! It's true, but only you and me know now, ok?!

Old Post 02-13-08 06:27 #
CodeImp is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
geit
Newbie


Posts: 3
Registered: 05-08


Hmm I got something failing.
It first started up quite normal.. but doing anything, like pressing 'new map' would make it crash. That is fixxed now because of that dll file. I als run it as compability mode. The onlything now is when I configure doombuilder, I tell doombuilder where it can find all the iwads, and when pressing ok, it says: error 9 subscript out of range.

kinda failed so, I have admin rights and even tried running it as administrator by right clicking. Does doombuilder just really fails on vista? :o

that'd be bad!

any help?

and oh yes, hello to all!
plas!

Old Post 05-14-08 19:03 #
geit is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 696
Registered: 09-06



geit said:
I tell doombuilder where it can find all the iwads, and when pressing ok, it says: error 9 subscript out of range.


I'm getting the same.... I really would like to Map for GZDoom and ZDoom, but this problem is occuring to where cannot do so. I too did all the steps, but this one comes in.

Old Post 06-04-08 05:17 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 00:22. Post New Thread    Post A Reply
Pages (2): [1] 2 »  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Builder > Doom Builder on Windows Vista - How To

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.