The best around
User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Builder > DB1 on USB and error52
 
Author
All times are GMT. The time now is 05:00. Post New Thread    Post A Reply
D_GARG
Forum Regular


Posts: 926
Registered: 12-09


Hi, I am here at my school having a break, I try to run doombuilder at a PC via my USB drive. I mapped some minutes and by some reason I get an error message which says :

"Error 52 while loading map: Bad file name or number"

Is there any connection between that I use it from a USB drive or that i might use it on the wrong PC, or that the program maybe has gone corrupted? the builder bumps into this on any wad file

maybe this is the wrong place to ask this at, sorry if so.

Old Post Aug 26 2010 09:32 #
D_GARG is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
CodeImp
Moderator


Posts: 1501
Registered: 12-03


Yea I don't care much for DB1 anymore, it is old. It is only still available for download because not everyone has a modern computer.

DB1 doesn't do anything in the background, so doubt it suddenly gave you that error out of the blue while you are mapping. You probably tried to save your map? Either way, yes, it may have to do with DB1 being on a USB stick. It was not made to work like that. Make sure you have writing rights to that USB stick, because DB1 saves its settings in its own program directory (regardless where you save your WAD file).

Old Post Aug 26 2010 10:25 #
CodeImp is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
D_GARG
Forum Regular


Posts: 926
Registered: 12-09


yea I noticed that the problem was that the config of files and nodes including testing exe was totally wrong.

by some reason, DB thought it all was in E:/ but there was nothing on E:/

so I fixed it by browsing it at H:/ were it actualy was

then it all worked fine

Old Post Aug 26 2010 10:37 #
D_GARG is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
GreyGhost
I have a custom title now!


Posts: 9412
Registered: 01-08


Normal practice is to allocate the lowest available drive letter to USB drives, so on one PC it was E:, on another it's H: and on a third it might be something entirely different. That's a problem you'll have to learn to live with.

Builder.cfg can be edited to use relative paths for IWADs, but not nodebuilders or testing - they'll need to be checked on each PC you plug the USB drive into. You can't trust the list of recently edited wads either since each entry is dependent on a specific PC's drive mapping.

Old Post Aug 27 2010 08:30 #
GreyGhost is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 05:00. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Builder > DB1 on USB and error52

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.