Severed bunny head
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > SPFALL (Acid Fall) Textures in Doom 1
 
Author
All times are GMT. The time now is 13:28. Post New Thread    Post A Reply
DooMBoy
Heh
(but Stupidity still cannot be concealed)


Posts: 8509
Registered: 12-00


Well, I've extracted SPFALL1 from Doom2 to be used in Doom 1 using Wintex. The problem is this: the texture shows up, but it doesn't animate like it would if it were in Doom2. How do I fix this problem?
Do I extract all the SPFALL textures or what?

__________________
Heh

Old Post 11-09-02 16:20 #
DooMBoy is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Kid Airbag
Not really a kid. Not really an airbag. WHAT THE HELL IS IT?!? Who's asking? Are you French? An airbag is a safety device in a car that inflates during a collision and blocks you from smashing your head into the dashboard or steering wheel!


Posts: 6359
Registered: 12-00


You need to extract all the SPFALL textures AND either replace another animating texture set with them, or find out some way to create an additional ani lump entry (which can only be done with source ports IIRC).

__________________
Hey Jude

Old Post 11-09-02 16:25 #
Kid Airbag is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
The Ultimate DooMer
(former) /newstuff Chronicler


Posts: 4701
Registered: 03-02


If you're using ZDoom, you can create an animdefs lump:

http://zdoom.notgod.com/zdkb/zdoom12.html

Old Post 11-09-02 17:00 #
The Ultimate DooMer is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DooMBoy
Heh
(but Stupidity still cannot be concealed)


Posts: 8509
Registered: 12-00


OK, I've got all the textures extracted and I did an ANIMDEFS lump and put it into my level. Thing is, the SPFALL textures don't animate. Here is the ANIMDEF lump:
texture sfall1

pic 1 tics 4
pic 2 tics 4
pic 3 tics 4
pic 4 tics 4

Now tell me if I'm doing something, cause I've never did one of these before, I'm just really guessing.

__________________
Heh

Old Post 11-09-02 17:38 #
DooMBoy is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
The Ultimate DooMer
(former) /newstuff Chronicler


Posts: 4701
Registered: 03-02


The text is the same when compared to mine (which has 5 tics instead of 4) so that's ok. I think what's wrong is that you have the sfall patches in the wad, but you haven't made them into textures yet. Here's what to do:

Select 'edit texture' from the Advanced menu.

Select 'new texture' from the Textures menu, typing 'sfall1' as the name. You now have a blank texture.

Use the sliding bar at the top to make it 64x128.

Go to the patch list in the bottom right corner, select the SFALL1 patch and drag it into the cyan square, making sure it fits exactly in the (0, 0) position.
(using the 'up' 'down' 'left' 'right' buttons if necessary, but highlight the patch in the box next to the patch list if you need to use these buttons)

Repeat this for SFALL2, SFALL3 and SFALL4, making sure they all appear after each other in the texture list (bottom left corner). To do this, highlight the texture below the one you just created and then create a new texture.

Quit, and click 'yes' to save textures into pwad.

Save your wad.

Old Post 11-09-02 22:25 #
The Ultimate DooMer is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Enjay
ASK ME ABOUT FOOTBALL / STEAM / DEAD CELEBRITIES / THE BLAIR WITCH PROJECT


Posts: 6381
Registered: 12-00


If you have indeed simply included the patches, but not made textures for them, then once you have created your textures too, there is actually no need to create an animdefs lump.

I just checked. I exported the SFALL graphics from doom2 to a WAD (intended for use in Doom1), loaded up the doom1 project in DeePsea, loaded my SFALL wad and then defined textures SFALL1-4 using the patches SFALL1-4. Then I editied the start room of E1M1 so that SFALL1 was used on the wall. I tried the level in Zdoom and Vanilla Doom and the SFALL walls appeared and worked correctly.

FYI, the lumps in the file were:

E1M1 and all its sub lumps
SFALL1 - a graphic
SFALL2 - a graphic
SFALL3 - a graphic
SFALL4 - a graphic
TEXTURE1 - The texture information lump
TEXTURE2 - The second texture information lump (Only found in registered Doom)
PNAMES - The list of all patches used in the textures.

__________________
Meek

Old Post 11-10-02 12:10 #
Enjay is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 13:28. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > SPFALL (Acid Fall) Textures in Doom 1

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.