Mancubus
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Can some1 tell me how 2 fix this error?
 
Author
All times are GMT. The time now is 23:32. Post New Thread    Post A Reply
The Shinjo
Warming Up


Posts: 13
Registered: 09-02


A couple months ago i released a Heretic map: Steeple Chase. I've since began to tidy it up and such with the aim being to rerelease it. However recently it has began to crash after I have crossed a specific number of trigger linedefs with the following error

P_AddActivePlat: no more plats!

I don't beleive it's because of to many triggers or anything like that because other maps i have made with more triggers don't suffer from said error.It also seems to be Heretic Specific

Can someone plz tell exactly what causes it, and how to fix it?

Old Post 01-09-03 21:43 #
The Shinjo is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Szymanski


Posts: 1016
Registered: 08-00


I think there's a limit to the amount of sectors moving at any time, can you give some specifics?

Old Post 01-09-03 21:54 #
Szymanski is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
Ichor
The Mysterious Red Square


Posts: 6940
Registered: 07-02


You can only have 30 platforms moving at once. However, I think it's possible to get this error if a line has a sector tag of 0. If that happens, every sector in the map may begin moving all at once.

__________________
0.666 - The number of the Millibeast

Old Post 01-09-03 22:09 #
Ichor is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
The Ultimate DooMer
(former) /newstuff Chronicler


Posts: 4701
Registered: 03-02


I've had this trouble occasionally, but I'm not sure what causes it. All I do know is that it affects vanilla, but not source ports.

Old Post 01-09-03 23:29 #
The Ultimate DooMer is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
The Shinjo
Warming Up


Posts: 13
Registered: 09-02


On closer inspection i have discovered the error only occurs in Jheretic, (Legacy and Zdoom work fine) Stupid me for not checking earlier. The error seems to realate to the ammount of activated triggers (bout 80)(wheter they are moving at the time of the crash doesn't seem to effect it). Guess it's a limitation i'll have to work round as the map's appearence was designed round Jheretic. Thanx for the asistence ppl

Old Post 01-10-03 13:01 #
The Shinjo is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
The Shinjo
Warming Up


Posts: 13
Registered: 09-02


Actually what I said above didn't seem to be the cause of the error. When I changed the lindefs values of about 10 sectors with the same propeties (and trigger linked to them) making them into 1 sector, the problem completely dispeared. Prehaps theres a limit in Doomsday that only allows a maximun amount of flats across different sector to move during a level

Old Post 01-10-03 18:20 #
The Shinjo is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 23:32. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Can some1 tell me how 2 fix this error?

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.