Reaper Grimm
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > wtf is going on? - helllllp please
 
Author
All times are GMT. The time now is 14:24. Post New Thread    Post A Reply
Russell
Newbie


Posts: 4
Registered: 11-01


I've been designing a vanilla doom2 level using WA. The level now has around 1700 sectors. Everything was fine until i added a few sectors to the middle of the map. Now, when I head to the northern end of the map and fire the BFG north, Doom crashes to a window like this....

http://www.duellist.net/ffs.jp

and I get an info box telling me...

"You cannot run this graphics appication windowed. This application will be suspended until you switch it to full screen by pressing Alt-Enter. Check the properties to ensure they are correct."

Obviously Alt-Enter does nothing and so I have to close the window :(

I've tried using a backed up version of the map and carefully added the sectors making sure everything is correct, but I still get the same error. The odd thing is that the new sectors are nowhere near where the error occurs.

Anybody had this problem or have any suggestions?

Old Post 11-20-01 22:23 #
Russell is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Russell
Newbie


Posts: 4
Registered: 11-01


Here's the correct link for the image i hope;

<a href=http://www.duellist.net/ffs.jpg>http://www.duellist.net/ffs.jpg</a>

Old Post 11-20-01 22:28 #
Russell is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Espi
Möh.


Posts: 682
Registered: 06-00


Here is a correct link. Anyway about the problem, I have no idea what could cause it.

Old Post 11-21-01 19:23 #
Espi is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Russell
Newbie


Posts: 4
Registered: 11-01


heh, thanks for correcting the link, I should have read the forum faq before trying to post!

I have a theory about what is causing the problem and i've found what is required to avoid the crash. I'll detail in the text file accompanying the level when it's released, cause I don't have the time to describe it now.

Old Post 11-21-01 19:56 #
Russell is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


I've seen that happen a lot with Vanilla doom/2.exe, I used to be able to avoid it but now I don't even remember what causes it.

/me hugs the Millennium engine.

Old Post 11-21-01 20:43 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lazer
Member


Posts: 362
Registered: 03-01


If I remember correctly, it is do to the nodes not being built right. (or at all)

Old Post 11-21-01 23:36 #
Lazer is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Erik
Senior Member


Posts: 2097
Registered: 10-01


I remember that happening to me once in vanilla doom2. It was not in a PWAD though. I believe it was Doom2 map26, right in the beginning with the chaingunners... Had to reinstall to fix it. No idea what caused it though.

Old Post 11-22-01 01:16 #
Erik is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 5924
Registered: 08-00


That's a classic venetian blinds crash. Been a long time since I saw it, brings back lots of bad memories ;)

Likely culprits could be a bad node build, bad sidedefs, or an otherwise corrupted level. I've seen some editors including WadAuthor tear levels completely up before, so bad that they can't be repaired.

Try running the level as-is in a modern source port and see if you don't get a better error message.

Old Post 11-22-01 01:41 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Russell
Newbie


Posts: 4
Registered: 11-01


The only source port I have on my machine atm is ZDoom 1.22 It doesn't crash, the error only seems to occur in vanilla Doom2. Maybe i'd better donload some other ports and see if they run it okay too. heh, should i be smiling or frowning?

Old Post 11-22-01 03:08 #
Russell is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Searcher
Senior Member


Posts: 1351
Registered: 05-01



I've been designing a vanilla doom2 level using WA. The level now has around 1700 sectors. Everything was fine until i added a few sectors to the middle of the map. Now, when I head to the northern end of the map and fire the BFG north, Doom crashes to a window like this....

http://www.duellist.net/ffs.jpg

and I get an info box telling me...

"You cannot run this graphics appication windowed. This application will be suspended until you switch it to full screen by pressing Alt-Enter. Check the properties to ensure they are correct."

Obviously Alt-Enter does nothing and so I have to close the window :(

I've tried using a backed up version of the map and carefully added the sectors making sure everything is correct, but I still get the same error. The odd thing is that the new sectors are nowhere near where the error occurs.

Anybody had this problem or have any suggestions?



I have not had the problem on my brand new system but I used to get it once in a while, somewhat randomly.

Most of the time a simple reboot would do the trick.
Eventualy my video card went out so it may tied to that. Can you check your video card? It seems like it might be one possible problem. My video card was only 6 months old when it bit the big one.

You might also check the properties on your icon to see if something in it got changed on Memory, screen or Misc. tabs.

Mine did not seem to be related to sectors or anything, it was very random. It never was at a time when it was convienent.

If not one of these things I have no clue :(

Old Post 11-22-01 03:14 #
Searcher is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Cyclane
Warming Up


Posts: 10
Registered: 12-01


For some weird reason, my old machine used to do that after killing the Boss Brain on Map 30. Is it really the editor's fault?

Old Post 12-02-01 06:30 #
Cyclane is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
pritch
Super Moderator


Posts: 6135
Registered: 11-01


after what cyclane said, I'd be tempted to say it was a system resources related problem, after all, using the BFG and the the explosion killing the boss brain is when system will be under most strain, though Doom isn't exactly a space hog by nowadays standards, so I dunno. It's a weird one alright, if only Lut remembered what happened...
/tries to make Lut feel guilty :)

Old Post 12-05-01 21:16 #
pritch is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Fredrik


Posts: 11685
Registered: 05-00


Happened to me a few times on an older computer... I think it's related to system performance (does not seem very much like an internal DOOM bug)

Old Post 12-06-01 21:38 #
Fredrik is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 14:24. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > wtf is going on? - helllllp please

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.