Spider Mastermind
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > SLADE3 freezes randomly in Windows 7
 
Author
All times are GMT. The time now is 02:55. Post New Thread    Post A Reply
TendaMonsta
Member


Posts: 288
Registered: 08-09


I have Windows 7 Home Edition and I've had slade for awhile. I kept running into issues where it would freeze randomly and it wouldn't even give an error report.

Keep in mind that I have the latest SVN build and the pdb file. I just wanted to know if anyone else is experiencing this same issue, or if there is a way to keep this from happening.

Old Post 03-01-11 05:54 #
TendaMonsta is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Alphawolf
Banned


Posts: 287
Registered: 10-10


Run as administratoor, a lot of programs don't work in Windows 7 or Vista if you don't run as administrator.

Old Post 03-01-11 16:00 #
Alphawolf is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11112
Registered: 07-07


Slade doesn't need to be run as administrator. Slayer uses Windows 7 as well for development, by the way.

Also, at the moment, the official version (3.0.1) is more recent than the latest SVN build (r820).

Old Post 03-01-11 17:13 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
PRIMEVAL
Senior Member


Posts: 1965
Registered: 03-09


Slayer uses Windows 7? Awesome!

Oh wait, we're not talking about the band, are we?




But hey, at least you can get Slade 3 to work in Win7...something I can't seem to do.

Old Post 03-01-11 17:49 #
PRIMEVAL is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11112
Registered: 07-07


http://mancubus.net/svn/slade/?op=log

Old Post 03-01-11 18:16 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Du Mhan Yhu
Member


Posts: 576
Registered: 12-10


SLADE 3 will freeze on me even when running as administrator, Forcing me to do some things in XWE and the other half of things in SLADE 3. If im lucky, SLADE 3 wont freeze while saving. I do run it in Windows 7 but SLADE 3 is the only program ive ever had to run as an admin...

Old Post 03-03-11 15:53 #
Du Mhan Yhu is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11112
Registered: 07-07



skaman86 said:
SLADE 3 will freeze on me even when running as administrator

That's because the problem you have isn't related to running as administrator. SLADE 3 doesn't need to have administrator access, and won't do anything with it, so running it as admin is using the wrong remedy for the illness.

I have no idea what would cause these freeze.

Can you try to find possible reasons for these freezes? Next time you have one, can you post the content of the slade3.log, slade3_crash.log and config/slade3.cfg on pastebin? You'll find them either in the directory where you've installed SLADE 3 (for a portable installation) or in %APPDATA%\Slade3 otherwise (just copy paste "%APPDATA%\Slade3" in the address bar of the Windows 7 file manager/explorer and it'll lead you there, but if not the full path is something like C:\Users\<username>\AppData\Roaming\Slade3).

If the crash always happen when a particular file is opened (for example, the mod you are working on), then we may need that file too, to see if we can replicate the bug.

Old Post 03-03-11 16:11 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Du Mhan Yhu
Member


Posts: 576
Registered: 12-10


Yeah, infact im going to be using Slade 3 here in a few minutes. If and when it does freeze, ill be sure to do that.

Also I just checked in C:\Users\<username>\AppData\Roaming\Slade3 all I find there are slade3.cfg, I don't see any kinda crash logs no slade3.log, slade3_crash.log.... I also tried put %APPDATA%\Slade3 in the address bar of the Windows 7 file manager\explorer.. but to no avail.

I must add, When it does freeze for me it says "Slade 3 is not responding" Then it just stays that way and doesnt change. Then ill try to "X" it out and it will tell me windows is looking for the cause of the problem, then it just closes shortly after finding no cause to the problem.

EDIT:Im amazed, Ive used Slade 3 quite a bit lately and im happy to say it hasnt froze... Even when copying over 3,000 entries at once.

Last edited by Du Mhan Yhu on 03-07-11 at 23:06

Old Post 03-03-11 18:01 #
Du Mhan Yhu is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
TendaMonsta
Member


Posts: 288
Registered: 08-09


These freezes are still happening and Slade won't even write a report. The freeze usually happens when that windows explorer window pops-up.

For example: User wants to export a flat as PNG "Slade is not responding"

Although I'm not really worried about these crashes anymore because I'll just have to get used to them until slade is fully stable.
Better yet I'll use SlumpEd since its reliable and I can do the important stuff in Slade such as adding patches into texturex and such because it never crashes when I'm dong stuff like that.

Last edited by TendaMonsta on 03-11-11 at 23:48

Old Post 03-11-11 23:34 #
TendaMonsta is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
NaturalTvventy
Forum Regular


Posts: 818
Registered: 06-09


Slade is pretty buggy for me as well. I have windows 7. it will freeze on me if i try to open a file after i've been using the program for more then about a minute. then it freezes up on me at random as well. I just use SLumpEd for the most part.

Old Post 03-12-11 05:42 #
NaturalTvventy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
sirjuddington
Slade doesn't mean what it used to


Posts: 1405
Registered: 05-00


Hmm, so does it only lock up when opening some kind of file dialog? Or can it also happen just randomly (ie while just scrolling through entries or editing text, etc)

Old Post 03-13-11 13:58 #
sirjuddington is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
TendaMonsta
Member


Posts: 288
Registered: 08-09



SlayeR said:
Hmm, so does it only lock up when opening some kind of file dialog? Or can it also happen just randomly (ie while just scrolling through entries or editing text, etc)


For the most part the crash seems to happen when another window shows up i.e. Import lump from file, export lump, import lump, etc...Sometimes if I'm exporting it never crashes at all until I bring another window into focus then switch back to Slade. Now I can't speak for everyone so, this is how the crashes happen on my OS.

It has never happened while saving or bringing up other tabs in slade.

__________________
My DemoPage

Old Post 03-13-11 15:41 #
TendaMonsta is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
zZaRDoZz
Junior Member


Posts: 114
Registered: 09-09


I take it that running slade3 in compatibility mode makes no difference?

Old Post 03-16-11 15:19 #
zZaRDoZz is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11112
Registered: 07-07


Compatibility mode is for running software designed for older versions of Windows. SLADE3 is developed on Windows Vista and Windows 7, so compatibility mode wouldn't solve anything and might even cause problems.


Likewise, running as administrator is not needed. Those are the two approaches that are generally taken as "one-size-fits-all" magic method to make everything works, even when it's not the case. So, just to be clear, you need neither compatibility mode nor running as administrator, any problem you currently have with SLADE 3 will not go away if you try those.

Old Post 03-16-11 15:23 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
disentomb
Banned


Posts: 65
Registered: 01-11


I use Vista, and out of the total amount of time Ive used SLADE3, it has only frozen once.. Ive used it for almost a year now.

Old Post 03-16-11 20:56 #
disentomb is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
LigH
Forum Regular


Posts: 683
Registered: 11-10


Recently I found the DRD Team SVN Builds of SLADE 3. I was able to run SLADE 3 r1378 (according to the About dialog) or r1379 (according to the archive name) once without issues on Windows 7 64-bit; but the next time, the welcome page did not appear, the button bar did not show any buttons, and when I hovered the mouse over it, one button background highlighted, then the task started consuming memory until it filled up 2 GB and caused an unhandled exception.

Running it as Administrator worked well.

Old Post 01-25-13 09:54 #
LigH is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
LigH
Forum Regular


Posts: 683
Registered: 11-10


^ my reason was solved: It had no access rights to the TEMP folder.

Old Post 01-30-13 13:16 #
LigH is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 02:55. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > SLADE3 freezes randomly in Windows 7

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.