Mancubus
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > In dire need of help! (SLOTH Builder 2)
 
Author
All times are GMT. The time now is 02:16. Post New Thread    Post A Reply
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


hello everyone, hope youre all doing well...to make a long story short, i became reattracted (probably even not a word) to the whole doom thing with a devotion to map like a pro and learn scripting and decorate the way i know my abc's...i thought this was the right forum to post this in so if it is not, please forgive me..

so when i open my doom builder 2 for the first time in a few months and it gave me the "Doom builder 2 has stopped working" issue. i thought "no problem"...so i go to doombuilder.com and download the most updated version and install it,and it worked...but here's where the problem is. for some reason everything is IMMENSELY slow..it took me about 20 minutes just to add resource wads...i know it's not my computer because it's as fast as a rocket and all other programs work just fine. i currently downloaded maxed's "gzdoom builder" because it looks damn amazing to work with, but same problem... i cleaned out the junk on my pc, defragged my comp TWICE and did a few malawarebytes scans..my comp moves at the speed of light but same problem with my beloved doom builder = (

any help or suggestions would be GREATLY apreciatted, i intend to contribute (once i'm worthy enough) to Doomworld.. thank you all very much

Old Post 10-01-12 08:12 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
sgt dopey
Member


Posts: 518
Registered: 09-11


Doom Builder 2 can take a while to start up if you add a whole heap of new map configurations

Old Post 10-01-12 08:43 #
sgt dopey is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


thank you for your response...yes of course but the thing is i am familiar with doom builder 2 and used it in the past... the second i opened it after downloading the latest installment i noticed it was just moving slowly in general, late click responses slow menus etc...right clicking a linedef/sector or thing takes about 30-45 seconds,visual mode is just impossible, the whole thing is just slow and choppy. tried a few other older versions, SVN's...now using GZDoom builder...all same result. gzdoom works perfectly fine all my other programs are fine. i tried everything and the whole thing is really upsetting me, as if it didn't take long enough to build a level = \

Old Post 10-01-12 09:03 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8768
Registered: 01-08


Might be a .NET issue. Doom Builder 2 recently stopped running on my laptop and the most likely suspect my research turned up was some Visual C+ 2008 runtime files. Uninstalling the runtime files and repairing .NET didn't work, re-installing Windows did. I hate .NET. :(

Have you checked out the Development forums, that's the best place to log a bug report.

Old Post 10-01-12 09:26 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


hi thank you very much for your input... and WOW that just sucks..i'm not even good with technical stuff like that but that just sounds like a nightmare..and yes youre right i shouldve gone to the deveelopment forums and not wasted your time here..wow the thought of reinstalling windows is just terrifying..can you even do that without losing all your damn files?

Old Post 10-01-12 09:34 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8768
Registered: 01-08


If it was my desktop I would have restored a recent backup. I don't keep anything precious on the laptop, so apart from time wasted re-installing stuff nothing's lost. Suppose what I should do is make a disk image once everything is setup to my satisfaction.

Old Post 10-01-12 10:06 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Pottus
Forum Regular


Posts: 802
Registered: 07-09


Try downloading this one.

http://svn.drdteam.org/doombuilder2...02%20(r1604).7z

Old Post 10-01-12 18:41 #
Pottus is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 882
Registered: 11-02


upload Builder.log for perusal

and/or read Installing Doombuilder2 which has some troubleshooting tips.

Old Post 10-01-12 20:24 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10



Pottus said:
Try downloading this one.

http://svn.drdteam.org/doombuilder2...02%20(r1604).7z



unfortunately yes i tried the svn builds and all same result...it can't be a doom builder problem alone because i downloaded too many different versions to get the same result...it's gotta be some doom builder - windows conflict but i have no idea where to begin..


Kappes Buur said:
upload Builder.log for perusal

and/or read Installing Doombuilder2 which has some troubleshooting tips.



i didn't even think of that one, hopefully the problem will be shown in there..

http://freetexthost.com/5ca4xudkxv

thank you for your replies

Old Post 10-01-12 21:46 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 882
Registered: 11-02


Everything looks as it should be.

From a historical point of view, there was a problem in 1.12f with a severe slowdown when
too many resources were loaded. But that was promptly fixed in 1.12g. However, it might
be advisable to also ask in the GZDoom Builder thread on the ZDoom Editing forum to what
extend it was fixed.

The only other thing which might slow down everything is the magnitude of WARNING: Unable to find the DECORATE class ..... warnings.

Have you tried a simple map without all the resources, eg DOOM2 MAP01? Does that slow down as well?

Try to run r1622:
http://svn.drdteam.org/doombuilder2-gzdb/
Maybe it will work better for you.

Old Post 10-01-12 22:32 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


i tried every single one of those versions and it's all the same shit =(
it's not a GZDoom builder problem..it happens with every version..and it's even beore i load anything the whole program itself is just slow and choppy, way before getting to resource files..for example..like you said if i wanted to open doom2.wad alone, as soon as opening doom builder, clicking the 'open map' on the top left takes about 45 seconds or the folder to open, the whole program in general..it just looks like a dead end i guess i'm going to have to attempt to reinstall windows as Grey Ghost said.. i just don't know how to do that without the CD or more importantly without losing my files. thank you all very much for your time

Last edited by M5 NYC on 10-01-12 at 23:46

Old Post 10-01-12 23:40 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 882
Registered: 11-02


Grasping at straws now .....

Which version of SlimDX is on your computer?

Old Post 10-02-12 01:00 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


sorry forgive me..but what is SlimDX? i have never heard of it before and i don't think i have it on my computer...should i download it?

Old Post 10-02-12 09:43 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8768
Registered: 01-08


SlimDX is a DirectX API for .NET which should have installed along with Doom Builder 2, check Programs and Settings (or Add/Remove Programs if you're using XP) in the Control Panel to find the version number.

Old Post 10-02-12 09:59 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


oh yes thank you i found it now...there are 2 versions:

SlimDX Redistributable for .NET 2.0 (September 2011)
SlimDX Runtime .NET 2.0 (January 2012)

Old Post 10-02-12 11:06 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8768
Registered: 01-08


Try highlighting the entries. If there's a "Click here for support information" option, click on that to get the version numbers for both programs. Probably 2.0.13.43 for the Runtime, don't know about the other.

Old Post 10-02-12 11:44 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


i think i made a huge mistake, i uninstalled them to try and reinstall them and now windows install won't let me install them...is there any other way for me to get them again? i apologize and thank you for your effort

Old Post 10-02-12 12:42 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8768
Registered: 01-08


Which version of Windows are you using?

EDIT - What exactly did you uninstall?

Last edited by GreyGhost on 10-02-12 at 13:34

Old Post 10-02-12 13:13 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
M5 NYC
Warming Up


Posts: 13
Registered: 09-10


SlimDX Redistributable for .NET 2.0 (September 2011)
SlimDX Runtime .NET 2.0 (January 2012)

i am using Windows 7, i uninstalled both of these in attempt to reinstall, so i downloaded it slimdx.com but windows won't let me install 'msi' files and i have no idea why...it stops half way through "There was a problem with this Windows' installer package. A program required for this install to complete could not be run, contact your support personnel or package vender"

i dug myself deeper into the hole like a moron thank you so much for all your help

Old Post 10-02-12 20:32 #
M5 NYC is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 882
Registered: 11-02


After opening DB2 or GZDB, check Task Manager, what processes are running. Perhaps some process is hogging all the resources.

Last edited by Kappes Buur on 10-07-12 at 22:07

Old Post 10-03-12 00:21 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 02:16. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > In dire need of help! (SLOTH Builder 2)

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.