Demon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Doombuilder constantly auto aligning textures? [SOLVED]
 
Author
All times are GMT. The time now is 11:18. Post New Thread    Post A Reply
Krispy
Senior Member


Posts: 1184
Registered: 02-12


I noticed that while I was working in 3D mode, Doombuilder kept re-aligning the textures that wrapped around a pillar I was working on, so that the inevitable misalignment somewhere on that post kept shifting around it. In the 'undo/redo' tab, I saw like 20 entries that said "Auto-align textures." What causes this and how can I avoid it?

Last edited by Krispy on 10-28-12 at 17:51

Old Post 10-28-12 05:05 #
Krispy is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Xaser
Forum Staple


Posts: 2590
Registered: 07-03


What's probably happening is that when you split a line, DB2 automatically adjusts offsets so that the texture continues seamlessly. It's great when you're drawing lines over other lines, but if you're splitting lines so that you can drag the vertices to a new spot (like I do constantly :P ), it can be a little irksome.

Still better to have it than not, of course. It just takes some elbow grease at that point.

[EDIT] Re-reading your post, seems we're talking about entirely different things. My bad -- in that case, no clue. It shouldn't do any sort of actual auto-alignment without you explicitly telling it to.

Old Post 10-28-12 06:33 #
Xaser is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
esselfortium
A Major Doomworld Concern


Posts: 6515
Registered: 01-02


There's an option in recent versions that allows you to disable the seamless alignment when manually inserting a vertex. It'll still do it when vertices are automatically added, like when you draw a line that overlaps other lines.

edit: Serves me right for only reading Xaser's reply. Um... hmm. Sounds like you might have the autoalign command bound to one of your movement keys. Try changing it to something else to avoid that. I use ctrl-a for autoalign and ctrl-d for vertical autoalign, so that they don't conflict with my WASD setup for movement.

Old Post 10-28-12 06:36 #
esselfortium is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Pottus
Forum Regular


Posts: 797
Registered: 07-09


I only use forward to move around and the mouse, you guys actually use all those other keys? I think that would drive me bananas!

Old Post 10-28-12 07:20 #
Pottus is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Krispy
Senior Member


Posts: 1184
Registered: 02-12


Yeah it seems like just viewing the column from a different angle (or moving around it) causes it to auto-align. I'm not hitting any key to adjust it or adding vertexes.

EDIT: Yup, Essel takes the cake. I recently reinstalled DB and the movement keys were bound the wrong way. Thanks!

Old Post 10-28-12 17:46 #
Krispy is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Rayzik
Member


Posts: 367
Registered: 10-11


This reminds me about an issue I was having that sounds similar. Have you changed your controls to "WASD"? DB2's default align key is "A" is I recall correctly.

EDIT: Ninja'ed by OP. Guess that's not the issue then.

Old Post 10-28-12 17:48 #
Rayzik is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 11:18. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Doombuilder constantly auto aligning textures? [SOLVED]

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.