Sarge
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > need help witth weird bug in my map - fixed
 
Author
All times are GMT. The time now is 21:44. Post New Thread    Post A Reply
mouldy
Senior Member


Posts: 1654
Registered: 02-12


I was testing my eye.wad map in prboom+ and found a door doesn't open from one direction for some reason, can someone help me test this out?

This is the latest version:
http://www.mediafire.com/?5ol3957kuzfclla

The door is sector 1515. The bug I get is that it doesn't open from line 5328, and yet if I go around the map and open it from the other side it works fine - and after its been opened from the back it then opens fine from the front as well?!

This has me scratching my head, it worked fine in older versions of the map...

Can anyone figure this out?

Edit: I figured it out, seems there's a linedef infront of the door which has a walkover action and it stops the door functioning for some reason. Anyone care to explain why that might be?

Last edited by mouldy on 02-08-13 at 02:34

Old Post 02-08-13 02:08 #
mouldy is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
wesleyjohnson
Senior Member


Posts: 1056
Registered: 04-09


Standard behavior, well documented.
Engines look for an action linedef in the direction of player facing, starting from the center of the player.
Finding one they stop looking and try to activate it, even if it is a walkover. A walkover is not triggered by pushing so no action.
Any trigger linedef within 32 of a door will create problems, within 13 of a door will totally block it being opened by push (numbers approximate, depending on your definition of problem).
There is a special push-thru flag for linedefs in Boom to get around this.

Old Post 02-08-13 04:55 #
wesleyjohnson is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
mouldy
Senior Member


Posts: 1654
Registered: 02-12


cool, cheers for the info!

Old Post 02-08-13 11:12 #
mouldy is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 21:44. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > need help witth weird bug in my map - fixed

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.