Demon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Unstable polygon textures with 3D models.
 
Author
All times are GMT. The time now is 04:00. Post New Thread    Post A Reply
MetroidJunkie
Junior Member


Posts: 122
Registered: 11-07


When I export to MD2, it doesn't seem too stable within GZDoom. So far, the worst offender is a holy water bottle I attempted to have as an item;

http://i50.tinypic.com/b8a3h0.png

At first, I thought it could be the fault of Blender's exporter but I imported the MD2 file back in and it looks fine.

http://i50.tinypic.com/2wdtvl3.png

I think it may have something to do with the UV Mapping (I tend to move around the verteces in the UV Map so there aren't different sections bleeding through where they're not supposed to) but I tried leaving it unmodified and it still gave me problems. If it helps, here's the MD2 file and UV Map;

http://www.filedropper.com/holywater_1

Old Post 02-22-13 01:02 #
MetroidJunkie is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
D00Med
Banned


Posts: 17
Registered: 02-13


So yes you might just have to redo the model, or logically...REINSTALL!

__________________
-----DOOOOOOOOOOOOOOOOOOOOOMED!------

Old Post 02-23-13 02:03 #
D00Med is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
MetroidJunkie
Junior Member


Posts: 122
Registered: 11-07



D00Med said:
So yes you might just have to redo the model, or logically...REINSTALL!


Reinstall what, Blender? Because I tried Skulltag and it was giving me the same crap. Also, what's wrong with the model that I have to redo it? It seems to be consistently glitching all my models so redoing it probably won't help.

http://i50.tinypic.com/33jtiip.png

Last edited by MetroidJunkie on 02-23-13 at 03:12

Old Post 02-23-13 03:03 #
MetroidJunkie is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Pottus
Forum Regular


Posts: 802
Registered: 07-09


Looks good in MAX

http://img10.imageshack.us/img10/7120/holywateru.png

Re-exported and brought into game

http://img577.imageshack.us/img577/...om201302222.png

Seems MAX does a much better job exporting.

Some observations:
- Eliminate your NGONS
- You can reduce model size by not including 30 useless animation frames
- Use MAX!!!!!

Old Post 02-23-13 03:58 #
Pottus is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
MetroidJunkie
Junior Member


Posts: 122
Registered: 11-07


I don't know, is there a freebie alternative that can get the job done? If it's able to export without any problems, then I can still make the models in Blender and just filter through.

http://www.moddb.com/games/quake-2/...del-editor-v090

Strike that, the center of origin seems to have corrected itself. I can just filter models through this. =D

Last edited by MetroidJunkie on 02-23-13 at 04:47

Old Post 02-23-13 04:24 #
MetroidJunkie is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Pottus
Forum Regular


Posts: 802
Registered: 07-09


I'm not sure why your exporter was giving you trouble but as long as what your doing now works you should be good, I hope my efforts set you in the right direction.

Old Post 02-24-13 03:27 #
Pottus is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
MetroidJunkie
Junior Member


Posts: 122
Registered: 11-07



Pottus said:
I'm not sure why your exporter was giving you trouble but as long as what your doing now works you should be good, I hope my efforts set you in the right direction.


Thanks for identifying the problem. This Quake 2 modeler seems to be just as effective at fixing the problem as MAX. I always go for freebie programs if I can get away with it.

http://i46.tinypic.com/kbd8q9.png

I don't get why Blender produces glitched models within Doom but not within other 3D modeling programs, maybe Doom and Blender just don't get along for whatever reason.

Last edited by MetroidJunkie on 02-24-13 at 05:44

Old Post 02-24-13 05:31 #
MetroidJunkie is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 04:00. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Unstable polygon textures with 3D models.

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.