Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > wad not working with custom weapons
 
Author
All times are GMT. The time now is 08:45. Post New Thread    Post A Reply
invictius
Member


Posts: 562
Registered: 03-06


This wad: http://www.doomworld.com/idgames/index.php?id=16631
doesn't seem to want to allow this custom weapon: http://www.realm667.com/index.php/c...nuclear-missile

to load (other custom weapons also). I'm not trying to use it as a pickup, just with idkfa or give all in the console. Could the wad have "barred" non-skulltag weapons from being loaded with it?

Old Post 04-01-13 18:26 #
invictius is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Lippeth
Junior Member


Posts: 157
Registered: 10-12


There's nothing wrong with either wad. Realm667 weapons are just resources for you to integrate into your own work. All you need to do is assign it to a weapon slot in it's DECORATE lump. Use something like Slade 3 to do this.

Basically paste this:

Weapon.SlotNumber 7

(or whatever number you want to assign it to) somewhere between the ACTOR definition and the animation states.

Old Post 04-09-13 19:56 #
Lippeth is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 860
Registered: 11-02



Lippeth said:

Basically paste this:

Weapon.SlotNumber 7


There is no need to do this, because in KEYCONF it is set up as default to slot 7.

To make this work, all you have to do is copy all lumps from nuclearmissile.wad
into your map and give the actor a DoomEd number, eg:

ACTOR NuclearMissileLauncher : Weapon 15555

and not to forget the ammo

ACTOR NuclearMissile : Ammo 15556

Last edited by Kappes Buur on 04-10-13 at 00:32

Old Post 04-10-13 00:24 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 08:45. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > wad not working with custom weapons

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.