Baron of Hell
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > No Strife sprites (things) in Doom Builder
 
Author
All times are GMT. The time now is 06:45. Post New Thread    Post A Reply
Inq
Warming Up


Posts: 20
Registered: 07-11


I've tried Strife modding Strife today - and the problem is the sprites just don't appear in the game world. It can be already seen in the Doom Builder (empty boxes where they should be displayed) - but I thought it's just a visual issue. When running test they simply don't exist like they were not put there.

There is no such issue while working with the original Doom WAD.

Strife alone works just fine.

Last edited by Inq on 04-21-13 at 18:38

Old Post 04-21-13 11:12 #
Inq is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
scifista42
Senior Member


Posts: 2341
Registered: 05-12


1. Check if the sprites are between SS_START and SS_END markers.
2. Check the format of sprites. I saw that there's a format named "Strife", maybe you need to use it. Or maybe you mustn't use it. I don't know, never modded for Strife.

EDIT: Just now I realised - I probably misunderstood completely, I assumed you're using custom sprites, sorry if you mean otherwise.

Old Post 04-21-13 12:13 #
scifista42 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Inq
Warming Up


Posts: 20
Registered: 07-11


I was trying to use default Strife sprites (npcs, weapon, decoration...).

As I mentioned, they do appear in game (Strife run with zDoom and Strife alone).

For what I remember, I had the same problem when I was using WAD file from the original CD (currently I'm using one downloaded from the
Internet).

edit:
Since sprites work with in game but not in tests I changed the thread name to be more descriptive.
I'll try to run the modified WAD with zDoom and see does it work.
Even if it will do, that won't solve the testing problem.

Last edited by Inq on 04-21-13 at 12:52

Old Post 04-21-13 12:44 #
Inq is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11225
Registered: 07-07


Probably just a question of whoever did the configuration file being lazy and not looking up sprite names for the various actors.

Have you tried in GZDB or plain old DB2? They don't have the same config files.

Old Post 04-21-13 14:06 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 6088
Registered: 08-00


I am pretty sure he's saying the things he placed don't show up in the game, either.

To avoid confusion, if you mean items that are placed into the map, use the word "things" and not "sprites." In DOOM parlance, a moving or stationary object is a "thing", while the graphic it displays is a sprite.

Old Post 04-21-13 16:47 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Inq
Warming Up


Posts: 20
Registered: 07-11


"Have you tried in GZDB or plain old DB2? They don't have the same config files".
DB2

I tried now to switch configuration from zDoom's Strife in Hexen format I was using to simply Strife. And: no things present in the visual mode - but things present in test.

Still, the thing is, I'd like to use all features zDoom provides. Well, at least some of them.

Last edited by Inq on 04-21-13 at 19:12

Old Post 04-21-13 18:52 #
Inq is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11225
Registered: 07-07


Check the flags on the things. Most importantly, are they flagged to appear at any skill at all?

Old Post 04-21-13 18:57 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 882
Registered: 11-02



Inq said:
I've tried Strife modding Strife today - and the problem is the sprites just don't appear in the game world. It can be already seen in the Doom Builder (empty boxes where they should be displayed) - but I thought it's just a visual issue. When running test they simply don't exist like they were not put there.

There is no such issue while working with the original Doom WAD.

Strife alone works just fine.



As Gez already hinted at, it has to do with somebody having to go through some of the config files and adding in the sprite names, etc.

For example, in the Strife config file Strife_things.cfg, you have this:

code:
3005 { title = "Crusader"; width = 40; }


change it to this:
code:
3005 { title = "Crusader"; width = 40; sprite = "ROB2A2"; height = 64; }


and the Crusader sprite will be visible in Doombuilder2 or GZDoombuilder.

Old Post 04-21-13 21:27 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
Inq
Warming Up


Posts: 20
Registered: 07-11


http://www.doomworld.com/vb/doom-ed...on-testing-map/
I found this thread and a solution in it.

What I did wrong: I didn't check the singleplayer flag.
(as Gez was suggesting)
(but then - why start marker works without it?)
Somehow I naively thought that was too obvious to be a matter at all.
Sorry for taking your time.

Old Post 04-22-13 09:14 #
Inq is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11225
Registered: 07-07



Inq said:
(but then - why start marker works without it?)


Player starts are handled differently from all other things; and notably they ignore skill flags as well as single/multiplayer flags.

Old Post 04-22-13 10:49 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 06:45. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > No Strife sprites (things) in Doom Builder

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.