Ouchface
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > scripting, acs terminate does nothing?
 
Author
All times are GMT. The time now is 20:55. Post New Thread    Post A Reply
96riv
Newbie


Posts: 7
Registered: 01-13


I'm trying to make a sector in which there is a glowing red light, and then I flip a switch and everything goes back to normal, but when I flip the switch, nothing happens. I've fiddled with all kinds of commands, all to no avail. The script below is far from what I started with. What kind of command can I use? Here is the script:

script 2 (void)
{
sector_setcolor (2, 255, 15, 15);
Light_Glow (2, 220, 120, 24);
}


script 4 Open
{
ACS_Execute (2, 0);
}

script 5 (void)
{
ACS_Terminate (2, 0);
Light_ChangeToValue (2, 192);
}

Old Post 09-28-13 07:16 #
96riv is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Phml
Forum Staple


Posts: 3373
Registered: 06-09


I'm guessing you can't stop script 2 because it isn't running at the time, the two effects are applied at first execution and the script is done. Perhaps in script 5 you could set a new Light_Glow to 192 min 192 max and a new sector color to whatever is the norm.

Old Post 09-28-13 12:09 #
Phml is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Kappes Buur
Forum Regular


Posts: 880
Registered: 11-02



Phml said:
I'm guessing you can't stop script 2 because it isn't running at the time, .....

Exactly


96riv said:
.... but when I flip the switch, nothing happens. .


You could try something like this
code:
#include "zcommon.acs" script 2 (void) // cross a linedef { Sector_SetColor ( 2, 255, 15, 15 ); Light_Glow ( 2, 220, 120, 48 ); } script 3 (void) // activate switch { Sector_SetColor ( 2, 255, 255, 255 ); Light_Stop ( 2 ); Light_ChangeToValue (2, 192); }

Old Post 09-28-13 13:21 #
Kappes Buur is offline Profile || Blog || Search || Add Buddy IP || Edit/Delete || Quote
96riv
Newbie


Posts: 7
Registered: 01-13


That's worked, thanks! I had a different layout originally, and when that didn't work, I screwed it up beyond recognition.

Old Post 09-28-13 22:56 #
96riv is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 20:55. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > scripting, acs terminate does nothing?

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.