Cyberdemon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Scripting problems. (I thought I was done)
 
Author
All times are GMT. The time now is 18:46. Post New Thread    Post A Reply
dachauncinator
Mini-Member


Posts: 70
Registered: 12-12


[SOLVED]
Was originally a texture problem thread, but why make a whole new one?
Anyways, weapon scripting problem, Doesn't function at all.
code:
Actor BlasterRifle : Shotgun 21000 { Weapon.SelectionOrder 350 Inventory.PickupSound "rifle/pu" Weapon.AmmoGive 12 Weapon.AmmoUse 1 Weapon.SlotNumber 3 AttackSound "rifle/fire" States { Spawn: RIFL C -1 Loop Ready: RIFL A 1 A_WeaponReady Loop Deselect: RIFL A 1 A_Lower Loop Select: RIFL A 1 A_Raise Loop Fire: RIFL A 2 RIFL B 2 A_FireBullets (9,9,1,5,"BulletPuff",FBF_USEAMMO) RIFL B 7 A_GunFlash RIFL B 2 A_CheckReload RIFL A 2 A_ReFire goto Ready } }

To note, I can pick up ONLY one of these, and when I fire, the weapon is put away.

Last edited by dachauncinator on 12-05-13 at 04:54

Old Post 12-05-13 01:07 #
dachauncinator is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1090
Registered: 11-09


No, they shouldn't be fine. You need a matching palette/colormap pair, the stock Doom colormap won't work with a completely new palette.

Old Post 12-05-13 01:33 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10996
Registered: 07-07


Select the palette, and then go Palette->Generate colormaps. Save and try again. Should be better.

Old Post 12-05-13 01:53 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
dachauncinator
Mini-Member


Posts: 70
Registered: 12-12



Da Werecat said:
No, they shouldn't be fine. You need a matching palette/colormap pair, the stock Doom colormap won't work with a completely new palette.

Understandable. I was just trying anything at that point.


Gez said:
Select the palette, and then go Palette->Generate colormaps. Save and try again. Should be better.

My version of SLADE didn't have that option so I had to go and update, and it worked! Thanks a bunch man.

Old Post 12-05-13 02:13 #
dachauncinator is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10996
Registered: 07-07


Okay, if you reuse a topic, you shouldn't edit out your original post because it makes the following posters look like complete doofus who reply to a question you're not asking. :p

Old Post 12-05-13 09:58 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
dachauncinator
Mini-Member


Posts: 70
Registered: 12-12



Gez said:
Okay, if you reuse a topic, you shouldn't edit out your original post because it makes the following posters look like complete doofus who reply to a question you're not asking. :p
That's why I stated that there was a texture problem in the first line.
I was going to just spoiler the orignal post but I remembered these forums don't have the drop down spoilers so I just left it out to conserve space.

Old Post 12-05-13 12:23 #
dachauncinator is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 18:46. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Scripting problems. (I thought I was done)

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.