Reaper Grimm
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Icon of sin in different level
 
Author
All times are GMT. The time now is 21:20. Post New Thread    Post A Reply
djvero
Mini-Member


Posts: 65
Registered: 04-10


Hello,

is it possible to have the Icon Of Sin working in a different level? I wanted to have the IOS in map17 for example, but when I build it it doesn't "wake up", it only does so when I build it in map30.

Thanks in advance

Old Post 01-11-14 19:09 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Spammer


Posts: 5617
Registered: 04-07


It should be waking up, you're doing something wrong. However, note that on maps other than map30 the monsters can't telefrag each other, so most likely you will get ugly piles of monsters stuck in each other (see Jenesis map28).

Old Post 01-11-14 19:20 #
Memfis is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


That's weird, coz when I copy-paste everything to map30 it does wake up whereas in map17 it doesn't...

Old Post 01-11-14 19:22 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Spammer


Posts: 5617
Registered: 04-07


Maybe when you're copy-pasting the difficulty flags get erased for some reason and so the thing simply doesn't appear on the map?
Can you post that map perhaps?

Old Post 01-11-14 19:25 #
Memfis is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


Well, it's part of a megaWAD I'm working on, but when I copy-paste it to MAP17 in a newly named WAD (test for example) for you to take a look at it it somehow works. However, in the megaWAD it doesn't, weird ???

Old Post 01-11-14 19:32 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


Instead of copy-pasting stuff into a new map, open the WAD in your favorite lump editor and change the level lump to MAP17 instead of MAP30. That should ensure nothing changes in the map.

Old Post 01-11-14 19:41 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


Lump editor?

Anyway, it's not like I want to copy-paste everything to a different level, I just did that to try and see if what I built in Map17 worked on Map30. And then I came to the conclusion it worked on Map30, but NOT on map17, in which I initially built the Icon of Sin structure.

Old Post 01-11-14 19:54 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


Hmm....I just figured out it doesn't work on any map in my megaWAD, not even Map30....

Old Post 01-11-14 20:02 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02



djvero said:
Lump editor?
Like SLADE or XWE.

Keep in mind the boss consists of the Romero head plus the spots where the launched monsters will spawn, not just one item.

Old Post 01-11-14 20:04 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11119
Registered: 07-07


Three different things, actually:

The Romero head on a stick is the weak point, the thing that can be damaged and destroyed to end the level. But it has no other function.

The spawn cubes are shot by an invisible thing (which is what sees the player and says the ominous-sounding backward voice clip). And finally, there are the spawn cube targets.

If you forget to place the boss shooter, then it will never "wake up".

http://doomwiki.org/wiki/Final_boss

Old Post 01-11-14 20:44 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Obsidian
Forum Staple


Posts: 2549
Registered: 05-12


On a side note, it's possible to have a working Icon in Boom on any level if you use scrolling floors, therefore preventing stuck monsters.

Old Post 01-11-14 21:16 #
Obsidian is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Dragonsbrethren
Senior Member


Posts: 2442
Registered: 03-09


Doesn't Boom already fix the telefrag problem, though? Or does that only apply to non-spawned monsters telefragging on MAP30?

Old Post 01-11-14 22:46 #
Dragonsbrethren is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10



Gez said:
Three different things, actually:

The Romero head on a stick is the weak point, the thing that can be damaged and destroyed to end the level. But it has no other function.

The spawn cubes are shot by an invisible thing (which is what sees the player and says the ominous-sounding backward voice clip). And finally, there are the spawn cube targets.

If you forget to place the boss shooter, then it will never "wake up".

http://doomwiki.org/wiki/Final_boss



Yea I know. I studied Map30 (doom2.wad) thoroughly, but it still doesn't wake up in my megaWAD. I can kill it - meaning I can shoot the Romero head so that it screams - but it doesn't wake up and spawn any monsters. The strange thing is that it does work when I copy-paste the whole thing to any newly named WAD

Old Post 01-12-14 11:30 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11119
Registered: 07-07


All I can say is that if you don't hear the backward speech and monsters are being spawned, you are missing the boss shooter thing -- or placing it somewhere it cannot see the player.

Old Post 01-12-14 11:44 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


No that's not it, because it does work when I open up a new map and copy-paste it to there. It just doesn't work in my megaWAD...

Old Post 01-12-14 11:55 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8691
Registered: 01-08


Which source port are you testing with?

Old Post 01-12-14 12:06 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


Zdoom

Old Post 01-12-14 12:09 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


OK I figured it out!! I added some new monsters to my WAD and one of them, the Archon Of Hell, is listed in the DECORATE file as "ACTOR ArchonOfHell : BaronOfHell". So it probably conflicts with the baron of hell because when I remove the Archon the Icon wakes up and starts spawning monsters.

Thanks to everyone who tried to help though

Old Post 01-12-14 17:12 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11119
Registered: 07-07


That shouldn't be the reason, actually. But it's excessively hard to diagnose the real issue just from what you've said. It'd be better if you uploaded your stuff somewhere so that people can take a look and find out the actual problem.

Old Post 01-12-14 17:16 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
djvero
Mini-Member


Posts: 65
Registered: 04-10


Yea well I'm not too keen on posting unfinished work. Not that anybody would copy or steal my junk, but still lol.

Besides, my problem seems to be fixed now. What I could do however, is to copy my material to a new WAD, call it "test" and then upload it for you to take a look at.

Old Post 01-12-14 18:04 #
djvero is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 21:20. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Icon of sin in different level

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.