Ouchface
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Missing Sky Textures, and Off textures [WAD included]
 
Author
All times are GMT. The time now is 04:03. Post New Thread    Post A Reply
Kontra Kommando
Let's attack aggressively


Posts: 1349
Registered: 02-13


Link:

http://www.mediafire.com/download/k...oom++BETA+2.zip

First off, Id like to mention that I'm showing my gratitude for those that have helped me with previous technical questions. I have included your names in the special thanks to section, in the read me text and credit graphic. I apologize if I had left anyone out; PM me if youd like.

There are two significant issues with my WAD that I would like to address. However, everything that I have tired does not seem to work.

Issue 1:

After I uploaded my custom patches to replace the hell patches, the sky of episodes 1,2, and 3 have gone black. In a way it sort of helps to remove the hellish themes for the 3rd level, but I would much rather upload my own sky textures if possible. I understand sky replacement for the first doom is tricky. I don't understand why the sky is broken, but I would like to get that corrected. Moreover, I want to replace them with my own skys.

Issue 2:

I replaced the Hell themed switches with the green tech switches. However, despite my efforts to fix the alignment in Slade, the switches remain in the same exact place. Moreover, there are other switches, that I have not altered whatsoever, that are off. I dont understand what the problem is here. E3M1s doors are a good point of reference for this issue.

Thanks in advance for the help; I will include your names in beta 2.1

Old Post 05-15-14 15:39 #
Kontra Kommando is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8683
Registered: 01-08


First problem I can see is that you're missing a TEXTURE2 lump, which is where Ultimate Doom's SKY2 & SKY3 textures are defined. I look at the switches in the morning.

Old Post 05-15-14 16:11 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
plums
Senior Member


Posts: 1925
Registered: 08-13


First of all, is this meant to be for Doom 1? Because it looks like your TEXTURE1/PNAMES entries were built for Doom 2.

How are you trying to change the alignment on the switches?

I think you are probably not working with the TEXTUREx lists, which is what you should be doing. In SLADE go to Archive > Texture Editor and then you'll get a list of all the textures that Doom has to work with. If you're making a wad for Doom 1, you should have two texture lists, TEXTURE1 and TEXTURE2. In this case you only have one.

Anyhow to replace the sky the proper way, edit the SKYx textures (x being 1 to 4, for episodes 1 to 4) to have the right patches. If you want to do it the easy way, add patches named SKYx between PP_START and PP_END that are 256x128.

For Doom 2, the patches are named RSKYx, but the textures are still names SKYx.

Old Post 05-15-14 16:16 #
plums is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8683
Registered: 01-08


Come to think of it, the Hell-themed switches are also defined in TEXTURE2 in the IWAD. Replacing that lump with one in your PWAD (even if it only contains one texture definition) should fix both issues.

Old Post 05-15-14 16:28 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kontra Kommando
Let's attack aggressively


Posts: 1349
Registered: 02-13


http://www.mediafire.com/download/f...TC+BETA+2.1.wad

Attached is a link to the updated WAD.

I have deleted the old texture 1 and pnames, and copy and pasted a new tex 1 tex 2 and pnames. The sky was successfully restored, and I believe most of the alignment problems were solved. However, the replacement switches are still off. I assume, I may have to go in and fix them individually. I think the off-alignment is due to the fact the replacement switch is a different size from the one it is replacing.

Old Post 05-16-14 00:03 #
Kontra Kommando is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8683
Registered: 01-08


Yep, the replacement patches will need re-centering in the texture lump editor. Depending on what it's replacing, the little tech green switch will be sitting at 20x73 or 20x84.

Old Post 05-16-14 04:00 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 04:03. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Missing Sky Textures, and Off textures [WAD included]

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.