Doom Comic
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Level from scratch in Deep.
 
Author
All times are GMT. The time now is 22:47. Post New Thread    Post A Reply
Lüt
Administrator


Posts: 9170
Registered: 05-00


OK, this is my first time trying this. Why do I have to make the sectors weird shapes to get them to work right? Is this some sort of issue with the prefabs? Like, whenever I make a rectangular sector attached to anything, it adds a 4th line, no matter if there is already a 4th line or not. Then it breaks it into 2 sectors and I gotta redefine those. BUT if I draw a triangle in the same situation, and expand it into a rectangle later on, it works fine.

Old Post 06-12-01 21:35 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


Gah, this is turning into a disaster zone 6 sectors in.

Old Post 06-12-01 21:57 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


OK, I used the triangle trick again for another wall indent and that fixed part of the problem of making a torchholder indentation in the wall... this isn't too bad but there's more tricks to getting this to work than there is avoiding crashes in WadEd.

Old Post 06-12-01 22:04 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


This is one hell of a crackpot program. Adding a sector in between two buildings caused the entire first buiding to become a new sector, but not the other building or the sector they were both in. How does that one work?

Old Post 06-12-01 22:31 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DeePTeam
Junior Member


Posts: 127
Registered: 05-00


Your posts are a bit confusing. Follow the basics as shown here:
http://www.sbsoftware.com/onlinehelp/deeptutorial_quick_start.htm

"Why do I have to make the sectors weird shapes to get them to work right?"

You don't. You can draw anything you like. Review the tutorial and view the interactive demo. It's pretty straight forward.

"Is this some sort of issue with the prefabs? Like, whenever I make a rectangular sector attached to anything, it adds a 4th line"

What 4th line? Nothing is added to prefabs. I can only assume you aren't merging lines correctly. If merging lines, they have to be ON TOP of one another. It's possible to get only 1 vertex, but then just drag the other vertex you missed and all better. Your grid and snap option affect how Prefabs are drawn and how they merge. Could be you have the grid set to high (and snap on). Angled areas in particular are better done with snap off (just press the / key to toggle).

DeePsea automatically SPLITS when dragging lines on top of one another. You can vary the tolerances and options - so tweak them to suit however you do stuff. The prefabs DO NOT split until you DRAG them. You may be putting 2 prefabs on top of one another by clicking too fast?

"Then it breaks it into 2 sectors and I gotta redefine those."

Let's make sure we define what a "sector" really is. If you happen to have sectors that you want to be the same floor/ceiling/etc (a "sector" is NOT an area), just merge them.

Keep a topic simple and please describe step by step what you mean, otherwise I can't help you.

Old Post 06-13-01 00:31 #
DeePTeam is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


Sorry, I was just kinda babbling. I'm gonna go through that help later on, but I've discovered a few tricks to make things work generally OK now.

If I still have problems doing what I want after reading that I'll be back, with screenshots and tutorial.

Old Post 06-13-01 00:59 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


I'm sorry, I won't post anything. For whatever reason, Save crashed and wiped the entire level. The backup file was 4 saves previous.

Guess I won't be seeing that level for a long long time :|

That's the same way it trashed previous maps in previous versions. Can't deal with it.

Sorry, back to WadEd.

Old Post 06-13-01 02:52 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DeePTeam
Junior Member


Posts: 127
Registered: 05-00


First of all, when you save, the current version is named .BAK so you CAN NOT possibly be back 4 versions. At the most it's your prior save - ONE version back. Why do you write this kind of nonsense?

How come nobody else has this happen? Maybe you have some combo I've never run across in your options, but this kind of post certainly doesn't help anybody.

For certain if you play ZDOOM (or ANY derivative of ZDOOM) it can play havoc with your system. ZDOOM 1.23 still roasts my machine after a few play tests, and 1.22 would only run once.

So don't be so quick to judge - especially since you give absolutely no description of exactly what you are doing.

I think I'd get feedback on something like this right away - don't you think?

There may or may not be an issue with the prefab when putting a line on top of anther line. I didn't make any changes in the way the prefabs are made, but I did in the interface. I think it's possible a message may pop up and goes by to fast to see, Enjay just did something similar. Need to check if a message can fly by.

So for example, it would be revealing to yourself and to me to list the other programs you were or had run and if you had the file backup options turned on (by default it's off). That's separate from the .BAK stuff. I don't always have time to test all variations.

Old Post 06-13-01 03:31 #
DeePTeam is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
diluted
I am maga


Posts: 215
Registered: 05-01


damn man ur fuckin havin more probs than me and im a newbie
some people should stick with what there good with
oh by the way deep team deepsea is kickin ass in the learning department all it takes is like to learn one thing and u got it all

Old Post 06-13-01 05:14 #
diluted is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


More problems? I guess so. I've managed to work around most of them, but nothing has ever made me go "what the fuck?" so many times in one day.

Both versions of the map now crash deep when I try to open them, so all I can assume is that the save got screwed up before it actually crashed the program, which would explain the non-recent backup. I've had earlier versions go through the regular save process, only to save totally different data. It looked like it was working fine until the crash, but who knows.

I'm not sure if was the program or Windows who started the problems, because that stuff doesn't usually happen; it's probably the 3rd most stable app I have on my computer. Seems like it only happens when I don't need it to. You know, if I change a few textures or add a few rooms, it never happens, but when I build a level, BOOM! Such is my luck.

Old Post 06-13-01 06:10 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Davidoom
Member


Posts: 468
Registered: 12-00


I just upgraded my Deep to the new one...seems pretty nice Deep!!!
*puts thumbs up icon on*

Old Post 06-13-01 08:42 #
Davidoom is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DeePTeam
Junior Member


Posts: 127
Registered: 05-00


So far I've learned nothing and I don't think you have either.

If you send me the level that supposedly crashes, I can quickly find out the problem. There's an awful lot of safety checking in loading a level - but who knows what I might have missed. An easy way to also give me an idea is if you can "preview" the level in the open dialog.

The FIRST thing that happens on a save is a RENAME to .BAK, , -then- it writes the new data. So you see, it's literally IMPOSSIBLE to not have a backup. OTOH, if you have a system that is not behaving correctly, you won't see the .BAK file because the directory never got written back.
-------------------
Oh, the email stuff is not visible anymore - send the file to jack@sbsoftware.com

Old Post 06-13-01 15:28 #
DeePTeam is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


I worked on it again in a different program so I don't have the version that crashes it, BUT I thought I did, until I tried to open up another WAD - now it seems that EVERY WAD I try and open crashes the program, so I guess it's not that specific WAD anymore. I guess I'll reinstall it and see what happens.

Old Post 06-13-01 18:56 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Lüt
Administrator


Posts: 9170
Registered: 05-00


You know what else now? I found why it's crashing on Opening WADs. You know how when you start the program, and that "Edit Level" selection comes up with ExMx and the map diagrams? I right-click on it to skip loading the default game level and just go to open mine. If I right-click out of that level select dialogue and get the blank map, then try to open a PWAD, it crashes. BUT if I load a default game level from the IWAD on startup, I can load all the PWADs I want.

Old Post 06-13-01 19:00 #
Lüt is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DeePTeam
Junior Member


Posts: 127
Registered: 05-00



You know how when you start the program, and that "Edit Level" selection comes up with ExMx and the map diagrams?


Oh, now I see, thanks for the info.

What you should do is set the F5 options to "Auto Load Levels" and "Auto Start program". Way faster and much easier.

Your last level is then automatically loaded and you skip that whole dialog.

I never test nor run that way - takes too long:)) (I'll need to see what's going on there though).

I did some testing with the prefabs and your "4th line" did have to do with drawing prefabs on top of one another - something I again never do.

In keyboard tool mode (eg Ctrl+R), it does a merge check/split (meaning it breaks overlaps into "pieces", but the message comes up too fast and goes away because the tool exit mouse click is still active. In my rearranging I forgot about that problem.

In dialog prefab mode, there is no merge split.

Anyway I made them all the same and put a wait for mouse buttons to stop being sent so all these messages can be seen.

Old Post 06-13-01 19:53 #
DeePTeam is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DeePTeam
Junior Member


Posts: 127
Registered: 05-00



.. "Edit Level" selection comes up with ExMx and the map diagrams? I right-click on it to skip loading the default game level and just go to open mine.

I checked and that was a mistake. As I mentioned before, I never run without "Auto Load Levels" and when testing the right click/cancel was just never done.

The right way to start a new level is to select from the File Menu and select "New Level". The way it was after exiting out as you did (a blank screen) would mislead one into thinking that it was ok to start drawing.

So I just disabled that dialog when starting up - looked like a leftover from a long time ago. I'll put out a slight revision next week that will also have "shadow tools". Anybody that received registered 11.1 will get the update for free. Please email me if I forget - not a problem:)

Old Post 06-16-01 16:33 #
DeePTeam is offline Profile || Blog || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 22:47. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Level from scratch in Deep.

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.