Severed bunny head
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Help with ZDOOM Script
 
Author
All times are GMT. The time now is 02:46. Post New Thread    Post A Reply
Doom II Guy
Member


Posts: 617
Registered: 04-02


Okay, this is what my script says (note, I did not make it, I got it as an example off a site)

#include "zcommon.acs"

script 1 (void)
{
print(s:"Hi! This is my map and it rocks!");
}
EDIT: I got rid of my question, I figured it out.

Last edited by Doom II Guy on 06-23-02 at 20:36

Old Post 06-23-02 20:18 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doom II Guy
Member


Posts: 617
Registered: 04-02


Damn my innability to be ably to make a working switch. I did get the script to work though. When I hit the switch I guess that text is supposed to pop up. Anyone up for helping me figure out how to work a switch?

Old Post 06-23-02 20:30 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00


what editor are you using?

__________________
http://doom64ex.sourceforge.net/
http://doom64ex.wordpress.com/

Old Post 06-23-02 21:39 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Biffy
Forum Regular


Posts: 894
Registered: 02-01


Making a guess....is your switch line set properly for player "using" vs. "walking over" or something else? Is it set to be repeatable? Then, is the switch set to active script one?

Old Post 06-23-02 21:56 #
Biffy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doom II Guy
Member


Posts: 617
Registered: 04-02


I'm using DeScriptED (http://www.newdoom.com/hosted/kaiser/descripted.shtml) and DeePsea for the level editing.

Old Post 06-23-02 21:56 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doom II Guy
Member


Posts: 617
Registered: 04-02



Biffy said:
Making a guess....is your switch line set properly for player "using" vs. "walking over" or something else? Is it set to be repeatable? Then, is the switch set to active script one?

It's set for "When Player Crosses Line". I have no clue how to set it to be repeatable...and lastly it is set to script one. Maybe I can send it to you and you can have a look?
EDIT: I see the repeat button now, what difference will that make?

Old Post 06-23-02 22:00 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Biffy
Forum Regular


Posts: 894
Registered: 02-01


It will allow the line to activated more than one time. Sure, you can send it to me, I need something to do! llblakely@earthlink.net

Old Post 06-23-02 22:14 #
Biffy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Biffy
Forum Regular


Posts: 894
Registered: 02-01


Hmmm, DeePsea has its own script compiler, I don't know anything about DeScriptEd. I now wonder if your script is being compiled as a "behavior" resource. I'll know after seeing your wad.

Old Post 06-23-02 22:17 #
Biffy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doom II Guy
Member


Posts: 617
Registered: 04-02


I did have to do something in DeePsea with "behavior", man I'm terrible at this! Anyway, I just sent it, thanks for the help.

Old Post 06-23-02 22:20 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Biffy
Forum Regular


Posts: 894
Registered: 02-01


Deathman, his mistake was in not having the right flags for his switch line. It's an impassible line on the wall and needed to be "use" vs. "walk over". His script works and was compiled OK and in the wad.

Old Post 06-23-02 22:37 #
Biffy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Doom II Guy
Member


Posts: 617
Registered: 04-02


"Your script is complied correctly and was correctly installed in the wad as "behavior". The text (human readable) data of your script is not in the wad. There is a "scripts" entry, but it is empty. It's not needed to make the wad work, the behavior lump does that, but if in the future someone needs to check your script, you should also insert it. DeePsea will let you load your script text file...give it the name "scripts"."
Ummm...whoops. Anyway, how do I load it in? Thanks for the help though, any idea how to make the script text BIGGER?

Old Post 06-23-02 22:49 #
Doom II Guy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 02:46. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > Help with ZDOOM Script

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.