Cyberdemon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom General > Problem with Hexen Demo 1.1 in source ports.
 
Author
All times are GMT. The time now is 23:59. Post New Thread    Post A Reply
Cire
Member


Posts: 314
Registered: 10-08


Today when I discovered that the Mac Hexen Demo contains a different, newer IWAD, I tried to play it with a few different source ports. To my surprise, none of the ZDoom-based source ports seem to handle it properly. ZDoom and Zandronum doesn't recognize it and fails to start it and GZDoom and Tower of Babel starts it up but crashes when starting the first level. Chocolate Doom v2 svn binary crashes upon starting. Vavoom seem to work though. Any ideas?

Old Post 01-10-13 21:57 #
Cire is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
fraggle
Filled with the code of Doom


Posts: 7468
Registered: 07-00


I wouldn't expect the demo IWAD to work with most source ports. Have you tried the IWAD from the normal demo to see if it's any different?

Old Post 01-10-13 22:17 #
fraggle is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Cire
Member


Posts: 314
Registered: 10-08


Yeah, the normal demo IWAD works fine. Is there any reason why not many source ports support the newer demo? Maybe because it's more uncommon? What's the difference between them anyway? The Mac Demo IWAD is quite a bit bigger.

Old Post 01-10-13 22:21 #
Cire is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10987
Registered: 07-07


Where did you find that Mac demo?


There might be many reasons why it doesn't work right, but without the file I cannot guess.

Old Post 01-10-13 22:33 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Cire
Member


Posts: 314
Registered: 10-08


Hexen Mac Demo: ftp://ftp.fu-berlin.de/pc/games/idg...tuff/hexen/mac/
Only IWAD in a more PC-friendly format: http://sourceforge.net/projects/hhe...hareware%20wad/

Old Post 01-10-13 22:37 #
Cire is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
kristus
Megablast!


Posts: 10604
Registered: 07-00


WAD got errors in a fair bit of the lumpnames. In map01 and 04's lumps specially.

Also, at the end of the file there are a few resources that seem to have been sized up and ran through a hx4 or whatever filter.

Old Post 01-10-13 23:00 #
kristus is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Cire
Member


Posts: 314
Registered: 10-08


Weird. Is that the reason why it's bigger than the normal demo? Also, does anyone know if the Mac Doom Demo IWAD is any different to the normal Doom Shareware versions?

Last edited by Cire on 01-10-13 at 23:25

Old Post 01-10-13 23:07 #
Cire is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10987
Registered: 07-07


Many lumps are "marked" like in Jaguar Doom with the upper bit set on the first byte of their name. This explains why it's glitchy. In Jaguar/PSX/etc. Doom, this was used to tell that the lump was compressed with LZ77, however here this isn't the case.

Old Post 01-11-13 00:40 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Blzut3
Member


Posts: 493
Registered: 06-04


I was probing around with the console ports of Hexen and noticed that as well (I believe this was in the N64 port). I wonder if the Mac port is based off of that? I would try the Mac version myself, but my Performa isn't hooked up to the network at the moment.

Old Post 01-11-13 02:27 #
Blzut3 is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 23:59. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom General > Problem with Hexen Demo 1.1 in source ports.

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.