Archvile
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom General > Strange Single-Player Lag on Mac
 
Author
All times are GMT. The time now is 22:05. Post New Thread    Post A Reply
jdagenet
Member


Posts: 302
Registered: 07-11


Hello,
When I start a single-player game in a source-port on my MacBook Pro, the game lags.
It shows that I get an average 200+ FPS during single-player gameplay but when I play online, the lag goes away with the same 200+ FPS.
This happens with all the source-ports I have tried: ZDoom, GZDoom, and Zandronum.

Here is my MacBook specs:

  • Processor: 2.3 GHz Intel Core i7
  • Memory: 16 GB 1600 MHz DDR3
  • Graphics: NVIDIA GeForce GT 750M 2048 MB
  • Software: OS X 10.9.2


I'm not sure what is causing this strange lag because as I have mentioned before, the lag completely goes away when I play online.

Could anyone here please give me some pointers on what is going on here?
Thanks in advance.

Old Post 04-26-14 22:32 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
fraggle
Filled with the code of Doom


Posts: 7830
Registered: 07-00


Do you have a retina display Mac? I've experienced low frame rate with some source ports and with DOSbox. You might try this:

  • Open the Applications folder in the Finder.
  • Click the icon of the source port.
  • Choose File -> Get Info from the menu. A window will appear with information about the application.

    https://i.imgur.com/swpYu5t.png

  • Check the "Open in Low Resolution" box and close the window.
  • Double click the application and it should run smoothly now.

Let me know if this helps.

Old Post 04-27-14 01:13 #
fraggle is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
jdagenet
Member


Posts: 302
Registered: 07-11


Yes, I am running Retina Display, sorry for not putting that in the OP.

Sadly, this didn't help.
I tried this method on both GZDoom and Zandronum and it didn't seem to help the unexplained lag.

If I join an online game with Doomseeker and then start playing a single-player game, it runs smoothly. If I start a single-player game from the Finder by double-clicking the app, it gives me this lag.
It very strange.
Thanks for the information though.

Old Post 04-27-14 01:46 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
printz
CRAZY DUMB ZEALOT


Posts: 8910
Registered: 06-06


Try a lower Doom resolution. To be fair, drawing 2880x1800 pixels (or doing any such operations) in software mode without parallelism can still take time, too much for a frame. And I'm not sure if fullscreen mode is even affected by the "low-resolution mode" setting.

__________________
Automatic Wolfenstein - Version 1.0 - also on Android

Old Post 04-27-14 07:38 #
printz is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
jdagenet
Member


Posts: 302
Registered: 07-11


I tried messing around with the resolution and fullscreen setting and I did not experience any improvement.

Old Post 04-27-14 16:36 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Avoozl
Forum Staple


Posts: 2737
Registered: 06-09


If you had it on already have you tried disabling vertical sync?

Old Post 04-28-14 01:46 #
Avoozl is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
jdagenet
Member


Posts: 302
Registered: 07-11


Yes, that was one of the first things I did because it was limiting my FPS to 60.
Upon disabling vertical sync, my FPS jumped up to the 200's but the choppy lag still remained.

Old Post 04-28-14 01:51 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Clonehunter
Forum Staple


Posts: 3947
Registered: 03-10


Interestingly I was having similar problems with Doom Legacy on my mac book. I posted a thread in source ports and haven't found much of an answer. It could be a computer issue then, if you're experiencing something similar with other ports.

Old Post 04-28-14 03:51 #
Clonehunter is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
jdagenet
Member


Posts: 302
Registered: 07-11


Have you tried playing other games on your MacBook to see if the problem occurs?

I can play other games such as Minecraft just fine without any lag.
It almost seems as if the lag occurs when I launch the source-port through the Finder or something. When the source-port launches via Doomseeker, no lag.
I've also opened the source-port through the Terminal but it has no affect.

I sure hope it's not a computer issue, it was a $2,500 MacBook :P.

Old Post 04-28-14 04:04 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Vs1991
Green Marine


Posts: 32
Registered: 10-13


go to nvidia control panel and change the 3d settings to use your gpu. im guessing its using the integrated one

Old Post 04-28-14 04:05 #
Vs1991 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
jdagenet
Member


Posts: 302
Registered: 07-11


I think the Nvidia Control Panel is only available on a Windows operating system.
If one does exist on a Mac, I have no idea where it's located.

Old Post 04-28-14 04:14 #
jdagenet is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Clonehunter
Forum Staple


Posts: 3947
Registered: 03-10


Other games have worked fine for me too. Though I mostly use the book for FTL or Poker Night now days, and not much else.

Old Post 04-28-14 04:54 #
Clonehunter is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 22:05. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom General > Strange Single-Player Lag on Mac

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.