Sarge
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > TAS (tools-assisted) demos
Pages (17): « First ... « 4 5 6 [7] 8 9 10 » ... Last »  
Author
All times are GMT. The time now is 15:08. Post New Thread    Post A Reply
odysseyofnoises
Member


Posts: 449
Registered: 09-10


what do you see thats so unusual on map08 lol, all i was doing was bouncing around in the sector waiting for it to lower all the way

Old Post 02-12-12 19:08 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
GhostlyDeath
Forum Retard


Posts: 1041
Registered: 08-05


This is an incomplete TAS of UV Max Doom 2, I only got up to map08 but I did manage to get a good time of 4 minutes 3 seconds.

Took much time to make and I am quite busy, and I just can't find the time to finish this. But I am not that great at making TAS demos.

Download: http://remood.org/downloads/gd2uvm4p.zip

Enjoy!

Attachment: gd2uvm4p.zip
This has been downloaded 21 time(s).

Old Post 02-28-12 02:58 #
GhostlyDeath is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


So i was planning to fix my old plutonia movie a little bit (map16 and map25 for example), but i dont want to redo anything except for these maps. Is there any way to roll the random number generator to the same number at the start of the next map? I've already fixed map25, but the movie quickly desyncs at map26, so the numbers are not right. Is there any tool that shows your current position in RNG table? dre2 seems to show some "rand" thingie, but it simply increments by 1 with each tic (except for intermission screens), and not reacting at my actions. Or am i missing something there?

Old Post 03-21-12 14:07 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
xepop
Junior Member


Posts: 232
Registered: 10-09


Dre2 doesn't show the correct rnd. It's possible to roll it as I did it myself in map01 using my own dre I hacked together for my built run. It may not be easy, though.

Old Post 03-21-12 14:23 #
xepop is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


could you share this hacked dre or is it super-secret? :)

Old Post 03-21-12 15:43 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
entryway
Forum Staple


Posts: 2739
Registered: 01-04


jongo, do you plan to add some random shoots / movements at end of newest map25 to make prndindex at start of map26 the same as before?

Last edited by entryway on 03-21-12 at 17:43

Old Post 03-21-12 17:34 #
entryway is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


yea, i was going to use chaingun on my way to (hopefully) quickly get the index i want.

Old Post 03-21-12 18:24 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


Also while editing 30pl1337.lmp i noticed a weird thing. It happens at tic 23309: right after entering the last teleporter in map25 i move a little bit, which allows me to pick up plasmagun (which is placed at the spot where i get teleported to). I don't have a plasmagun by that point, so this starts a weapon changing animation, and i can abuse it to switch to rocket launcher instead. I still can't move manually though and have to wait a few tics before being able to move / turn, and no one shoots me too. Is this phenomenon caused by final doom buggy teleporter behaviour and can it be manipulated? I really need these few tics to get under 12 seconds in this map, but i always end up standing still after teleporting now :/

Old Post 03-22-12 07:26 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
xepop
Junior Member


Posts: 232
Registered: 10-09



Is this phenomenon caused by final doom buggy teleporter behaviour


No, I first encountered it in doom2 map15. I don't know what causes it, though. Check your pm btw.

Old Post 03-22-12 12:25 #
xepop is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
ClumsyDoomer
Junior Member


Posts: 210
Registered: 02-11


Real World (sorry if RW demos thread exists - I couldn't find it, so I post my RW demo here) map09 UV-Speed in 0:04 (TAS), CL 2, built with DRE 2.
PS: Sorry, I posted in wrong thread :( Can't delete this post. Please, move this post into "Miscellaneous TAS demos" thread.

Attachment: rw09-004.zip
This has been downloaded 15 time(s).

Last edited by ClumsyDoomer on 03-22-12 at 15:40

Old Post 03-22-12 15:33 #
ClumsyDoomer is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
Donce
Member


Posts: 547
Registered: 10-03


jongo, do you mean the phenomenon when you teleport and are moving immediately after that, i.e. the teleporter doesn't hold you? I had this happening quite a few times recently in Equinox.wad, and only on certain teleporters. I suspected this may have something to do with the player being next to (or getting stuck at) a monster just before teleporting, but now I'm in doubt, because sometimes this also happens without any monsters nearby.

If you are willing to investigate, I can tell specifically at which teleporters I encountered this behavior, and I have one saved demo (though I had this happen numerous times). All those teleporters do have something in common - the player enters them westward and teleporting lines touch 1-sided lines. But I'm not sure if that is important - I tried to make a test wad based on this observation, and I could not reproduce this behavior.

Old Post 03-22-12 20:46 #
Donce is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


Something like that, but i move only for 1 tic and do not have any control over the movement, and the distance i travel in that tic isn't big. I still have to wait standard ~15 tics before being able to move at will.
Actually, i was wrong in my previous post, the tic to look at in my demo is 23308, not 23309. The correct teleport destination is (1504,992), but i somehow get translated to (1504.888687,1000.307648).
Also it's not your typical situation where you get shot right after teleporting, which eliminates the teleporter wait. Like in map03 in 10uv-256.lmp for example.
I'll try to test it, but i guess it would be more reasonable to ask coders for help :D

Old Post 03-23-12 05:10 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


moar spamming by me!
This time it's Ultimate Doom demo. Inspired by entryway's this post, i decided to look at how many tics i could save from e4m1. It appeared that another second is shaveable, with the cost of using jerky turns. The demo is actually barely watchable imo and entryway's one looks more impressive and flashy. So now i'm not sure whether i should continue making e4uv or lay it off and leave it to more skilled builders out there.
Still happy to crack another second :)
EDIT: i decided against continuing the movie, at least for now. I'll keep working on d2reloaded.

Attachment: e4m1-013.zip
This has been downloaded 33 time(s).

Last edited by jongo on 03-30-12 at 09:15

Old Post 03-29-12 13:20 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
ClumsyDoomer
Junior Member


Posts: 210
Registered: 02-11


Real World is losing its blood.
RW map01 UV-Speed (also pacifist) in 0:04. Built with DRE 2, CL 2.
Uhm, why not to make the whole-wad UV-Speed movie?..

Attachment: rw01-004.zip
This has been downloaded 15 time(s).

Old Post 04-10-12 09:53 #
ClumsyDoomer is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


Final DOOM tnt Evilution MAP09 "Stronghold" nightmare! 100% secrets tool assisted speedrun in 2:09

Attachment: es09x209.zip
This has been downloaded 21 time(s).

Old Post 04-30-12 01:02 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Andy Olivera
Forum Regular


Posts: 722
Registered: 12-02


Squadron 417:

MAP22: 9:48

Attachment: sq22x948.zip
This has been downloaded 20 time(s).

Old Post 05-03-12 15:42 #
Andy Olivera is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


yeah, i got lazy lately and went full-DRE. Combining prboom and dre could yield same results and smoother demo, but my workflow is very inefficient, so maybe it's a bad tip after all.
Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?

Old Post 05-03-12 16:53 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10



jongo said:
yeah, i got lazy lately and went full-DRE. Combining prboom and dre could yield same results and smoother demo, but my workflow is very inefficient, so maybe it's a bad tip after all.
Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?



problem is that i cannot run DRE on my system at all, i have tried before a while ago for hours without success, dunnio why it wont run. but i would like to run it because i know it produces better results... in fact, what is the concept behind DRE ? how does it even work and what does it let you do. i just utilize all of the built in TAS tools that come with prboom in my demo, thats using gamespeed 20, enabling permenant strafe50, enabling strafe50 on turns, and of course using segmenting =) i do hate how long it takes to load the later maps using recordfromto...

Old Post 05-03-12 18:10 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Andy Olivera
Forum Regular


Posts: 722
Registered: 12-02



jongo said:
Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?

I start by creating an empty demo (a few seconds) with PRBoom+ which I then load in to DRE. The only other thing PRBoom+ gets used for is playback if I need to track how much damage I'm doing. When doing that, I just save the demo, suspend DRE, tab to the command line, playback the demo, then tab back to DRE to continue. That's pretty much it, in terms of workflow.

Oh, when I'm done with the demo I'll use -recordfromto to remove the garbage at the end that gets built up over time, then tack on some WT tics with DRE.

Old Post 05-03-12 21:59 #
Andy Olivera is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
ClumsyDoomer
Junior Member


Posts: 210
Registered: 02-11



odysseyofnoises said:


problem is that i cannot run DRE on my system at all, i have tried before a while ago for hours without success, dunnio why it wont run. but i would like to run it because i know it produces better results.....


Try xepop's XDRE. It's based on Prboom-Plus 2.5.1.3, so it should run on every system. Link can be found in that thread:
http://www.doomworld.com/vb/doom-sp...nster-full-run/
Find the download link below.

Old Post 05-04-12 08:21 #
ClumsyDoomer is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10



ClumsyDoomer said:

Try xepop's XDRE. It's based on Prboom-Plus 2.5.1.3, so it should run on every system. Link can be found in that thread:
http://www.doomworld.com/vb/doom-sp...nster-full-run/
Find the download link below.



alright thanks bro ill try that when i get home tonight after school (6pm!)

Old Post 05-04-12 13:17 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


the link is nowhere to be found wth -_-

Old Post 05-05-12 05:31 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
jongo
Member


Posts: 311
Registered: 07-07


It's somewhere at the bottom of the first page and is not highlighted, here it is:
users.jyu.fi/~jomihaka/xdre.zip

Last edited by jongo on 05-05-12 at 06:21

Old Post 05-05-12 06:04 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


how do i even use xdre... all it does when i launch it is pull up a black window and crash everything

Old Post 05-05-12 06:35 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
ClumsyDoomer
Junior Member


Posts: 210
Registered: 02-11



odysseyofnoises said:
how do i even use xdre... all it does when i launch it is pull up a black window and crash everything

I probably know what's the matter. Did you read readme.txt? There is many useful info. Really. :)

Old Post 05-05-12 08:41 #
ClumsyDoomer is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


i should copy the prboom-plus.wad from prboom-plus v2.5.1.3 right?

Old Post 05-05-12 09:14 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


1monster map17 uv-speed TAS in 1:52 (with new tricks!)

Attachment: 1m17x152.zip
This has been downloaded 22 time(s).

Old Post 05-06-12 18:17 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
xepop
Junior Member


Posts: 232
Registered: 10-09


There's 1.20 version for xdre: http://users.jyu.fi/~jomihaka/xdre.zip

Added button to unset savepoint for easier check for desyncs. Also fixed brainfart in bruteforce. Now it should actually work. Unfortunately, I don't have time nor willingness to look for prboom_plus' savegame bugs, which you are experiencing.

Old Post 05-08-12 17:27 #
xepop is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
odysseyofnoises
Member


Posts: 449
Registered: 09-10


what does brute force do in XDRE?

Old Post 05-08-12 17:57 #
odysseyofnoises is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
ClumsyDoomer
Junior Member


Posts: 210
Registered: 02-11


I don't know :p I used it, but I couldn't get any results.
Probably simple tricks, like glides (for example, jongo used brute force to make map25 glide in his 30pl1316) or some successful wallruns. I've just asked xepop in PM, just for interest. :D
BTW, going to test new version :3
I'm [probably] pro in these DREs and I can do [probably] every trick. Let's try...

Old Post 05-08-12 18:12 #
ClumsyDoomer is online now Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 15:08. Post New Thread    Post A Reply
Pages (17): « First ... « 4 5 6 [7] 8 9 10 » ... Last »  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > TAS (tools-assisted) demos

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.