Archvile
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > problem with doom replay editor 2
 
Author
All times are GMT. The time now is 00:07. Post New Thread    Post A Reply
didierbertrand
Member


Posts: 506
Registered: 10-10


hi guys
i wanted to improve the quality of my tas demos
so i've downloaded doom replay editor(dre2.zip) and an old version of prboomplus (the version number is 2.2.6.29).
problem: when i click on dre.exe the only thing that appear is a black screen .
can someone help me ?

Old Post 02-26-11 21:42 #
didierbertrand is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Creaphis
I will deliberately take a contrary position just for the sake of writing incredibly long arguments


Posts: 4181
Registered: 10-05


Hm. The problems I ran into with DRE2 were some error boxes about missing DLLs (which went away when I got the right DLLs) and the unintuitive text-only interface. When you say you get only a black screen, do you mean there's really only a black screen or is there also a window with some info, a text input box and a tic list? In the second case, you need to type "load" into the text input to load a demo, and after that you need to type something like "f1" followed by a space to get started.

Old Post 02-27-11 03:25 #
Creaphis is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Andy Olivera
Forum Regular


Posts: 713
Registered: 12-02


Why the old version of PRBoom+?

There should be two windows when you open DRE. The black one is the game screen, which is only for viewing. The other window is the one you use for entering commands. On the Input Line, type 'i'; it should increment one tic and update the other window.

A few tips on how to use it:

* Everything is controlled from the Input Line with text commands. Clicking on the Tic List or any other part of either window has no effect. It's a CLI, not a GUI.

* All commands are case sensitive.

* It's limited to Complevel 2.

* It's based on PRBoom+ v2.2.6.2, so it doesn't have any of the Overflow Emulation of future versions. As such, demos are not 100% guaranteed to play back with v1.9.

* The WalkCam isn't frame-limited. If you have a fast computer, one touch of a turn key will flip you nearly 180 degrees. Example: on my 1.6GHz netbook it runs perfectly; on my 3.2GHz desktop it's virtually useless.

* It has some sync issues. To avoid these, only load one demo per session. Similarly, only set one Save Point per session. If you need to reload or set another Save Point, close the program and restart.

Obviously, it could use some improvements. However, once you get accustomed to the interface, you'll find it becomes pretty easy to use.

Old Post 02-27-11 03:28 #
Andy Olivera is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
didierbertrand
Member


Posts: 506
Registered: 10-10


i had a black screen and a window,i didn't know how to start it,now everything is ok, thanks.

EDIT:i talked too fast, everything is far from ok .
I manage to start the game, but it's doom2 map 01 deathmatch, and the only comand that work is the one that allow to go between first and third person camera.
when i exit dre there is a lmp file named "THISISBACKUP" that last 1second (or less)and that's all.

When i record a demo i don't use the command line but i create the shortcut and enter the command in the case "properties", must i do the same thing with dre , if i want to record a demo ?

Last edited by didierbertrand on 02-27-11 at 19:09

Old Post 02-27-11 18:32 #
didierbertrand is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Hock
Banned


Posts: 185
Registered: 10-09


The black screen pops up then a pop up appears and says "I_SignalHandler: Exiting on signal: signal 11"

Whats wrong with this?

Old Post 02-27-11 23:56 #
Hock is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Andy Olivera
Forum Regular


Posts: 713
Registered: 12-02


When starting a new demo I just create a couple seconds worth with PRBoom and load that into DRE. The only parameters you should use when starting DRE are -file or -deh. All demo-related commands are handled within the program.

Also, a tip I forgot: you can edit the CFG file so the Boom HUD shows up. It only shows up every other frame for some reason, but it's far more useful.

As for the 'signal 11' error: I have no idea.

Old Post 02-28-11 02:27 #
Andy Olivera is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
didierbertrand
Member


Posts: 506
Registered: 10-10


i've managed to record a demo but when i want to watch it, there is this message on the screen:I_Read:read failed:EOF
what's wrong?

Old Post 04-03-12 18:51 #
didierbertrand is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
xepop
Junior Member


Posts: 232
Registered: 10-09


That error comes, at least, when prboom-plus.wad is corrupt.

Old Post 04-03-12 19:19 #
xepop is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 00:07. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > problem with doom replay editor 2

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.