Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > Extremely weird demo desync.
 
Author
All times are GMT. The time now is 03:09. Post New Thread    Post A Reply
Archy
Forum Regular


Posts: 672
Registered: 11-09


Hello Doomworld, I'm going to tell you a little about my self today. When ever I make a YouTube video of one of my demos, I always make a batch file like this:
code:
ren NR01-434.LMP demo1.lmp doom2 -file nerve.wad nervemus.wad demo2.lmp demo1.lmp -config dpp.cfg ren demo1.lmp NR01-434.LMP


This is so the title screen displays before the demo plays and makes the video look like this as opposed to this .

demo2.lmp is deigned to crash doom2.exe so Fraps stops recording as soon as the demo ends. demo2.lmp has codes similar to this:
code:
gadfskjlhgadsklhad54654165465skudfsladskjl


But when I wanted to make a video of KF05-412.LMP using the same method, the demo desynced and this has never happened to me before. Here's my batch code:
code:
ren KF05-412.LMP demo1.lmp doom2 -file ksutra.wad demo2.lmp demo1.lmp -config dpp.cfg ren demo1.lmp KF05-412.LMP


This code however doesn't desync the demo:
code:
doom2 -file ksutra.wad -playdemo KF05-412 -config dpp.cfg


After playing around a bit, I found that a good portion of demos with the -FAST Parameter desync with my method of starting the title screen before demo playback. I theorized that it was because of the "strange" parameter and quickly tried other "weird parameter demos" such as Green Herring's M226R545.LMP demo which features the -RESPAWN Parameter and it indeed desynced.

I then tried this same method with source ports. First PrBoom-Plus-2.5.0.4 which was a complete fail because it didn't except *.lmp files after the -FILE parameter. Chocolate-Doom-1.60 however desynced the demos in the same way Vanilla Doom2 v1.9 did.

Any ides how this glitch happens? It doesn't affect all -FAST and all -RESPAWN demons but the ones it affects it always affects in the same way. Know any way to get around this glitch? How well has this glitch been documented because I've never heard of it.

Thanks good people of Doomworld.

Old Post 01-28-12 22:35 #
Archy is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Ryback
Member


Posts: 390
Registered: 06-01


I have no idea, but it sounds like an interesting bug. The only issue I'm aware of with demos that desync when played back from the title screen involve revenant missiles. Something in the missile behaviour code checks against the internal timer, and this is different when played back from the command line versus played back in the demo1-demo2-demo3 loop. Doesn't sound like something that would be responsible for a -fast demo not playing back though.

Old Post 01-29-12 05:33 #
Ryback is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Archy
Forum Regular


Posts: 672
Registered: 11-09



Ryback said:
I have no idea, but it sounds like an interesting bug. The only issue I'm aware of with demos that desync when played back from the title screen involve revenant missiles. Something in the missile behaviour code checks against the internal timer, and this is different when played back from the command line versus played back in the demo1-demo2-demo3 loop. Doesn't sound like something that would be responsible for a -fast demo not playing back though.


It's interesting that you say that because all the -FAST and -RESPAWN demons desynced when a revenant got involved. I'll try to find a non -FAST/-RESPAWN demo with lot's of revenants in it to test this out. Map 27 of Doom 2 sounds like a good map to test this. I'm to tired to test it now but I'll try tomorrow or the day after. Thanks for the info and it explains allot.

Old Post 01-29-12 05:54 #
Archy is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 03:09. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > Extremely weird demo desync.

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.

Message Board Statistics