Mancubus
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > demo playback start with titlepic
 
Author
All times are GMT. The time now is 09:56. Post New Thread    Post A Reply
40oz
Forum Spammer


Posts: 6894
Registered: 08-07


One thing I've noticed particularly with tatsurdcacocaco's Doom UV-MAX youtube videos is the demos start with the titlepic opening and then starts the demo. I like this and I would like my demos to playback the same way, as my current demo library has a mixed bunch of random maps from random megawads, and I don't like to always have to guess what wad it is when someone watches the demos with me.

The only way I could think to do this is playing back an alternate version of the megawad where the DEMO1 lump is added/replaced with the demo I want to watch, and simply open the megawad and let it rip, but that seems terribly inconvenient and I doubt tatsurdcacocaco did that for all of his demos.

I can't seem to find anything like it in the prboom configuration files through. Am I missing something that will simulate the intro sequence before playing back each demo?

video for reference:



Also, in the Doomsday Engine, every time a new map starts the CWILVxx graphic is displayed at the top of the screen for a brief moment, which would also be pretty neat too. Does PrBoom have anything like that?

another video for ref:

Old Post 05-06-14 21:45 #
40oz is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Spammer


Posts: 5703
Registered: 04-07


No, prboom-plus doesn't have such functionality. I'm pretty sure that Tatsurd does exactly what you described (replacing the DEMO1 lump).

Old Post 05-06-14 22:00 #
Memfis is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
blob1024
Forum Regular


Posts: 709
Registered: 05-10


i do the same but made it different...
im rendering my videos with sonyvegas, one of the few which can edit easily more videos sources into 1 file.
so I recorded with fraps the intro of each wad I'm interested in (10seconds video) and then the demo.lmp.
then I obviously merge those and render the file afer renaming

Old Post 05-07-14 00:15 #
blob1024 is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
HackNeyed
Member


Posts: 383
Registered: 08-04


I'm pretty sure it's as simple as renaming the lmp to demo1.lmp and adding it to the -file command.

code:
glboom-plus.exe -file av.wad demo1.lmp


Works for me just like tatsurdcacocaco's videos. I just tested doom2.exe in DOSBOX and it also works.

-EDIT-
Odd, I'm using "Tatsurd-cacocaco DooM2 v1.9 5:56 CN" from http://doomedsda.us/wad84m215.html and it works fine as -file av.wad demo1.lmp in glboom-plus. However, in doom2.exe as -file av.wad demo1.lmp will desync shortly before the outdoor courtyard! Yet running doom2.exe -file av.wad -playdemo demo1 stays in sync!

Last edited by HackNeyed on 05-07-14 at 13:41

Old Post 05-07-14 13:21 #
HackNeyed is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Spammer


Posts: 5703
Registered: 04-07



HackNeyed said:
Odd, I'm using "Tatsurd-cacocaco DooM2 v1.9 5:56 CN" from http://doomedsda.us/wad84m215.html and it works fine as -file av.wad demo1.lmp in glboom-plus. However, in doom2.exe as -file av.wad demo1.lmp will desync shortly before the outdoor courtyard! Yet running doom2.exe -file av.wad -playdemo demo1 stays in sync!

It could have something to do with the fact that revenant missile behavior depends on the tic number (like if the current tic is even then the missile becomes homing or something). Maybe demos that are played 10 seconds after loading the game may start on a different tic. And maybe glboom-plus fixes it. Just a guess...

Old Post 05-07-14 16:50 #
Memfis is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 6086
Registered: 08-00


Unbelievably, this phenomenon was not documented on the Doom Wiki.

I have addressed that problem:
http://doomwiki.org/wiki/Revenant_t..._internal_demos

Old Post 05-07-14 18:02 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 09:56. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Doom Speed Demos > demo playback start with titlepic

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.