Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Eternity > Polyobject is empty?
 
Author
All times are GMT. The time now is 01:22. Post New Thread    Post A Reply
Mordeth
Administrator


Posts: 1989
Registered: 05-00


I'm getting the error message:
code:
Polyobject 4 is empty Bad polyobject 4 for anchorpoint


Polyobject is made offmap from a simple 1-sided linedef square containing a 270 trigger tagged 4 referring to a extradata linedef special with PolyObj_StartLine and recordnum 4. Anchorpoint 9300 in offmap; spawnpoint 9301 in-map.

Basically, verbatim copy of the wiki example. And it won't work and it's driving me up the walls. Any help please?

Location: http://www.mediafire.com/download/y...upcjp4/test.wad

Old Post 11-18-13 13:59 #
Mordeth is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 6052
Registered: 08-00


I'll take a look-see this evening. Sounds like you might have found a bug in the polyobj linedef gathering code.

Old Post 11-18-13 17:34 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mordeth
Administrator


Posts: 1989
Registered: 05-00


Doubtful. The wiki example level still works correctly.

Old Post 11-18-13 19:49 #
Mordeth is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mordeth
Administrator


Posts: 1989
Registered: 05-00


Bump. And solved: I took the 'args' line in the linedef definition as meaning the 'total number of arguments' instead of the actual argument: the PolyId.

Old Post 11-20-13 11:00 #
Mordeth is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 01:22. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > Eternity > Polyobject is empty?

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.