Severed bunny head
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > PSX Doom/Final Doom TC (Version 2.1 now released!)
Pages (28): « First ... « 25 26 27 [28]  
Author
All times are GMT. The time now is 01:32. Post New Thread    Post A Reply
FreddBoy
Warming Up


Posts: 28
Registered: 02-14


I have to admit, the wave of nostalgia was high when I heard the opening title music. Somehow menacing AND eerie at the same time...
The last time I played this was in 1997 on a proper PlayStation. Had both DOOM and Final DOOM. But allowing me to play all 60+ levels on one WAD?
I could kiss you all. Seriously, the people who helped get this going, from the programmers even to the plautesters, give yourselves a well deserved pat on the back.

Now if you excuse me... (hurries off to the cacowards thread).

Old Post 03-14-14 14:48 #
FreddBoy is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Brewtal_Legend
Member


Posts: 256
Registered: 08-04


I've been experimenting with some enhancement wads to be used with the psx doom tc. There is one thing I've noticed that consistently refuses to work correctly.

Why is it that blood will not stain the walls in the psx tc? Is there a way to make it so that blood decals will stick to the walls in psx doom?

The blood appears on the floors and sometimes ceilings (with ketchuptest4.pk3)But not the walls.

I'm using gzdoom latest stable release.

Last edited by Brewtal_Legend on 03-21-14 at 05:08

Old Post 03-21-14 05:01 #
Brewtal_Legend is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Blue Shadow
Junior Member


Posts: 244
Registered: 09-12


It's because decals are disabled in the TC.


Edit: the decals weren't disabled in the way I thought (with CVARs), but rather, they're redefined in DECALDEF to display an "empty" image.

Last edited by Blue Shadow on 03-21-14 at 10:19

Old Post 03-21-14 09:37 #
Blue Shadow is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Brewtal_Legend
Member


Posts: 256
Registered: 08-04


After digging deeper into the thread, I see that the dummy decaldef file was put in to adjust a bug with the decals.

No one ever figured out what causeses the bug that makes decals not appear on any walls other than on switches? Could it have something to do with the lighting or textures?

Old Post 03-22-14 02:05 #
Brewtal_Legend is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
ProGamerX56
Green Marine


Posts: 45
Registered: 02-14


Just a suggestion, add these values into the default PSXDoom.cfg file.
SECRETMESSAGE="A SECRET IS REVEALED"
WI_SHOWTOTALTIME="TRUE"
Then set the default colour of the secretmessage string to yellow.
It'll feel a lot more like PSX doom, no?
Just cos it resets itself every time...
BTW running 2.133 with only the music PK3

Old Post 03-22-14 08:43 #
ProGamerX56 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Blue Shadow
Junior Member


Posts: 244
Registered: 09-12



Brewtal_Legend said:
No one ever figured out what causeses the bug that makes decals not appear on any walls other than on switches? Could it have something to do with the lighting or textures?

The reason is simple: I've noticed that most, if not all, of the textures and flats are given an animation with ANIMDEFS, even textures and flats that only have one static graphic. And unless explicitly specified with the allowdecals keyword, decals are disallowed on animated textures by default.

Old Post 03-22-14 13:33 #
Blue Shadow is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
BaronOfStuff
Senior Member


Posts: 1121
Registered: 06-08



ProGamerX56 said:
Just a suggestion, add these values into the default PSXDoom.cfg file.
SECRETMESSAGE="A SECRET IS REVEALED"
WI_SHOWTOTALTIME="TRUE"
Then set the default colour of the secretmessage string to yellow.
It'll feel a lot more like PSX doom, no?


No.

Old Post 03-22-14 15:44 #
BaronOfStuff is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Brewtal_Legend
Member


Posts: 256
Registered: 08-04



Blue Shadow said:

The reason is simple: I've noticed that most, if not all, of the textures and flats are given an animation with ANIMDEFS, even textures and flats that only have one static graphic. And unless explicitly specified with the allowdecals keyword, decals are disallowed on animated textures by default.



So, adding ALLOWDECALS to the ANIMDEFS file should make them work? Does it work as a blanket command or does it have to be added to each texture? (NM figured it out)

Does the same have to be done for the flats?

Last edited by Brewtal_Legend on 03-23-14 at 00:10

Old Post 03-22-14 23:48 #
Brewtal_Legend is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10672
Registered: 07-07


It has to be added to each texture; though I'd hazard the guess that non-animated textures were declared as animation to disable decals in the first place.

Old Post 03-23-14 00:04 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Brewtal_Legend
Member


Posts: 256
Registered: 08-04


I just got done adding ALLOWDECALS to all the textures in the animdefs file, but it did not appear to work. Am I missing something? (NM again. I just didn't save it properly. I got the blood decals working now.)

Thanks for the help.

Last edited by Brewtal_Legend on 03-23-14 at 00:48

Old Post 03-23-14 00:22 #
Brewtal_Legend is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
BlueFireZ88
Junior Member


Posts: 206
Registered: 09-12


I've been attempting a 100% play-through of the TC and so far, everything has held together (not sure if the MAP52 fix I posted before was implemented into the main install).

Reached a minor problem with MAP81 (Lunar Mining Project):

In the large room on the other side of the courtyard (opposite the start point), there is a hatch room which opens when walking into one of the two smaller cylinder rooms in the center. This hatch room has shotgun guys and commandos. In the back of this hatch is a brown brick wall and if you notice on the map (cheat: iddt) that there are two other monsters behind the wall.

The wall never seems to open even with a full exploration of the level. And the sector tag for the wall itself is 27, which is shared between three other wall sectors.

I'm not sure what the exact problem is with these two stuck monsters, whether the wall was supposed to open or they were supposed to teleport out of the room. Could this be patched for future downloads?

UPDATE: Just finished Final Doom, and besides the problem mentioned above, 100% is possible for every level. Hopefully this keeps with the Lost Levels.

Last edited by BlueFireZ88 on 04-15-14 at 21:05

Old Post 04-14-14 20:07 #
BlueFireZ88 is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 10672
Registered: 07-07


This could interest you. Combined with the info here, you can use the new UDMF thing properties Health, Renderstyle, and Alpha to reproduce any of the PSX monsters accurately. Spectres and nightmare spectres no longer need to be separate thing types from demons, too.

Old Post 04-15-14 09:54 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
BlueFireZ88
Junior Member


Posts: 206
Registered: 09-12


Solved the problem with MAP81:

Apparently, the area I described can only be accessed by Players 2 through 4 when they leave their starting area (Walk-Over trigger). This area can't be reached by Player 1 without cheats. Thus, these two enemies (Commando and Zombieman) can only be seen in multiplayer.

Simply removing the singleplayer checkmark from their actor settings removes them from the level count.

Fix Upload:
Here

With my full playthrough and patches (MAP52/MAP81) I have verified that all 90 levels of the TC can be finished with 100% completion.

Last edited by BlueFireZ88 on 04-16-14 at 20:25

Old Post 04-16-14 20:16 #
BlueFireZ88 is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 01:32. Post New Thread    Post A Reply
Pages (28): « First ... « 25 26 27 [28]  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > PSX Doom/Final Doom TC (Version 2.1 now released!)

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.

Message Board Statistics