Baron of Hell
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > jdoom questions
 
Author
All times are GMT. The time now is 01:33. Post New Thread    Post A Reply
Brad_tilf
Redemption! Bath in its pure Light!


Posts: 984
Registered: 10-02


Ok - so I downloaded the jdoom files including the required files for kickstart so I could get rid of the ocx error. I have two issues with this port. well, maybe more than that so see if you can help...
When I use the Directx 8 funtionality all the sprites, etc... are surrounded by these stupid looking black squares. Ugly, nasty and useless - so I switch to OpenGL mode which I know works fine cuz I use it with Zdoom and Legacy quite often. Man does that shit look nice.. but - when I use it with Jdoom the game drags so bad that I just quit cuz its not even worth bothering. I set the screen res to 320x200 and pretty much left all the models alone cuz whats the point of using the port otherwise? I did try it with the models disabled but with the same results anyway. So, now I'm thinking - if I had to review this port it would come out like this:
Pain in the ass
hard to configure
too many goddam options
not worth the time

However, I want to give it every chance possible
so any ideas?

__________________
Doom Wad StationGet your wads here!

Old Post 11-22-02 22:36 #
Brad_tilf is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Brad_tilf
Redemption! Bath in its pure Light!


Posts: 984
Registered: 10-02


By the way - since I forgot to mention this...
I am using a PII 400mhz with 256 megs of ram.
my video card is an ATI 3D Rage Pro AGP 2X. Old I know but shouldn't have a problem with this port. If those specs aren't good enough to run Jdoom then maybe the makers of Jdoom should reconsider the direction they are heading in.
Oh yea, one more thing which might have a bearing - I'm using Windows XP

__________________
Doom Wad StationGet your wads here!

Old Post 11-22-02 22:40 #
Brad_tilf is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Grazza
Let's try Caesium


Posts: 12512
Registered: 07-02



Brad_tilf said:
I had to review this port it would come out like this:
Pain in the ass
hard to configure
too many goddam options
not worth the time

jDoom does demand high-end hardware, with full OpenGL support. Beyond that, I would say:
Easy to use
Easy to configure
Many options, though the default settings are OK

Very occasionally I get a bit of slowdown, but only in massive areas with a lot of enemies (in fact, there was only one significant instance: the start of Equinox map04). [P4 2.2 GHz, 1 GB RAM, GeForce 4.]

Old Post 11-23-02 00:06 #
Grazza is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
Brad_tilf
Redemption! Bath in its pure Light!


Posts: 984
Registered: 10-02


So how do I get it to perform halfway decent on my computer? What the hell are those black squares there for on the sprites and enemies on directx8 and why does the gl not work for shit with JDoom but ok with Zdoom and Legacy?

__________________
Doom Wad StationGet your wads here!

Old Post 11-23-02 02:13 #
Brad_tilf is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Grazza
Let's try Caesium


Posts: 12512
Registered: 07-02


The black squares sound like something I got on my notebook when I tried to run Deus Ex on it. That notebook had an ATI card, but I don't recall exactly which one - I think it was a RAGE PRO 128(?). It didn't always cope very well at all with OpenGL.

The same notebook handles Legacy's OpenGL mode fairly well, except that dynamic lighting is highly exaggerated (best to turn it off). I get the impression Legacy's requirements aren't quite so great as jDoom's.

Old Post 11-23-02 04:01 #
Grazza is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit || Quote
Brad_tilf
Redemption! Bath in its pure Light!


Posts: 984
Registered: 10-02


Aiiight - I fixed it but its why I say this particular port is a pain. First, I needed to get an update to a file that works with Jdoom to make the launcher work. Ok - fair enough. I think everything you need should be in one package. After installation and everything "apparently" working correctly, I got all that ugly stuff I described before. Finally, I decided to try and find an updated driver for my ATI card - that fixed it. Its a beautiful port - wonderfully rendered colors and the openGLis beautiful but... I think I prefer the simplicity of Zdoom and Legacy still. They are command line but come with a launcher if you so choose. Jdoom also can be launched from the command line but it is designed as a Win32 app and meant to work with a Windows launcher. I liked the launcher but it could use some additional features (such as using a browse button to find pwads ala doom95). It could also use to remember the last game you played. It always reverted back to Shareware Doom every time I shut it down and relaunched which brings me to another wish list item for this port - keep the launcher open after leaving your game. You may just want to load a differnt pwad or change a setting.
Anyway - enough bitching. It looks beautiful. Once I got the upadated driver it even ran good on my poor old computer. I may even want to design a level for it just because it does look that good.
:-)

__________________
Doom Wad StationGet your wads here!

Old Post 11-23-02 05:57 #
Brad_tilf is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit || Quote
Spike
Team Future has a new Giger-esque in the works


Posts: 2562
Registered: 04-02


The problems described earlier are indeed due to card/driver problems. I've had no problems since getting a new 3dcard, with the kickstart launcher or otherwise.
Incidently, we're making a megawad for Jdoom; check out http://the.underworld.web1000.com to see what i'm on about.

__________________
I Love the Dead. Frequently.

Old Post 11-23-02 22:27 #
Spike is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit || Quote
All times are GMT. The time now is 01:33. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > jdoom questions

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.