Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > PrBoom-Plus, ver. 2.5.1.3
Pages (72): « First ... « 61 62 63 [64] 65 66 67 » ... Last »  
Author
All times are GMT. The time now is 18:15. Post New Thread    Post A Reply
LingtheDoomGuy
Green Marine


Posts: 42
Registered: 06-12


Where do I put that in when I open the cfg file under "Sound settings"?

Also, when I tried to put it in and then run the program, it doesn't do anything. After I quit the program and open the cfg file again, "mus_opl_gain" is gone.

Old Post 12-07-12 15:44 #
LingtheDoomGuy is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
entryway
Forum Staple


Posts: 2709
Registered: 01-04



LingtheDoomGuy said:
After I quit the program and open the cfg file again, "mus_opl_gain" is gone.

You need beta version of prboom-plus.
http://prboom-plus.sourceforge.net/history.html

Old Post 12-07-12 15:50 #
entryway is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
TimeOfDeath
Forum Regular


Posts: 2512
Registered: 06-06


Feature request: What do you think about programming pr+ to make maps33-99 playable? After exiting map30 (and the intermission screen and story), it goes to map33 (if map33 exists) instead of "our hero" victory screen? And map33 goes to 34, then 35, etc? And allow idclev and -warp for 33-99?

Old Post 12-30-12 02:16 #
TimeOfDeath is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Rizera
Member


Posts: 588
Registered: 12-07


Feature request: Be able to switch fast monsters on and off while in game.

It is annoying to have to set up a a batch file just for that, unless there is some other way of turning it on that I'm not aware of.

__________________
You are very welcome to watch my Doom speed demos: http://www.youtube.com/user/1ntru

Old Post 12-30-12 02:19 #
Rizera is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
printz
CRAZY DUMB ZEALOT


Posts: 8541
Registered: 06-06


Does PrBoom+ for Mac use an outdated SDL framework? I can't run it as fullscreen in Lion. The latest SDL is 1.2.15 and it has been described that 1.2.14 wouldn't do full screen on Lion, on this thread. Note that you'd drop PowerPC support if you put 1.2.15 in the package.

__________________
Automatic Wolfenstein - Version 1.0

Old Post 12-30-12 07:13 #
printz is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
entryway
Forum Staple


Posts: 2709
Registered: 01-04



printz said:
Does PrBoom+ for Mac use an outdated SDL framework? I can't run it as fullscreen in Lion. The latest SDL is 1.2.15 and it has been described that 1.2.14 wouldn't do full screen on Lion, on this thread. Note that you'd drop PowerPC support if you put 1.2.15 in the package.

I do not know what is using on Mac. I do not know anything about Mac. Ask Neil about that.

Old Post 12-30-12 08:32 #
entryway is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
shoober
Green Marine


Posts: 35
Registered: 12-12


Does PrBoom+ support music playback via MP3 or FLAC files? I have the Doom Soundtrack in FLAC, played threw a Roland SoundCanvas SC-55 and want to use them while I play Doom. I have the files named according to this wiki page. Is there a way I can play them back while using PrBoom+?

Also, if I use the -complevel 3 command-line parameter, will it make Doom behave like it does in Ultimate Doom while I'm playing? Or just this setting only effect demo playback? Do I even need to change the compatibility settings in the options menu if I use the -complevel parameter?

Last edited by shoober on 12-31-12 at 01:10

Old Post 12-31-12 00:58 #
shoober is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
TimeOfDeath
Forum Regular


Posts: 2512
Registered: 06-06


It does support mp3, not sure about flac. One way to do it would be to download XWE from one of the mirrors, go to File->New, write a name for your music wad, then Entry->Load, and select all your music files, then close. Drag and drop the music wad file on to prboom+ for the new music.

Yes, -complevel 3 emulates ultimate doom. If you used the -complevel 3 parameter, your game will play in that complevel (you don't have to go to the menu to change it). You could also change the default compatibility in prboom-plus.cfg to 3 and then just double-click prboom-plus to start.

Old Post 12-31-12 02:06 #
TimeOfDeath is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
shoober
Green Marine


Posts: 35
Registered: 12-12


Okay cool, its a big relief that I don't have to mess around with the compatibility settings if I use the -complevel parameter. I just found out that PrBoom+ supports MP3 and OGG formats. I already have them in OGG format so I'll use that. Thank you very much for the quick response TimeOfDeath.

I was wondering why PrBoom+ is so much brighter then other source ports I have used. Is there a reason PRBoom+ is so bright? Is it supposed to look this bright?

Last edited by shoober on 12-31-12 at 03:27

Old Post 12-31-12 02:41 #
shoober is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
tempun
Member


Posts: 597
Registered: 08-09


Try pressing F11 many times

Old Post 12-31-12 11:14 #
tempun is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
printz
CRAZY DUMB ZEALOT


Posts: 8541
Registered: 06-06



entryway said:

I do not know what is using on Mac. I do not know anything about Mac. Ask Neil about that.

Where do I contact him?

__________________
Automatic Wolfenstein - Version 1.0

Old Post 12-31-12 11:24 #
printz is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Dragonsbrethren
Forum Staple


Posts: 2395
Registered: 03-09



shoober said:
I was wondering why PrBoom+ is so much brighter then other source ports I have used. Is there a reason PRBoom+ is so bright? Is it supposed to look this bright?

Its gamma correction is set to 3 by default. Like tempun said, hit F11 a couple times or set usegamma to 0 in your config.

Old Post 12-31-12 17:32 #
Dragonsbrethren is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Legend


Posts: 4785
Registered: 04-07


Maybe entryway should set it to 0 by default. I wonder how many players were scared away by overly bright levels. :)

Old Post 12-31-12 17:35 #
Memfis is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Dragonsbrethren
Forum Staple


Posts: 2395
Registered: 03-09


0 is too dark for the GL renderer with the default light mode, but I agree for prboom-plus.cfg.

Old Post 12-31-12 17:42 #
Dragonsbrethren is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
shoober
Green Marine


Posts: 35
Registered: 12-12


Wow, that looks a lot better. Thanks guys. PrBoom+ is awesome.

Old Post 12-31-12 22:04 #
shoober is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
jongo
Member


Posts: 305
Registered: 07-07


i'd personally like it to go higher than it allows now. Like, to 8 at least, it's the darkest opengl port ever.

Old Post 12-31-12 23:34 #
jongo is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Donce
Member


Posts: 547
Registered: 10-03



Rizera said:
Feature request: Be able to switch fast monsters on and off while in game.

It is annoying to have to set up a a batch file just for that, unless there is some other way of turning it on that I'm not aware of.



There is: a cheat code TNTFAST works since DOS Boom.

Old Post 01-01-13 01:05 #
Donce is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
tempun
Member


Posts: 597
Registered: 08-09



jongo said:
i'd personally like it to go higher than it allows now. Like, to 8 at least, it's the darkest opengl port ever.
Switch to GZDoom light mode

Old Post 01-01-13 08:20 #
tempun is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
blob1024
Forum Regular


Posts: 671
Registered: 05-10


sry for stupid question probably, but all of a sudden (i guess ia ctually pressed something weird accidentally while playing or the likes)
the glboom.exe doesnt ask me anymore what wad to launch, so I cant decide what to play or to -for example- start a demorecording session.
double clicking on my usual glboom link ""C:\Users\Admin\Desktop\Doom II\PrBoom 2.5.1.4\glboom-plus.exe" -complevel x -skill 4 -warp xx -record xxx" doesnt start anything beside original doom2 wad level demorecording (and also in a strange resolution I never used actually oO)

how to switch this back to normality?

Old Post 01-05-13 14:24 #
blob1024 is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Coolster
Green Marine


Posts: 34
Registered: 04-10



tempun said:
Switch to GZDoom light mode


or Fog Based (that's what im using and it looks great)

Old Post 01-05-13 16:22 #
Coolster is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Dragonsbrethren
Forum Staple


Posts: 2395
Registered: 03-09


Or shaders. (It looks better.)

Old Post 01-05-13 17:13 #
Dragonsbrethren is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Memfis
Forum Legend


Posts: 4785
Registered: 04-07


blob: did you reset all the settings to default?
For the launcher try going to glboom-plus.cfg and setting "launcher_enable" to 1.

Old Post 01-05-13 17:33 #
Memfis is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
blob1024
Forum Regular


Posts: 671
Registered: 05-10



Memfis said:
blob: did you reset all the settings to default?
For the launcher try going to glboom-plus.cfg and setting "launcher_enable" to 1.


no idea why, but yea thats what happened

thanks

Old Post 01-06-13 09:40 #
blob1024 is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
shoober
Green Marine


Posts: 35
Registered: 12-12


I have just got around to trying out PrBoom+ with the OGG files, and I ran into a problem. They play faster then they normally do. I even put the frame rate cap on and the music was still running too fast. I made my own WAD file of the music. What could have gone wrong?

EDIT:

Nevermind, I figured it out. I had to change the sound frequency from 48000 to 44100.

But there is another problem. The music will stutter when I pick up items. It will also stutter at random times. What could be causing this?

EDIT2:

I found a remedy to the problem. If I change the priority to "Above Normal", it stops the music from stuttering. I also downloaded the new 2.5.1.4 test release, which adds FLAC support. I'm currently using the Roland SoundCanvas SC-55 FLAC music pack and its working great. PrBoom+ is awesome, I love it.

Last edited by shoober on 01-06-13 at 20:01

Old Post 01-06-13 16:00 #
shoober is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
entryway
Forum Staple


Posts: 2709
Registered: 01-04



shoober said:
But there is another problem. The music will stutter when I pick up items. It will also stutter at random times. What could be causing this?

process_affinity_mask should be 0 in cfg if you are not using "sdl" music player (you should not)

Old Post 01-07-13 14:45 #
entryway is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Platinum Shell
Forum Regular


Posts: 720
Registered: 08-11


What sound player is the best for me?

All the other ones (SDL, FluidSynth, PortMIDI) stutter and get choppy a bit in the music, but mostly sound. OP2 works the best it seems, eliminating those problems, but it occasionally plays a tiny fragment of a sound that recently played at approx. 1/2-1 second after it occured.

Any way I can stamp out these issues? Thanks.

Old Post 01-14-13 13:53 #
Platinum Shell is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Xeriphas1994
Junior Member


Posts: 176
Registered: 06-07



printz said:
Where do I contact him?


I emailed him a bug report using the DW profile link, and he replied.

Old Post 01-17-13 06:20 #
Xeriphas1994 is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Sp00kyFox
Junior Member


Posts: 122
Registered: 03-10


I don't know if this is normal behaviour but I noticed some palette issues on bonus pickups with the following demo file:

http://doomedsda.us/lmps/1258/2/30sdx2556.zip
http://www.doomworld.com/idgames/index.php?id=16040

I disabled palette changes on damage and powers. The problem occurs a few times in the demo but the first one is right at the beginning in map1 where the doom marine pick ups the berserk powerup right at the start. The palette brightens up but stays at this level for nearly the rest of the map. This happens both in software and opengl mode.
Here is my config:
http://pastebin.com/NNDyc2Ua

Also got a question regarding the viddump feature. Is it possible to set another framerate than 35? At the moment I have do drop frames from the output afterwards to get the standard 30fps, which of course results in little stuttering.

edit:
noticed this issue in a few other demos also. can anyone confirm this problem?

Last edited by Sp00kyFox on 01-24-13 at 15:55

Old Post 01-21-13 18:55 #
Sp00kyFox is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
WildWeasel
Resident Castlevania Super-Fanboy


Posts: 2741
Registered: 07-03


I'm having some pretty horrible sound stuttering issues on 2.5.1.3. Settings are fresh defaults from a clean install, though I did try setting the music device to OPL2.

PC's hardware (where relevant) is the following:

Windows 7 Ultimate 64-bit
AMD Phenom II X4 955 Black (3.2 GHz)
NVIDIA High Definition Audio (device manager gives no further details about it)
Logitech USB headset
StarTech PEXHDCAP PCI Express video capture card (probably not relevant but including it anyway)
NVIDIA GeForce GTX 460 SE

I'm running PRBoom Plus in 32-bit color software.

Old Post 01-31-13 17:03 #
WildWeasel is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Platinum Shell
Forum Regular


Posts: 720
Registered: 08-11



WildWeasel said:
sound troubles

You're not the only one, man. Not quite sure what the deal is.

Old Post 01-31-13 23:22 #
Platinum Shell is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 18:15. Post New Thread    Post A Reply
Pages (72): « First ... « 61 62 63 [64] 65 66 67 » ... Last »  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > PrBoom-Plus, ver. 2.5.1.3

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.

Message Board Statistics