Demon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Doom64 EX 2.0a (Feedback Build) - Updated 3-12-11
Pages (12): « 1 2 [3] 4 5 6 » ... Last »  
Author
All times are GMT. The time now is 11:33. Post New Thread    Post A Reply
Tamhvm
Warming Up


Posts: 14
Registered: 01-11



Kaiser said:
Couldn't get the issue with the flashing lights to occur.



Me neither... I think it has to do with Akira98's hardware setup.

Nevertheless, nice job fixing some of the problems with the save games!
I finally was able to move on, minus one small curiosity.

I'm perfectly fine on MAP04, everything is nice, and then I decide to load up a previous save game (in Hectic), the game loads up perfectly.
Then I decide to go back via savegame to MAP01, and I get this:
code:
Error - P_UnArchiveMobjs: Mobj read is inconsistent

Then I run again, load that MAP01 save, everything is nice, then I load up the Hectic save, and I get the same thing.
Third chance: Loaded my MAP04 save, all is fine, then I load up the MAP01 save, and it crashes.
If I load between Hectic and MAP04, there's no problem at all.
Basically I can resume it up to:
code:
MAP04 -> Hectic = OK MAP04 -> MAP01 = NG Hectic -> MAP01 = NG Hectic -> MAP04 = OK MAP01 -> MAP04 = NG MAP01 -> Hectic = NG


I'll upload my saves when I have a chance.
Also, what is up with Hectic's BG?
http://i83.photobucket.com/albums/j315/tamhvm/sshot001.png

Old Post 01-24-11 06:35 #
Tamhvm is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00


Skies aren't affected by looking up/down. Didn't really support that since the original didn't have looking. Could probably do something about that in the future but thats considered low priority compared to the other stuff that needs to be addressed.

Also, is the savegame on map01 from an older version?

Old Post 01-24-11 15:59 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
footman
gimme DWJ3!


Posts: 1076
Registered: 03-01


Turning on Sky Pitch will make look less awkward.

Old Post 01-24-11 17:11 #
footman is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Tamhvm
Warming Up


Posts: 14
Registered: 01-11



Kaiser said:
Skies aren't affected by looking up/down. Didn't really support that since the original didn't have looking. Could probably do something about that in the future but thats considered low priority compared to the other stuff that needs to be addressed.

I knew you were going to say that, but nevertheless it felt kind of awkward seeing that flame going up and down with me.
Trust me that I agree with you, you shouldn't be able to look up and down (but I think I grew too accustomed to looking up and down in other engines).


Kaiser also said:
Also, is the savegame on map01 from an older version?

Nope, as always when you release a new version, I erase everything from the directory minus the Doom 64 ROM (thus I have to restart my game, but this goes towards the advancement of the engine).
Here's the savegame pack http://ifile.it/woj73b6. Hope it helps you in any way.

I might be saying this as I never stated it before (but I'm not having any graphic glitches so far), my video card is an ATi Radeon X700.

Last edited by Tamhvm on 01-25-11 at 03:17

Old Post 01-25-11 01:24 #
Tamhvm is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Swiss_Cheeseman
Green Marine


Posts: 35
Registered: 05-03


Any chance of a better selection of screen resolutions? Having to rearrange my desktop (I have a dual monitor setup) due to the resolution change is really bugging me. I can get it to run at 1920x1080 by forcing the resolution via the console/config file but it stretches it to 16x9 instead of either running it at the correct aspect ratio natively or running it within a pillarboxed window.

In addition I might as well request that you change the fullscreen implementation from the old-fashioned way to the more modern "full-screen window" way that a lot of games and apps are using nowadays.

Old Post 01-25-11 09:25 #
Swiss_Cheeseman is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Swiss_Cheeseman said:

In addition I might as well request that you change the fullscreen implementation from the old-fashioned way to the more modern "full-screen window" way that a lot of games and apps are using nowadays.



Out of curiosity, what is the modern method? Never knew there was a difference in how older games handled fullscreen mode.

Old Post 01-25-11 15:55 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Swiss_Cheeseman
Green Marine


Posts: 35
Registered: 05-03


I believe the method used is making a borderless window the size of the desktop. XBMC has options for both, it's possible to toggle between the two modes.

Old Post 01-25-11 23:15 #
Swiss_Cheeseman is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Akira_98
Junior Member


Posts: 120
Registered: 07-10


There's some odd behavior involving freelook, which has been easier to find with the crosshair. More screenshot spam...
http://img96.imageshack.us/img96/800/crosshairdownhigh.th.pnghttp://img194.imageshack.us/img194/3876/crosshairdownlow.th.png

All these shots were taken when aiming below the default height. In the upper area (the first screenshot), the shots were appearing below the crosshair. In the area just below, and keeping the same view angle, the shots were appearing above the crosshair. Aiming above the default height is also affected.

If you turn autoaim off, you end of firing at whatever height you were looking at, regardless of where you're looking at now.
http://img209.imageshack.us/img209/6711/autoaim1.th.png

The odd light glitch in the crusher room has been fixed with the most recent version. Not sure exactly what happened there.

Lost souls can kill each other through infighting. Now that I think about it, I actually don't know if this is normal behavior or not. =P

You can activate the automap from the pause menu.

Music never restarts when loading a savegame from the same map you are on, but it does loading from the menu. Happens every savegame I've tried.

With the pain elemental on MAP06, more often than not couldn't spawn lost souls correctly. It happens regardless of whether or not the N64 collision is being used. The pain elemental would either spawn them inside something, killing both lost souls, or spawn them inside each other, which would cause the infighting problem as they try to attack me.
http://img703.imageshack.us/img703/7376/lostsoulcollision.th.png
I've included the save file with the pain elemental in question, so it can be easily reproduced: http://files.drdteam.org/index.php/...entalglitch.zip

Old Post 01-26-11 01:56 #
Akira_98 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
DaniJ
Senior Member


Posts: 2081
Registered: 08-03



Swiss_Cheeseman said:
I believe the method used is making a borderless window the size of the desktop. XBMC has options for both, it's possible to toggle between the two modes.

Pretty much. The upcoming Doomsday 1.9.0-beta6.10 release has a similar option. This method is particularly useful for multi-display setups.

Old Post 01-26-11 03:44 #
DaniJ is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Akira_98 said:
There's some odd behavior involving freelook, which has been easier to find with the crosshair. More screenshot spam...

All these shots were taken when aiming below the default height. In the upper area (the first screenshot), the shots were appearing below the crosshair. In the area just below, and keeping the same view angle, the shots were appearing above the crosshair. Aiming above the default height is also affected.




That is mostly a d64ex 'feature'. I say feature because its the best I could do to fake bullet puffs hitting the floor and ceiling. Doom never really supported proper collision detection for ray-trace shots and Eternity's implementation to fake this was only good enough for software. I basically had to write my own method to support my engine. Its not exactly perfect and I knew that there was going to be some precision issues. Its REALLY bad in wide open spaces like in No Escape or Eye of the Storm. Sadly I am limited by lack of arithmetic skills.

This only affects where the bullet puffs are spawned though and not the actual ray-trace of your line of sight.


Edit:
Password system and autoaim option fixed
http://dl.dropbox.com/u/18609/Kex_Engine.zip

Last edited by Kaiser on 01-26-11 at 04:45

Old Post 01-26-11 04:24 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11069
Registered: 07-07


Hey Kaiser, little trivia question. I see this wiki edit and I think it'd be more accurate to say "RECT (MOTH in the Absolution TC)", wouldn't it?

Old Post 01-26-11 09:43 #
Gez is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00


To make things confusing, the sprites are named as MOTH in the TC, but is actually named as RECT in the original so its more accurate to go with that. Though the wiki itself should probably be updated with additional information sometime in the future. Also some information still pertains to the TC version so it needs to be updated anyways.

Old Post 01-26-11 15:52 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Akira_98 said:

Lost souls can kill each other through infighting. Now that I think about it, I actually don't know if this is normal behavior or not. =P

With the pain elemental on MAP06, more often than not couldn't spawn lost souls correctly. It happens regardless of whether or not the N64 collision is being used. The pain elemental would either spawn them inside something, killing both lost souls, or spawn them inside each other, which would cause the infighting problem as they try to attack me.



Confirmed to be normal behavior. Tested this on the N64 version and the pain elemental had the same trouble spitting out the lost souls. Lost souls will also infight each other.

Old Post 01-26-11 18:59 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
footman
gimme DWJ3!


Posts: 1076
Registered: 03-01


Yet another bug with passwords: Any password that gives you a backpack will quadruple your max ammo count, as opposed to simply doubling it.

Old Post 01-27-11 22:00 #
footman is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



footman said:
Yet another bug with passwords: Any password that gives you a backpack will quadruple your max ammo count, as opposed to simply doubling it.


rofl. I'll have a looksie. Can you provide that password?

Old Post 01-28-11 01:23 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
footman
gimme DWJ3!


Posts: 1076
Registered: 03-01


Pretty much any password that includes the Backpack will do it, such as the cheat password or any of the fully loaded passwords Ledmeister has on his site.

EDIT: For the hell of it, here's a non-fully loaded password that does it: LX91 CVX4 7D84 RF7Z

Old Post 01-28-11 02:22 #
footman is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Mechadon said:

- If you die near a wall and press use, the player will still make the grunting noise just like he would if he were alive. Of course directly after that the game fades out to restart the level. I just found this one out by accident and I don't think it's anything major. I didn't check to see if switches could still be pressed though.



I just confirmed that this DOES happen on the original N64 version. Not sure if I should add a compatibility fix or whatnot.

Old Post 01-29-11 01:42 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mechadon
Senior Member


Posts: 2192
Registered: 12-06


It is sort of weird but I don't suppose it's really a horrible sort of bug. I never did check to see if you could press switches though. That might be a little more worrisome but still not something game-breaking bad.

Old Post 01-29-11 01:49 #
Mechadon is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Tamhvm
Warming Up


Posts: 14
Registered: 01-11



Mechadon said:
It is sort of weird but I don't suppose it's really a horrible sort of bug. I never did check to see if you could press switches though. That might be a little more worrisome but still not something game-breaking bad.


If you didn't take the chance to find it, it would remain unknown.
Nevertheless, I think it doesn't breaks a single thing (gameplay wise) thus a compatibility fix it's not that important or need any priority.

For now, I tested the last release. It seems to work really nice.
The "P_UnArchiveMobjs: Mobj read is inconsistent" save game error still occurs (detailed info in a previous post).
Also, it seems save games from last version work in this release.

I had something to say about the fullscreen techniques but I need to research more about the programming side to properly explain what I want.

Old Post 01-29-11 03:28 #
Tamhvm is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Tamhvm said:

The "P_UnArchiveMobjs: Mobj read is inconsistent" save game



It seems like you're the only one getting this now unless others can verify that its occurring for them to. Without any way to reproduce this on my end, this will be very non-trivial to fix. I've already reviewed your savegame files and according to the hex editor, everything is in place and loads fine on my end.

Old Post 01-29-11 08:20 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Akira_98
Junior Member


Posts: 120
Registered: 07-10


I still have the savegame issue. Sometime tomorrow I can check again on a totally different machine. Since it's only affecting a couple people, here is: Specs (Chapter 2):

OS: Windows XP Professional SP3
HD: Samsung SP1604N
CPU: 2.20 GHz AMD Athlon XP 3200+
1 GB RAM
Sound Blaster Live! 24-bit

Can't think of anything else that can help in this regard.

Old Post 01-29-11 10:12 #
Akira_98 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
_bruce_
Senior Member


Posts: 1289
Registered: 11-07


"P_UnArchiveMobjs: Mobj read is inconsistent" still occurs on and off when I save/load.
Last time was on Map13.
Seems that it's more likely to occur when there are more mobs on screen... though this is an uneducated guess.
Will upload the savegame when it happens again.

Edit: played some more - the Mobj-error occurs basically at random.
The save game works, then out of the blue, the error occurs.
Restart the prog and loading the save game works for a few times - and so on.

1 crash so far - http://www.mediafire.com/?lxxerjhn9fx40k8

Last edited by _bruce_ on 01-29-11 at 23:44

Old Post 01-29-11 10:21 #
_bruce_ is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Mechadon
Senior Member


Posts: 2192
Registered: 12-06


I haven't had a chance to play this again for a while, but I'll mess around with saves/loads again soon. I'll try and see if a player can press switches when he's dead as well.

Old Post 01-29-11 18:33 #
Mechadon is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Akira_98
Junior Member


Posts: 120
Registered: 07-10


I tried on a different machine, and I'm still getting the savegame error, where I cannot load a save on any level other than the one the save was made on. Savegames:http://files.drdteam.org/index.php/...9Y/newsaves.zip

Here is the machine's specs:
Windows 7 Home 64-bit
AMD Athlon II X4 360 2.8 GHz CPU
4 GB RAM
Realtek HD Audio
Video is some craptastic on-board, which refuse to give me any details, other than "RS880".

Old Post 01-30-11 06:31 #
Akira_98 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00


Added yet another possible fix:
http://dl.dropbox.com/u/18609/Kex_Engine.zip

In this thread it turns out that certain file reading/writing routines may have contributed to the mobj inconsistencies when reading savegame files. Though I will need testers to give this another shot. Should be able to use the existing savegame files.

Old Post 01-30-11 22:50 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Tamhvm
Warming Up


Posts: 14
Registered: 01-11



Kaiser said:
Added yet another possible fix:
http://dl.dropbox.com/u/18609/Kex_Engine.zip

In this thread it turns out that certain file reading/writing routines may have contributed to the mobj inconsistencies when reading savegame files. Though I will need testers to give this another shot. Should be able to use the existing savegame files.


Sir Kaiser, I think you've got your own testing army here.
I can confirm, the savegame error still occurs (using the old savegames).
One surefire way to test it, in my case: Load my first savegame (named BEFOREH). You can walk, do whatever, minus exit the map. Load the second savegame (named HECTIC1) [NOTE: You could load any other savegame]. The error occurs.
Same in the inverse: Load any other-than-first savegame. Go around, play, and when you're ready load the first savegame. The error occurs.
You can load freely between the other-than-first savegames. I don't know what the difference is in that first savegame, maybe mobs or something, as _bruce_ said.

P.S. I saw the other thread and well, that's awesomely interesting. But I have to agree with andrewj. There are some high-level functions to abstract-ize the low-level calls. It's really unnecessary and cumbersome to say the least. Also, that tidbit about INT 21 is hilarious. I can't really figure what method/function to utilize to properly determine a file's length, beyond fstat.

Old Post 01-31-11 01:47 #
Tamhvm is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00


Try this one: http://dl.dropbox.com/u/18609/Kex_Engine.zip

You'll HAVE to re-save this time. Basically I think it could be the padding issue. If this doesn't work then I'll have to implement a thorough logging system just for this.

Whats really annoying is that I can NEVER get any error to occur on my end. I really don't know whats going on.

Old Post 01-31-11 02:27 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Akira_98
Junior Member


Posts: 120
Registered: 07-10


Unfortunately, I'm still experiencing the same save bug from...well, the whole time. I started fresh, removed everything before testing.

Also, I have a bug that I had believed was just my ears or speakers until I tested it with good headphones. Occasionally the music will only play from the left speaker. I've only tested it on my Sound Blaster Live! 24-bit.

Anyways, I have a tiny piece of good news. The autoaim bug (where the aiming would get stuck, but not the view) is a confirmed fix on my end. Another confirmed fix on my end: intermission screen while set to 'padded'. Older verify, didn't realize it needed it still. Bonus: It even works flawlessly on my Nvidia Riva TNT2 M64 (Basically the only thing).

Old Post 01-31-11 15:22 #
Akira_98 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Kaiser
Doom64 Guru


Posts: 2858
Registered: 08-00



Akira_98 said:
Unfortunately, I'm still experiencing the same save bug from...well, the whole time. I started fresh, removed everything before testing.


Upload the savegame file once again and provide detailed repro steps. From launching game up to the crash.

If I can't fix this then I will either:
a. Release the next official build with this bug present
b. Don't release the next official build until this is fixed

This is starting to become a lost cause on my end due to being unable to reproduce the crash. Unless I redesign the entire savegame system, this will probably never get fixed.

Though next time if anyone gets this crash, post what operating system you're using.

Old Post 01-31-11 15:54 #
Kaiser is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Akira_98
Junior Member


Posts: 120
Registered: 07-10


Saves: http://www.megaupload.com/?d=5WFB4TOH
Sorry for the Megaupload, DRDTeam Fileshare doesn't want to cooperate at the moment.
Save "A": At the end of map01.
Save "B": At the beginning of map02.

Repro 1:
1. Launch Doom64.exe. (Or use the launcher, irrelevant)
2. Start a new game (any difficulty, again irrelevant)
3. Attempt to load savegame "B".
Crashes for me here. (Loading savegame from map02 while at map01)

Repro 2:
1. Launch Doom64.exe. (Same as last time)
2. Load "B" from the title screen menu. (This will work for me. All savegames work from title screen menu.)
3. Once "B" loads, attempt to load savegame "A".
Crashes for me here as well. (Loading savegame from map01 while at map02)

It's the same as before. Loading a savegame from the map it was saved on, or the title screen results in a successful load. Loading a savegame from any map other than the one it was created on results in a crash.

Old Post 01-31-11 16:21 #
Akira_98 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 11:33. Post New Thread    Post A Reply
Pages (12): « 1 2 [3] 4 5 6 » ... Last »  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Doom64 EX 2.0a (Feedback Build) - Updated 3-12-11

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.