Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Sound desync in big maps (GZDoom)
 
Author
All times are GMT. The time now is 21:24. Post New Thread    Post A Reply
killer2
Member


Posts: 651
Registered: 02-10


Lately I noticed a really strange bug in GZDoom. All my 3 svn's have it. On some really large maps weird sound desync problems appear. Sometimes sounds play normally, sometimes delayed, and sometimes not at all. It also seems to only happen to some sounds...

This bug happened to me on The island 2 and also on the huge maps that come after you fight Korax in Serpent:Resurrection. I recall playing The Island 2 in 2008 and had no problems (on ZDoom). Apparently this problem also happens in ZDoom (as some people noted on Island 2's idgames page). Does anyone know any way to fix this except downloading an old as hell (G)ZDoom release?

Old Post 12-10-11 08:39 #
killer2 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
killer2
Member


Posts: 651
Registered: 02-10


Seriously, no one knows anything about this?!

Old Post 12-19-11 08:51 #
killer2 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Phml
Forum Staple


Posts: 3331
Registered: 06-09


I ran into the same problem in Sunder map04 (I think, the one with all the crushers). Perhaps increasing the number of sound channels could work? I don't know, honestly.

You'd probably be better off posting a bug report in the ZDoom forums.

Old Post 12-19-11 11:26 #
Phml is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
killer2
Member


Posts: 651
Registered: 02-10



Phml said:
Perhaps increasing the number of sound channels could work? I don't know, honestly.

Will definitely try that

Phml said:
You'd probably be better off posting a bug report in the ZDoom forums. [/B]

I already did, but thanks for the suggestion.

EDIT:Upon playing with the sound channels I managed to reduce the desync a lot. It's still like 0.3 of a second off, but it's much better than it used to be. Thank you a lot, you've been of great help!

Last edited by killer2 on 12-19-11 at 18:08

Old Post 12-19-11 18:01 #
killer2 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
killer2
Member


Posts: 651
Registered: 02-10


Managed to get it working fine right now, no more desync. If anyone is interested in how to fix this, you should make the "buffer size" and "sound channels" have a matching number. You can find both somewhere in the sound options.

Old Post 12-20-11 19:21 #
killer2 is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 21:24. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Sound desync in big maps (GZDoom)

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.