Cacodemon
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Demo loop issue
 
Author
All times are GMT. The time now is 01:37. Post New Thread    Post A Reply
Quasar
Moderator


Posts: 5757
Registered: 08-00


I noticed that Eternity displays what appears to be an incorrect help/credits screen during the demo loop, between the first and second demos, when playing with the 1.9 registered version IWAD - the registered version push ad from the shareware version is displayed.

I am curious if this is an original vanilla DOOM bug, Linux Doom bug, BOOM/MBF bug, or something I have broken myself.

Old Post 08-12-12 05:16 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15137
Registered: 04-02


It looks like a bug or change introduced after vanilla. In both registered and shareware modes Doom v1.9 shows CREDIT after the first demo and HELP2 after the second demo.

Old Post 08-12-12 06:31 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
printz
CRAZY DUMB ZEALOT


Posts: 8538
Registered: 06-06


Ultimate Doom v1.9:

TITLEPIC
DEMO1
Credits screen
DEMO2
Credits screen
DEMO3
DEMO4

Doom 2 v1.9:

TITLEPIC
DEMO1
Credits screen
DEMO2
TITLEPIC
DEMO3

These are the correct sequences. Older versions are irrelevant, people should upgrade to the latest, it's free.

Eternity sometimes shows its own credits screen instead of Doom's.

__________________
Automatic Wolfenstein - Version 1.0

Old Post 08-12-12 09:57 #
printz is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 5757
Registered: 08-00



printz said:

These are the correct sequences. Older versions are irrelevant, people should upgrade to the latest, it's free.

Eternity sometimes shows its own credits screen instead of Doom's.


Mmmm, no. Registered is still a distinct gamemode and always has been, and I'm not ripping it out. If I did, and always treated the game as if though it were running in Ultimate Doom, the game would bomb out when you tried to start a new game on E4 (no Thy Flesh Consumed). Demos from Doom 1.9 would also desync.

Old Post 08-12-12 10:51 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
DaniJ
Forum Staple


Posts: 2055
Registered: 08-03


I don't know if they are the same as vanilla but here are the scripts we use with Doomsday:

DOOM1 (inc, variants):
code:
Script { # There is no skipping during the titlescreen loop. NoSkip # Any event shows the menu. Trigger MARKER title_loop # Step 1. Patch back 0 0 "TITLEPIC" MusicOnce "intro" Wait 4.857 # Original wait is 170 tics. # Step 2. IF MODE:doom1-share PlayDemo "sdemo1.cdm" IF MODE:doom1 PlayDemo "rdemo1.cdm" IF MODE:doom1-ultimate PlayDemo "udemo1.cdm" # Step 3. Set back "CREDIT" Wait 5.714 # Original is 200 tics. # Step 4. IF MODE:doom1-share PlayDemo "sdemo2.cdm" IF MODE:doom1 PlayDemo "rdemo2.cdm" IF MODE:doom1-ultimate PlayDemo "udemo2.cdm" # Step 5. IF MODE:doom1-ultimate Set back "CREDIT" ELSE Set back "HELP2" Wait 5.714 # 200 tics. # Step 6. IF MODE:doom1-share PlayDemo "sdemo3.cdm" IF MODE:doom1 PlayDemo "rdemo3.cdm" IF MODE:doom1-ultimate PlayDemo "udemo3.cdm" # Step 7. IF MODE:doom1-ultimate PlayDemo "udemo4.cdm" GOTO title_loop };


DOOM2 (inc, variants):
code:
Script { # There is no skipping during the titlescreen loop. NoSkip # Any event shows the menu. Trigger MARKER title_loop # Step 1. Patch back 0 0 "TITLEPIC" MusicOnce "dm2ttl" Wait 13 # Original was 11; this'll play the whole song. # Step 2. PlayDemo "2demo1.cdm" # Step 3. Set back "CREDIT" Wait 5.714 # Original is 200 tics. # Step 4. PlayDemo "2demo2.cdm" # Step 5. Set back "TITLEPIC" Music "dm2ttl" Wait 13 # Original was 11. # Step 6. PlayDemo "2demo3.cdm" GOTO title_loop };

Old Post 08-12-12 11:45 #
DaniJ is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Quasar
Moderator


Posts: 5757
Registered: 08-00


EE is showing HELP2 in registered mode as well. The problem is, HELP2 seems to be the shareware ad screen in the registered IWAD :)

Is this really something that id overlooked?

Old Post 08-12-12 11:55 #
Quasar is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15137
Registered: 04-02


I'm guessing they left it there as a reminder about the shareware and an encouragement to register that people could also see on DOOM running on the computer of anyone who registered the game.

The behavior of the help screens doesn't change when you register either, as you get the ad when you hit F1 and must hit Enter to see the actual help screen. That itself is more awkward than the demo loop because if the player hits Escape instead of Enter he or she might think that's all the help option offers. They did place the menu skull on the screen to hint that Enter will activate something but that's not something everyone would notice. It would have been sensible to swap those screens in registered mode, getting HELP1 first, but maybe they were too eager to keep selling copies :p

Old Post 08-12-12 21:50 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 01:37. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Demo loop issue

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.

Message Board Statistics