Severed bunny head
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Loading Saved Games from ZDoom 2.5.0 With ZDoom 2.6.1?
 
Author
All times are GMT. The time now is 14:12. Post New Thread    Post A Reply
NiTROACTiVE
Forum Regular


Posts: 886
Registered: 03-11


I had ZDoom 2.5.0 for some time now, but when I try to load a game saved in that version with ZDoom 2.6.1, it won't let me from some reason and just says "older version". Is there a way to be able to load saved games that are from older versions or not?

__________________
Radioactive & Explosive | YouTube | deviantART | Twitter | Project: Illuminatus (32-level Megawad) [Beta Testers Wanted]
Previously Known as NitroactiveStudios

Old Post 09-01-12 04:54 #
NiTROACTiVE is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8647
Registered: 01-08



NitroactiveStudios said:
Is there a way to be able to load saved games that are from older versions or not?
Depends on how old the save is, demo and save game compatibility aren't high priority goals for ZDoom. There's a backward compatibility list and some more info here.

Old Post 09-01-12 05:19 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Maes
I like big butts!


Posts: 12386
Registered: 07-06


Short answer: no. If you have "unfinished business" with a level or entire megawad, it's advised that you finish them with the version you started them before upgrading. That's true of ANY source port, really.

Long answer: it COULD be done if Randy had no life and bothered writing converters fro and to every single version that every poor sod "left saves behind". But he has a life. And the differences between the memory layout of different ZDoom versions can be so great that the side-effects of loading (even if forced/tricked) old games won't just be minor errors.

Old Post 09-01-12 23:39 #
Maes is online now Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Graf Zahl
Why don't I have a custom title by now?!


Posts: 7711
Registered: 01-03


Savegame compatibility only gets broken if there's considerable changes to the engine's internal workings that make it impossible to load old saves.

And there have been many, many changes between 2.5 and 2.6

Old Post 09-02-12 00:00 #
Graf Zahl is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 14:12. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > Loading Saved Games from ZDoom 2.5.0 With ZDoom 2.6.1?

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.