Spider Mastermind
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > question on Zandronum command line
 
Author
All times are GMT. The time now is 04:05. Post New Thread    Post A Reply
keithktam
Junior Member


Posts: 121
Registered: 10-10


hi, i got stuck in a mod, so i decided to see if i can get through it with the help of the console command, I used ZDoom before, it allows player to use the console to gain ammo or certain item, can i do that with Zandronum?? I am trying to get a yellow key that does not exist in the level, therefore i can't get through certain doors...

many thanks in advance
keith

Old Post 08-13-13 12:31 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08


Try "give yellowcard" or "give yellowskull", and penalize yourself 50% of your score for cheating.

Old Post 08-13-13 13:29 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10



GreyGhost said:
Try "give yellowcard" or "give yellowskull", and penalize yourself 50% of your score for cheating.


thanks man! I will!! don't know if you have played Astrostein, on the level "the forcus", i swear their no yellow key, I used IDCLIP to "ghost" the level, and after a significant effort, I found no yellow key, their could be two possible explanation since it is a mod, is either the guy forgot to put it there, or its there somewhere, but since I am using Zandronum to run it, it may affect things like the location of the key, that could be cause if somehow the floor is raised higher or lower, what i am saying it, may be it was alright when the guy did it, but the translation through different source port might cause problems... dunno, while the game has various flaws and certainly ain't perfect, I am impressed with the mod and the guy though!!

Old Post 08-13-13 14:40 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Graf Zahl
Why don't I have a custom title by now?!


Posts: 7694
Registered: 01-03


Can you make a screeshot of the level's automap? I'm not sure which one it is but I can't remember not finding a key on any of them. If I see the level's layout I might give you a hint where the key is.

Old Post 08-13-13 15:02 #
Graf Zahl is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08



keithktam said:
Astrostein, on the level "the forcus", i swear their no yellow key
If that's Map04, there is a yellow key but it's not in plain sight, and you might appreciate some protective clothing (if available) before going after it.

Old Post 08-13-13 15:27 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10



Graf Zahl said:
Can you make a screeshot of the level's automap? I'm not sure which one it is but I can't remember not finding a key on any of them. If I see the level's layout I might give you a hint where the key is.


here the map, thanks!!!

http://imageshack.us/photo/my-images/266/ty3a.jpg/

Old Post 08-14-13 10:32 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08


Yep - that's Map04.

ImageShack is going to Hell in a handbasket! Has anyone managed to remove this pop-up using the close gadget, or have I blocked too much of their other crap for that to work?

http://www.mediafire.com/convkey/ec4c/wig8p1718pkqzge4g.jpg
(Thumbnail)

Old Post 08-14-13 11:19 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Graf Zahl
Why don't I have a custom title by now?!


Posts: 7694
Registered: 01-03



GreyGhost said:
If that's Map04, there is a yellow key but it's not in plain sight, and you might appreciate some protective clothing (if available) before going after it.


Precisely. The key is there, but it's quite well hidden in a place you wouldn't normally want to go. (Hint: It's not too far away from the yellow doors to the engine room so you do not have to search the entire map for it.)



GreyGhost said:
[B]Yep - that's Map04.

ImageShack is going to Hell in a handbasket! Has anyone managed to remove this pop-up using the close gadget, or have I blocked too much of their other crap for that to work?



You need to allow Javascript for all to get rid of it. That site should be boycotted. It has become completely useless for images.

Old Post 08-14-13 11:34 #
Graf Zahl is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10



Graf Zahl said:


Precisely. The key is there, but it's quite well hidden in a place you wouldn't normally want to go. (Hint: It's not too far away from the yellow doors to the engine room so you do not have to search the entire map for it.)



i was suspecting it in either of the "particle accelerator" at east side of the map, two of them actually, both with a hanged corpse, I die trying, of course, literally. I always got blocked by the corpses, i tried using IDCLIP and IDDQD to just test to see if my theory was correct, but with no avail... it lead to accidental discovery though, I found tow arch vile and two pain elementals hiding around the bottom of those reddish lines things... still no luck...

update: I found it it is actually in the place i suspected it, and i would like to point out that i did go there to try to find the key in the first place, and died many times because the stupid corpse blocked my path, this is what i have been talking about have bugs in the game or in the source port, I am pretty sure, the game is designed to let the player pass the corpse, and this is not the first time, it seems with Zandronum port, some of the sprites that hanged from the ceiling, for example, the police/fire alarm, or the CCTV like plasma shooter, these sprites would block your path, at first, I didn't know care that much, is a mod after all, and is not really affecting gameplay until now... and another thing i would also like to point out is that the plasma shooter i mentioned above, it didn't work, no plasma shooting from it what so ever, so naturally i thought it was a CCTV, a decoration if you know what I mean??

and speaking of port, which one did you guys play with the Astrostein??

cheers

Last edited by keithktam on 08-14-13 at 13:34

Old Post 08-14-13 12:52 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10


man, got stuck againnnnn!! i am now at map6 crasher... everything went fine, beat the two green headed medic bot, went back in the hallway i originally encountered them, pressed the red button to release the two blockade, got on with the game, found the yellow key, then... when i had to go pass that same corridor, the two blockades automatically went back up again, except this time that same red button would not work.... and I am stuck again!! you see, my problem is that of my paranoia, cause i am always thinking that, ok, is a mod, and i am playing with a different source port (Zandronum), so there might be bugs and errors?? so can you nice people at least tell me I am wrong about the bug of this level and i would then try harder...i want to cry....

Old Post 08-14-13 12:59 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10


and yeah, (don't mean to spam, is better with a new slot), the same kind of bug occurred at the very first level where if you press that red button on the wall before the acquirement of blue or red key, can't remember, the blockage would rise up and the back door wouldn't open cause you don't have the key, and damn it i tried pressing space button on every segment of the walls, nothing happen... but now speaking of it, I did experience an annoying thing that took me a long time to figure, there was one level where the red button would not work and you have to shoot it... could this be the case guys??

Old Post 08-14-13 13:07 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08



Graf Zahl said:
You need to allow Javascript for all to get rid of it. That site should be boycotted.
That explains it, I'm using a combination of NoScript and AdBlock Plus to keep unnecessary eyesores to a minimum. Looks like I'll be joining the boycott.


keithktam said:
I found it it is actually in the place i suspected it, and i would like to point out that i did go there to try to find the key in the first place, and died many times because the stupid corpse blocked my path, this is what i have been talking about have bugs in the game or in the source port, I am pretty sure, the game is designed to let the player pass the corpse, and this is not the first time, it seems with Zandronum port, some of the sprites that hanged from the ceiling, for example, the police/fire alarm, or the CCTV like plasma shooter, these sprites would block your path
I played the map last night and those corpses are an error, the Macintosh version has a skeleton in a cage and it's undoubtedly meant to be non-blocking - I'll investigate further. As for other overhead obstacles that you'd expect to be able to walk under, it's not only Zandronum that's affected.


there was one level where the red button would not work and you have to shoot it... could this be the case guys??
Yes, you will occasionally encounter shootable switches.

Old Post 08-15-13 07:49 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
SavageCorona
Member


Posts: 459
Registered: 07-13



GreyGhost said:
ImageShack is going to Hell in a handbasket! Has anyone managed to remove this pop-up using the close gadget, or have I blocked too much of their other crap for that to work?
(Thumbnail)



I assume you use NotScripts? Unblock imageshack.us and it'll enable the script that closes it.

__________________
Watch my videos for some British gaming
LINK TO MY BLOODY CHANNEL MATE
Go on my Twitter for some funnies and newses
'ERE'S THE BLOODY LINK TO ME TWITTERS

Old Post 08-18-13 23:05 #
SavageCorona is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08


Unblocking that script also results in banks of thumbnails for stuff I'm not the least interested in appearing on the page, which is probably why I blocked that script in the first place.


keithktam said:
I am pretty sure, the game is designed to let the player pass the corpse
You shouldn't even be seeing a corpse, let alone being blocked by it.

some of the sprites that hanged from the ceiling, for example, the police/fire alarm, or the CCTV like plasma shooter, these sprites would block your path
They shouldn't, since they're not flagged as obstacles.

another thing i would also like to point out is that the plasma shooter i mentioned above, it didn't work, no plasma shooting from it what so ever, so naturally i thought it was a CCTV, a decoration if you know what I mean??
Looks like they're also supposed to run along tracks on the ceiling, though I don't know what keeps them there.

After spending some more time wandering around Map04, I don't know if there's something fundamentally wrong with astro.deh that I haven't picked up on yet or if DehackEd support in source ports is patchier than I thought, so far the only port I've tested that doesn't appear to have issues with the patch is Legacy. There's too many sprite issues for normal play with Chocolate but it at least handles the "hanging corpse", overhead lights and item pickups correctly. Edge v1.35 also showed promise until I realized it was impossible to shoot (or be shot by) anything outside the sector I'm standing in, apart from having a map full of invisible ballistic shields things seemed to be working properly. I think every other port I tested that map in suffered the same problems keithtam reported, as well as using the standard Doom names for item pickups.

Any suggestions - apart from abandoning DehackEd and cobbling together a patch to support the more advanced ports?

Old Post 08-20-13 09:29 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Vermil
Senior Member


Posts: 1667
Registered: 03-04


Both Doomsday and GZDoom don't seem to have any issues with the astro.deh.

Some of Keithktam's issues sound like he is actually not loading the deh file at all.

Also, note that there is also a second mod inside the Astrostein zip with it's own graphics and deh; Portal.

Old Post 08-20-13 12:08 #
Vermil is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Graf Zahl
Why don't I have a custom title by now?!


Posts: 7694
Registered: 01-03


Who knows?

Skulltag has been known to do some ill-advised code changes and some of those probably have survived to this day in Zandronum.

Old Post 08-20-13 12:10 #
Graf Zahl is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08



Vermil said:
Some of Keithktam's issues sound like he is actually not loading the deh file at all.
Or miss-using a wad launcher, which has been my major brain fart for the week. I'd forgotten how few ports recognize deh/bex patches by their filename suffix. :(

@keithktam - that patch should work correctly if you select it AND astro.wad then drag'n'drop them onto Zandronum. How have you been running them until now?

Old Post 08-20-13 15:34 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10



GreyGhost said:
Or miss-using a wad launcher, which has been my major brain fart for the week. I'd forgotten how few ports recognize deh/bex patches by their filename suffix. :(

@keithktam - that patch should work correctly if you select it AND astro.wad then drag'n'drop them onto Zandronum. How have you been running them until now?



well, i am using win7, and i set it (actually it set itself...) to be opened by Zandronum... thats how i play astro... at first i didn't not recognize any weird stuffs going on, so I assume thats the way to open the wad...

and another strange anomaly is that if a clip, like a bullet/laser clip happened to be sitting in between door, when the door came down, that clip turned into corpse that looks like its came from a rocket kill, a pile of flesh... very strange, must be an error during a "translation" within Zandronum...

Old Post 08-21-13 13:13 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
keithktam
Junior Member


Posts: 121
Registered: 10-10



GreyGhost said:

After spending some more time wandering around Map04, I don't know if there's something fundamentally wrong with astro.deh that I haven't picked up on yet or if DehackEd support in source ports is patchier than I thought, so far the only port I've tested that doesn't appear to have issues with the patch is Legacy. There's too many sprite issues for normal play with Chocolate but it at least handles the "hanging corpse", overhead lights and item pickups correctly. Edge v1.35 also showed promise until I realized it was impossible to shoot (or be shot by) anything outside the sector I'm standing in, apart from having a map full of invisible ballistic shields things seemed to be working properly. I think every other port I tested that map in suffered the same problems keithtam reported, as well as using the standard Doom names for item pickups.

Any suggestions - apart from abandoning DehackEd and cobbling together a patch to support the more advanced ports?



if Legacy is a port, then i might consider using it instead...

Old Post 08-21-13 13:15 #
keithktam is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
GreyGhost
Why don't I have a custom title by now?!


Posts: 8574
Registered: 01-08


Yep - Legacy is a port, the old 1.4* codebase is currently being worked on by the forum's own wesleyjohnson. It's fairly stable so you might like to give it a run.

If you're otherwise happy with Zandronum, instead of switching ports what you can do is open astro.wad in your favorite wad editor, import astro.deh (using Import Files in the Archive menu) and rename it dehacked. Move it up above the MAP01 marker so there's no interfering with map loading, save and close the wad, then you should be ready to go since Zandronum will automatically load DehackEd patches when they're embedded in wads.

I've noticed the occasional puddle of gore and that's something which could probably have been eliminated in astro.deh.

Old Post 08-21-13 14:36 #
GreyGhost is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 04:05. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Source Ports > question on Zandronum command line

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.