Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > Putrefier
Pages (2): « 1 [2]  
Author
All times are GMT. The time now is 22:45. Post New Thread    Post A Reply
Gez
Why don't I have a custom title by now?!


Posts: 11214
Registered: 07-07


Sorry to say, but that looks like a problem with your hardware and/or OpenGL drivers.

Try gzdoom -nomusic -iwad doom2; without loading any mod. Do the textures and sprites glitch again?

Old Post 01-28-13 19:14 #
Gez is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Kirby
Senior Member


Posts: 1586
Registered: 10-04



Gez said:
Sorry to say, but that looks like a problem with your hardware and/or OpenGL drivers.

Try gzdoom -nomusic -iwad doom2; without loading any mod. Do the textures and sprites glitch again?



Im having the same problems as rrwoods. Albeit I know my graphics card is not great for this at all (Intel Graphics Integrated 3000) but I can play other wads just fine. Maybe it has to do with the amount of linedefs?

Using your command line parameters all looks and plays good as well with no problems

Old Post 01-28-13 23:03 #
Kirby is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
kristus
Megablast!


Posts: 10620
Registered: 07-00


More likely to have something to do with the textures then.

Old Post 01-29-13 00:32 #
kristus is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
rrwoods
Mini-Member


Posts: 52
Registered: 10-05


Running doom2 works fine. I've tried fullscreening and reducing the resolution, together and separately.

I notice in the console that it's picking up my onboard graphics card though (GL_RENDERER: MOBILE INTEL(R) HD GRAPHICS), and I've got an AMD Radeon HD 6490M. Any way I can tell gzdoom to use a different graphics card?

(Don't know if this is what Kirby is experiencing)

Old Post 01-29-13 01:41 #
rrwoods is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
MarcoLambda
Warming Up


Posts: 22
Registered: 01-13


I must say your work is impressive. Very deatailed. I like that

Old Post 01-29-13 02:34 #
MarcoLambda is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Ed
Senior Member


Posts: 1276
Registered: 07-01


Try bumping down the texture filtering to linear. My girlfriend's laptop had that problem, disabling trilinear filtering seemed to do the trick.

Sorry, Putrefier is a bit of a problem child it seems.

Old Post 01-29-13 05:49 #
Ed is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
rrwoods
Mini-Member


Posts: 52
Registered: 10-05


I had to turn off the GL renderer :-/ Will that ruin any special effects on this map?

Old Post 01-29-13 17:58 #
rrwoods is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11214
Registered: 07-07


Yes. There are dynamic lights, sloped 3D floors, and 3D models, IIRC. All things that will not render in software.

Old Post 01-29-13 18:17 #
Gez is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
rrwoods
Mini-Member


Posts: 52
Registered: 10-05


http://forum.drdteam.org/viewtopic.php?f=22&t=6038

The Samsung Series 7 causes OpenGL applications to use the onboard graphics card, and there is no solution out-of-the-box. They have released a fix (as mentioned in that thread), we'll see if it helps at all.

This explains why turning off OpenGL in GZDoom (vid_renderer 0) will cause the textures to work properly; it's probably switching to my dedicated card.

Again, don't know if this is what Kirby is experiencing but maybe.

Old Post 01-31-13 20:22 #
rrwoods is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Gez
Why don't I have a custom title by now?!


Posts: 11214
Registered: 07-07


As I posted in the DRD Team thread, you might want to try putting this opengl32.dll in the GZDoom directory. It'll wrap the instructions to DirectX calls, which should trigger the autoswitch on those faulty Samsungs. (The other wrappers I listed over there are older and less likely to be useful.)

Old Post 01-31-13 20:50 #
Gez is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
rrwoods
Mini-Member


Posts: 52
Registered: 10-05


Ah, I hadn't seen that before installing the fix. I actually now have real control over whether I want an application to use a specific graphics card, which is nice. Good to know there's a software workaround as well though.

Remains to be seen whether it causes Putrefier to work yet, I'll have time to check that out a bit later.

EDIT: Sweet, I see sprites and beautiful texturing!

Last edited by rrwoods on 02-01-13 at 12:46

Old Post 01-31-13 20:57 #
rrwoods is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Sokoro
Member


Posts: 367
Registered: 10-10


I am stuck... You know that switch behind the barrier close to megasphere secret? I just used it and there do not seem to be anything opened by that. I can not access red card yet.. No idea where to go, I guess that doomguy will have to shot himself with shotgun to save himself from terrible death by starvation. He would probably die even faster because I do not think that the water in starting area is drinkable.

Old Post 08-04-13 20:14 #
Sokoro is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
joe-ilya
Nescient Member


Posts: 2302
Registered: 10-12


Looks good and awesome , but it's really boring to play , I stopped after the third switch.

Old Post 08-04-13 21:41 #
joe-ilya is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Sokoro
Member


Posts: 367
Registered: 10-10


Ok, so I finished it and it was fun.

Lot of interesting visuals and effects, like that bloody room where you find shotgun, or the meaty thing which swallowed a screen, those little buildings which are outside of room with red key..
And of course the final area with the display which wrote something about vallhala.
I guess you made that map too.

Gameplay was mostly well balanced. Some encounters suprised me at first, but were not that hard when I retried them. I had to reload a save several times at cyberdemon fight until I realised that it is much easier to just dodge the rockets and constantly shoot from plasmagun, than hiding behind corners.

Found a neat trick, or rather glitch at final boss, the generator like thing.. which shoot like some sort of lava fountain.
You just need to climb up to it and hide behind it, then it start to shoot itself without harming you.

So, thank you for the map :)

Old Post 08-06-13 14:07 #
Sokoro is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 22:45. Post New Thread    Post A Reply
Pages (2): « 1 [2]  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > Putrefier

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.