Doom monster
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > Doom 2 In Name Only - Now (supsiciously) on a load of gaming articles
Pages (102): « First ... « 91 92 93 [94] 95 96 97 » ... Last »  
Author
All times are GMT. The time now is 18:18. Post New Thread    Post A Reply
EffinghamHuffnagel
Junior Member


Posts: 161
Registered: 12-12


You're all very welcome. A man's got to know what he's good at to get through life. I've always been more of a Watson, than a Holmes. I don't create, I help others with their work. I've spent my working life helping others; in Customer Service, in Systems Support (maintaining document and file versions, making changes and moving them to production), as a Corporate Software Beta Tester and in IS (break/fix, install, upgrade). Right now I had a couple of weeks with some free time almost every day. In two weeks I probably won't. Aside from Obsidian's speedmap megawad, this is the first time I've actually jumped in and helped on a project before it was released. Sometimes I've e-mailed notes to the author afterwards. Usually, I just put the notes in a folder and make the fixes for my own benefit. I still have notes on 2002ADO from 12 years ago I never sent anyone. Always wondered if the authors found all the bugs on their own by the 3rd release.

Thanks for letting a new guy jump in and finally give back a little and thanks for making me feel welcome.

Old Post 05-14-14 23:01 #
EffinghamHuffnagel is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


Doom 2 In Name Only - Day 637
Beta VIII is here. With Da Werecat's graphics, all the fixes highlighted by Effingham and plums, it is possible that this project is finally finished.
Except MAP01. I'm still not sure if the disappearing monsters are fixed.

Old Post 05-15-14 16:13 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
mouldy
Senior Member


Posts: 1586
Registered: 02-12



Eris Falling said:
Doom 2 In Name Only - Day 637
Beta VIII is here. With Da Werecat's graphics, all the fixes highlighted by Effingham and plums, it is possible that this project is finally finished.
Except MAP01. I'm still not sure if the disappearing monsters are fixed.



Cool, although it is missing the updates to 28 and 30 that I posted the other day, you can find them here:
http://www.mediafire.com/download/3...pdates13may.zip

Old Post 05-15-14 17:20 #
mouldy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


Always something :P
Fixed. Same link.

Old Post 05-15-14 17:30 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
scifista42
Senior Member


Posts: 2335
Registered: 05-12


Somebody has broken MAP19's bridge gimmick. PrBoom-plus crashes upon launching the wad because: "createPatch: Unknown patch format TITLEPIC." O_O

Old Post 05-15-14 17:44 #
scifista42 is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
cannonball
Senior Member


Posts: 2257
Registered: 07-11



scifista42 said:
Somebody has broken MAP19's bridge gimmick. PrBoom-plus crashes upon launching the wad because: "createPatch: Unknown patch format TITLEPIC." O_O

Yep I get the same problem

Old Post 05-15-14 17:49 #
cannonball is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


Removed link for now
Scifista, about MAP19, can you please elaborate? I think I was the only one who touched that map and I'm pretty sure nothing I did would've broken anything.

Old Post 05-15-14 17:53 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
scifista42
Senior Member


Posts: 2335
Registered: 05-12


Entrance to the Citadel opens immediately, but it should open only after the HKs and Barons are dead. This problem doesn't occur in my own latest version of the wad. Also a certain ammo box lies on the descending grass field, while it should have sit in a pit.

I'll try to look at it closer soon.

Old Post 05-15-14 18:02 #
scifista42 is online now Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
mouldy
Senior Member


Posts: 1586
Registered: 02-12


Here's the problem with map 19:

https://www.mediafire.com/convkey/4712/d2641sko6enc77n4g.jpg

Top is how it was, bottom is how it is now. There are sectors over the top of the teleport pads that are meant to stop the floor from rising when a monster is there.

Old Post 05-15-14 18:09 #
mouldy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


Ah, those platforms along the bridge had some extra linedefs (triangles) on them I believe. To me they looked like they served no function so I removed them. Whoops.

Oh, it's those linedefs that were reported as absorbing projectiles. Hmm.

Old Post 05-15-14 18:12 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
mouldy
Senior Member


Posts: 1586
Registered: 02-12


Also looks like the TITLEPIC is a png file, which is probably why prboom is crashing (CREDIT is as well)

Old Post 05-15-14 18:16 #
mouldy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


A small wad with working gfx.

https://drive.google.com/file/d/0B9...dit?usp=sharing

Old Post 05-15-14 18:16 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


I've already converted them to Doom format since, but thanks anyway Werecat. Are there any changes to the graphics themselves?

Old Post 05-15-14 18:21 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


TITLEPIC is cropped slightly differently, but nothing really important.

Old Post 05-15-14 18:27 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
EffinghamHuffnagel
Junior Member


Posts: 161
Registered: 12-12


I just noticed this. Why is the D2INO_B8.deh file in the zip not the same as the DEHACKED entry in the wad? The one in the zip has two additional entries not in the wad:

Thing 25 (Commander Keen)
Bits = 774

Frame 763
Duration = 0
Next frame = 0

Is that what was causing the missing monsters in MAP31?

Old Post 05-15-14 18:31 #
EffinghamHuffnagel is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


That would be me replacing the external DEH with Xaser's more recent one, and forgetting there was an embedded DEH too.
Okay, I'll make it easier for everyone

List the things I didn't break/miss

Old Post 05-15-14 18:36 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
EffinghamHuffnagel
Junior Member


Posts: 161
Registered: 12-12


I still had MAP34 loaded in my editor, so when I opened it, I saw a note I missed. On the cliff edges near linedef tag 56, the author used BFALL1 for all the falling lava instead of DBRAIN1.

Old Post 05-15-14 19:37 #
EffinghamHuffnagel is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


Saw this in Waste Tunnels. It's a secret room.

http://i.imgur.com/pa568nK.png

1. Walls connect to the slime floor in an ugly way.
2. The floor is not damaging. Actually, I can understand this problem: there's no way to make a sector both secret and damaging with only vanilla assets. So I guess I shouldn't whine.

Old Post 05-15-14 21:43 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
glenzinho
Forum Regular


Posts: 731
Registered: 09-11


Can't you have secret and damaging by way of dummy sector?

Old Post 05-15-14 22:05 #
glenzinho is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
EffinghamHuffnagel
Junior Member


Posts: 161
Registered: 12-12



Eris Falling said:
Except MAP01. I'm still not sure if the disappearing monsters are fixed.


Yes, it's fixed. The two imps no longer fall into holes.

Old Post 05-15-14 22:55 #
EffinghamHuffnagel is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


I got stuck on MAP07 in ZDoom. The stairs rose too high.

Old Post 05-17-14 18:18 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Eris Falling
Forum Staple


Posts: 3038
Registered: 07-12


That was one I left out. Can't remember the reasoning off the top of my head.

And scifista, if you're reading this: I'd rather you took B8's version and put the techy stuff back in yourself. I don't know the mechanism.

Old Post 05-17-14 18:35 #
Eris Falling is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


So it can't be fixed?

Old Post 05-17-14 19:13 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
mouldy
Senior Member


Posts: 1586
Registered: 02-12



Da Werecat said:
I got stuck on MAP07 in ZDoom. The stairs rose too high.


Was there a reason why the stairs couldn't just be given lift-lower-wait-raise actions on its outside linedefs, for when this bug happpens? I don't see that it would effect anything else.

Old Post 05-17-14 19:59 #
mouldy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Antroid
Senior Member


Posts: 1500
Registered: 09-07



mouldy said:
Was there a reason why the stairs couldn't just be given lift-lower-wait-raise actions on its outside linedefs, for when this bug happpens? I don't see that it would effect anything else.

Is there a chance of the sectors not moving up upon the required monsters' death if the lift is used at an inopportune time? Like even if they are totally in the floor, isn't there some pause between the two clicks they would do anyways if used, during which if the special action happens it will do nothing? Or am I misunderstanding how those things work?

Old Post 05-17-14 20:50 #
Antroid is offline Profile || Blog || PM || Email || Search || Add Buddy IP || Edit/Delete || Quote
plums
Senior Member


Posts: 2011
Registered: 08-13



Da Werecat said:
I got stuck on MAP07 in ZDoom. The stairs rose too high.


Did you try playing it with the "Use Buggier Stair Building" compatibility option turned on?

If that works, it's a thing that can be enabled by default with a MAPINFO lump.

Old Post 05-17-14 21:05 #
plums is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Da Werecat
Senior Member


Posts: 1296
Registered: 11-09


Technically, it's not a stair, it's a bunch of platforms with tag 667. They're rising multiple times with some complex arch-vile trickery. Which is not entirely reliable, as far as I can see.

Old Post 05-17-14 21:19 #
Da Werecat is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
plums
Senior Member


Posts: 2011
Registered: 08-13


Oh, I might know what's going on.

667 sectors rise to the height of the shortest lower texture of any linedef of that sector. However Doom interprets 'no texture' as AASHITTY, even for linedefs that don't need a texture on the other side, so stairs rise a max of 64 units. ZDoom fixes this 'bug', meaning if all the lower textures are > 64 units, the 667 sectors will rise higher than they would in vanilla.

The easy fix is to put a 64 px high texture as a lower texture on all the sectors marked 667, even if it's on the back linedef that will never need a lower texture.

If I didn't explain that well enough, I can make an example wad (or even just try to fix MAP07 myself, if requested).


edit: Actually looking at the map, that might not be the problem, since I see BRNSMAL1 used on some linedefs. Hmm, nevermind maybe...

Last edited by plums on 05-17-14 at 21:43

Old Post 05-17-14 21:28 #
plums is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
mouldy
Senior Member


Posts: 1586
Registered: 02-12



Antroid said:

Is there a chance of the sectors not moving up upon the required monsters' death if the lift is used at an inopportune time? Like even if they are totally in the floor, isn't there some pause between the two clicks they would do anyways if used, during which if the special action happens it will do nothing? Or am I misunderstanding how those things work?



yeah I just tested it and you are right, if you activated the lift and then killed the last spider the stairs won't rise.

There are probably other more complicated solutions to this, for example having a monster on a dummy 667 sector who can cross a linedef in the event of his platform raising twice, thereby activating something that will allow the player to escape.

Old Post 05-17-14 22:03 #
mouldy is online now Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
plums
Senior Member


Posts: 2011
Registered: 08-13


Since the problem appears to be semi-random, I may as well point out that in vanilla, killing the last two arachnotrons very close to one another but not at the same time can cause 667 sectors to raise twice. So I guess having some workarounds isn't a bad idea anyhow.

Sorry for my earlier posts, I should really check the map before guessing at what the problem is :p

Old Post 05-17-14 22:56 #
plums is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 18:18. Post New Thread    Post A Reply
Pages (102): « First ... « 91 92 93 [94] 95 96 97 » ... Last »  
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > WADs & Mods > Doom 2 In Name Only - Now (supsiciously) on a load of gaming articles

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.