Spider Mastermind
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > Problem: Extremely high count of lumps in a PWAD results in particular error
 
Author
All times are GMT. The time now is 12:22. Post New Thread    Post A Reply
Doom Marine
took his ball and went home


Posts: 1653
Registered: 09-03


XWE 1.15 stops importing and displaying Flats properly when the lump count exceeded 2,790... just to confirm my case, I ran XWE on two different computers, both of which followed the same protocol upon the insertion of a new Flat:

1) Opened up my PWAD with XWE 1.15.

2) Entry ----> Load.

3) Loaded a 64x64 bitmap.

4) Received the following message: "File was still open."

5) Followed by: "Read beyond end of file."

I closed my PWAD and opened it again, scrolled to the newly uploaded flat, lo and behold it turned into a tutti-frutti patch with 165x165 dimensions.

I've converted over 800 flats with this procedure, and weird things only started to happen recently with XWE as my lump count skyrockets.

Hopefully you'll spot this problem too.

Thank you for your time.

Old Post 08-12-05 08:16 #
Doom Marine is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Csabo
Moderator


Posts: 541
Registered: 02-02


I've tested XWE with WADs that have a lot more entries and did not run into any problems. It's possible that there's a particular problem with the WAD you're using. You could email the WAD file to me and I can check it out for you.

Old Post 08-12-05 18:55 #
Csabo is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Doom Marine
took his ball and went home


Posts: 1653
Registered: 09-03


Sure, I'm emailing the WAD zip to you right now. It's about 14 MB zipped.

Old Post 08-12-05 20:41 #
Doom Marine is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Csabo
Moderator


Posts: 541
Registered: 02-02


Got WAD your file. First something a bit off topic: I couldn't figure out why everyone who emails me keeps using my old web-based email account, since I changed the email link on the XWE homepage months ago. Finally it hit me: I didn't update the profile here at doomworld (well now it's updated). If you would have sent it to my new address I would have gotten it.

Anyway, as a first try, I imported >100 large test bitmaps, no problems whatsoever. XWE's internal lump limit in one WAD is actually 50000, so you're nowhere near yet. Your WAD is very large though, the only thing I can think of is your computer running out of resources. Did you try turning off undo from the options menu? For a WAD this large you'd probably want to do that.

To be sure that it's your WAD's size, you could try this: make a copy of your Doom2.WAD, and edit it. That has almost 3000 entries BTW, more than your WAD, but the file size is smaller. Import some images, it should be fine. Let me know how it goes.

Old Post 08-14-05 01:48 #
Csabo is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Doom Marine
took his ball and went home


Posts: 1653
Registered: 09-03



Csabo said:
Did you try turning off undo from the options menu?


The only options menu I found was through XWE-->View-->Options...
And I didn't see "undo", unless one of the general options is related to undo... I'm clueless, please spell it out for me :)

Old Post 08-14-05 06:15 #
Doom Marine is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Csabo
Moderator


Posts: 541
Registered: 02-02


Grab the latest version of XWE from here: http://ca.geocities.com/xwe@rogers.com/xwe_beta.zip. This has a new option which lets you disable Undo. Regardless, did importing into a copy of the Doom2 WAD work?

Old Post 08-14-05 23:15 #
Csabo is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Scuba Steve


Posts: 3923
Registered: 11-02


What about that new option you added to eliminate writing to a backup and write directly to the wad itself?

Old Post 08-15-05 05:53 #
Scuba Steve is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 12:22. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > Problem: Extremely high count of lumps in a PWAD results in particular error

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.