Icon of Sin / Baphomet
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > Steps for Texture Editing ....
 
Author
All times are GMT. The time now is 01:11. Post New Thread    Post A Reply
ReX
Senior Member


Posts: 1743
Registered: 05-00


Csabo, someone had a question on inserting textures into a wad in a manner that would not replace existing textures. I have listed the steps using XWE in this thread. Please review the steps and let me know if I did not get anything right. If it's good I'd like to put this up on my site as one of my many tutorials for newbies.

Also, I vaguely remember having a discussion with you when you were first developing XWE, where you were surprised that there was no provision to automatically insert TEXTURE and PNAMES lumps into a wad. [The way I currently do it is to open doom.wad or doom2.wad and save the lumps, then load those lumps into my PWAD.] I could not find an easier way to insert these lumps. Let me know if I'm not looking in the right place.

Old Post 08-28-06 23:52 #
ReX is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Csabo
Moderator


Posts: 541
Registered: 02-02


Hey ReX,

From the thread it looks like the original question is just regarding importing new textures. If that's all you need to do, it can be done in a lot less steps. Just one, really: double-click the PATCHES button from the Filter toolbar. This will let you import all your textures (as long as they are in one folder), it creates the PP_START/PP_END entries, adds them to the PNAMES and TEXTURE1 lumps (grabs those from the main WAD if they are not yet present).

I revamped the XWE's help file a while back, it's much better than it used to be (I hope). In the "Documentation" section I tried to cover basics of WAD editing. I'd like add more though, so if you (or anyone else) comes up with tutorials, I'd be happy to add it.

Old Post 08-30-06 03:04 #
Csabo is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
ReX
Senior Member


Posts: 1743
Registered: 05-00


Csabo, I tried what you suggested (I'm still using v1.15) and got this error message:

Access violation at address 00403E20 in module 'XWE.EXE'. Write of address 00000024.

It imported the last graphic from the list I had selected in my textures folder, and inserted a TEXTURE1 and a PNAMES entry. However, neither of these entries included the patch that had been imported.

Then I repeated the double-click maneuver and selected all but the last of the graphics (which had already been imported in the first try). This time it imported all of the graphics just fine, and the TEXTURE1 and PNAMES entry included all the graphics. [The first one that had been imported during the first try was still missing.]

Tomorrow I will download v1.16 and try this thing again.

Old Post 08-30-06 03:39 #
ReX is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 01:11. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > Steps for Texture Editing ....

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.