Weird impy thing
Register | User Profile | Member List | F.A.Q | Privacy Policy | New Blog | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > XWE Problem(s)
 
Author
All times are GMT. The time now is 01:47. Post New Thread    Post A Reply
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Ok, just got back an all, but on to the issue:

My XWE is having serious issues, first was I get the whole "List index out of Bound (0)" and then I tried opening one of my maps, but it gave the same thing except with a 3 instead of 0.

Now the other issue is I re-downloaded XWE and replace the files, I ope and try out to open my map again instead I get- "Access Violation at Address 00442E5A in Module 'XWE.exe'. Read of Address 00000050. "

What could be wrong?

Last edited by Mithral_Demon on 01-08-09 at 05:34

Old Post 07-02-08 22:15 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
RTC_Marine
Junior Member


Posts: 544
Registered: 06-01


Unfortunately XWE is buggy and even more of an issue, the author has disappeared off the face of the earth.

Its a real shame, I offered him my skills to help him with it, he said no, then asked time and time again for him to release the source.

You can try to work around the issues or just use another editor like slumped

Old Post 07-03-08 00:54 #
RTC_Marine is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


XWE's source would be nice, especially if Csabo has discontinued it. I bet its source isn't too edit-friendly, though, so enhancing SLumpEd or the like would probably be easier than reworking parts of XWE.

As for the first error message, check this thread.

Old Post 07-03-08 01:02 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


For Slumped, can it:
Replace Level Music
Merge Files
Do what ever XWE can but maybe better?

Old Post 07-03-08 01:15 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


SLumpEd will replace any single lumps (including music), but it can't merge WADs directly. SLumpEd is somewhat more bare-bones than XWE.

Old Post 07-03-08 01:56 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
RTC_Marine
Junior Member


Posts: 544
Registered: 06-01



myk said:
XWE's source would be nice, especially if Csabo has discontinued it. I bet its source isn't too edit-friendly, though, so enhancing SLumpEd or the like would probably be easier than reworking parts of XWE.

As for the first error message, check this thread.



More developer friendly than anything, it does have a lot of (working) stuff and ways of doing things that slumped doesn't.

Slumped's site is in a state of being reworked.. no source?

Old Post 07-03-08 02:19 #
RTC_Marine is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Well, I have Slumped, but how do I add a monster to the wad? What of Textures and Music? I need a manual for this... >_>

Old Post 07-03-08 23:28 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


In the Lump menu you can create new lumps or import lumps or raw resources, delete them, or rename them.

I don't recall whether you can import multiple files by selection, but you could try and see.

Old Post 07-03-08 23:37 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Well, I won't exactly be able to get anywhere since I don't know how Slump works... All I need to know is:

1. Music
2. Monster
3. Textures

An I was used to XWE but it's acting up (probably cause comp is Vista), so if any help possible, a Tutorial/Guide or just simple advice would help..

Old Post 07-06-08 03:55 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Slumped really can't figure out... Can't seem to put textures, music or monsters in when I "import from File" or "import lump" ... Rather like to have a manual to use. I put it in, save, try on DB, but nothing shows cept what the wad had in it originally.

Do you think if the problem for XWE on my comp is because it's Vista or something?

Old Post 07-14-08 04:21 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


I wouldn't be surprised if those bugs occur only on Vista.

As for SlumpEd, open WAD or create a new one (with the File menu) and try adding a New lump (with the Lump menu) and just hit OK when it asks for a name. Select the new empty lump on the list, and use Import (Lump menu again) and browse for the music or graphics you need to add. This'll be easier of the file that goes in as a lump is already uses the name of the desired lump (a music file called D_RUNNIN.MID, for example). If not, use the Rename option in the Lump menu.

Old Post 07-14-08 07:59 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Nuxius
Forum Regular


Posts: 751
Registered: 02-05


FYI: The SlumpEd page hasn't been updated in ages, and the version linked there (.05a) is old and outdated.

The actual latest version is 0.7, which can be downloaded here:

exe
http://slumped.mancubus.net/files/slumped_07.zip

source (since RTC_Marine was asking about it)
http://slumped.mancubus.net/files/slumped_07_src.zip

Old Post 07-14-08 11:02 #
Nuxius is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Wow...
I can't exactly work SlumpED, I import/make new lump for the things I'd like added to my map, but yet when I save, and edit, I don't see the textures nor hear new music and see the "Exclamation mark of doom" (Or the missing sprite), it's either some one forces Mr. Sabo to make XWE Vista compatible or some one give me a manual for SlumpED.

I love mapping an all, but this can't really cut it for editing.

[Edit] Ok, I get the music, much like XWE, change the name to specified level. But still need to know of Textures and Monster/Sprite.
[Edit2] I see something of the Textures, but I copy/paste the folder with the textures (Texture1, GothicDM) and PNames folder, but when tested it with Doom Builder, I don't see my newly implemented textures... This might be same case as my Monster Implementing ordeal.

Last edited by Mithral_Demon on 07-25-08 at 02:07

Old Post 07-24-08 03:02 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


Ok, I think I see what the problem is, but I don't know how to fix, it says "Fail to create KEY .WAD", anything that anyone knows how to solve this?

Old Post 08-01-08 22:56 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
myk
volveré y seré millones


Posts: 15226
Registered: 04-02


Did you read the thread I linked to in the first post I made?

It talks about that error message and provides an option against it.

Old Post 08-02-08 04:27 #
myk is offline Profile || Blog || PM || Email || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Jimmy
doesn't rhyme with MIDI :(


Posts: 1575
Registered: 04-06


Sorry, I'm an idiot and didn't look hard enough.

Last edited by Jimmy on 01-03-09 at 13:32

Old Post 01-03-09 13:25 #
Jimmy is offline Profile || Blog || PM || Homepage || Search || Add Buddy IP || Edit/Delete || Quote
Mithral_Demon
Forum Regular


Posts: 701
Registered: 09-06


You can delete this thread, issue has been resolved, back when I had the issue, I didn't really care to look at Myk's post, but yeah.


Thanks Myk, now i'm on the DoomBuilderVista issue.

Old Post 01-08-09 05:35 #
Mithral_Demon is offline Profile || Blog || PM || Search || Add Buddy IP || Edit/Delete || Quote
All times are GMT. The time now is 01:47. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Special Interest > XWE > XWE Problem(s)

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by: vBulletin Version 2.2.5
Copyright ©2000, 2001, Jelsoft Enterprises Limited.