Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
NaturalTvventy

GZDoom Builder keeps making new sectors from multi-polygon sectors

Question

I play with lots of multi-part sectors, meaning my sectors can have different polygons spatially apart from each other. This is especially important with dummy sectors where part of my sector is out in the void to create various effects. GZDoom Builder keeps "splitting" these sectors into two or more when I move vertices arounds or what have you, so that each polygon is now a unique sector. I keep having to rejoin sectors together to keep my map working. Is there a way to stop this issue? I never remember it happening with Doom Builder II.

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

Doombuilder 2, or DBX don't do that either, unless you draw something new inside a sector you have joined with another one already. In that case they always "disjoin" for me as well, it just takes one linedef that doesn't even "split" a sector and it still happens. If there was a way to turn that off, I'd sure like to know, because sifting through the options and preferences I didn't see anything that would help with that.

Share this post


Link to post
  • 0
Posted (edited)

I made a quick video to show how joining sectors works for me, with subsequent editing of the joined sectors.

 

edit:

deleted the videoclip, since it is now superfluous.

see post below for "feature"

Edited by Kappes Buur

Share this post


Link to post
  • 0

That behavior was a "feature" added in some version of GZDB. But it was later reverted (AFAIK there is no toggle option for it), so maybe you're still using a version where this was enabled?

Share this post


Link to post
  • 0
Posted (edited)
16 hours ago, boris said:

That behavior was a "feature" added in some version of GZDB. But it was later reverted (AFAIK there is no toggle option for it), so maybe you're still using a version where this was enabled?

 

Yes indeed, that "feature" is still in the editor, both GZDB and GZDBBF.

You can toggle it in Edit - Split Joined Sectors when Drawing Lines.

 

 

Or toggle the icon in the top toolbar

 

Spoiler

UDgYon7.jpg

 

edit:

I just checked the changelog. To toggle this feature was added in r2649, after much discussion during June 2016, in which boris was a major pundit to get this resolved.

 

Edited by Kappes Buur

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×