Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Comrade Pingu

[SOLVED] GZDoom not able to find IWADS (even when specified)

Recommended Posts

Posted (edited)

So, I've been trying to get GZDoom working on my Manjaro install. However, I keep getting this error whenever I try to run GZDoom:

 

Did you install GZDoom properly? You can do either of the following:

1. Place one or more of these wads in ~/.config/gzdoom/.
2. Edit your ~/.config/gzdoom/gzdoom.ini and add the directories of your
iwads to the list beneath [IWADSearch.Directories]

 

I have tried to reinstall GZDoom, delete the home folder, and a whole plethora of other things I've seen on the internet, and I still can't get it to work.

 

NOTE: I'm running the gzdoom-git package off of the AUR.

 

Edited by Comrade Pingu

Share this post


Link to post
Posted (edited)

It can find gzdoom.pk3 perfectly fine (presumably), the error message isn't complaining about that. It can't find any IWADs, which are the Doom part of Doom. Grab one of them from your copy of Doom and place it in the location listed in the message.

Share this post


Link to post

I used the command

gzdoom -iwads doom.wad 

in order to run it.

 

I made this post late last night and I was having troubles with getting gzdoom to find doom.pk3 until I discovered I was missing a library to run gzdoom. So I'm going to change the title to something more accurate.

Share this post


Link to post

You also don't need to specify that. Just place doom.wad in ~/.config/gzdoom/, as it suggested.

Share this post


Link to post
Posted (edited)
17 hours ago, DaIcemann76 said:

The parameter is "-iwad", not  "-iwads".  Try that and see if it works.

 

 

17 hours ago, Edward850 said:

You also don't need to specify that. Just place doom.wad in ~/.config/gzdoom/, as it suggested.

 

I tried both of those methods and I still got the same error message. Not even specifying full path-names in the gzdoom.ini file would make it work. So, I think I'll try to get rid of the IWAD and PWAD directory and put all my WADS into the ~/.config/gzdoom/ directory and see how it works.

 

EDIT: On checking the filesize of my doom.wad and doom2.wad files I noticed that they were 0 bytes. So, I'll take the wad files from my laptop and put them on my desktop. Wish me luck!

FINAL EDIT: It worked and this whole thread was moot. Hooray for not checking basic stuff!

Edited by Comrade Pingu

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×