Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Urthar

QZDOOM rendering glitch

Recommended Posts

Posted (edited)

I noticed a midtexture glitch has crept into the 3.3.1 version of GZDoom's software renderer. (GL mode works fine.)

 

GZDOOM 3.3.1 (software mode)

V5c1Goi.png

 

ZDOOM 2.8.1 (and all other Boom compatible ports)

jgzoIgM.png

 

The glitch effects midtexures inside Boom format 242 invisible platforms/walls, and essentially renders them invisible. Interestingly, any part of an effected midtexture that's outside the invisible doodah still renders correctly.

I'm not sure if this glitch was also present in 3.3, but QZDoom versions prior to this year seemed to work fine.

Edited by Urthar

Share this post


Link to post

Just suggest you should report your bug to ZDooM forum, to get the devs know quickly, and please do that.

 

Also, when firing a bug report on there, you should give info about your system spec and what map of your screenshot because do not except everyone know what the map is from your screenshot(unless the devs just know), and can't debug from it. :P

Share this post


Link to post

Fair enough, I just reverted to 3.2.5 for the time being. I should probably register at the ZDoom forums at some point too.

Share this post


Link to post
On 14.4.2018 at 8:58 AM, Couldn't not display Name said:

Hey the textures in the levels look like from Quake right?

Yes…

Share this post


Link to post
On 4/14/2018 at 9:58 AM, Couldn't not display Name said:

Hey the textures in the levels look like from Quake right?

Look in this thread

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×