Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Bridgeburner56

GZDoom vs GZDoom Builder brightness rendering (annoying me)

Recommended Posts

So, when doing gradated lighting sectors in GZDoombuilder, what is then rendered in GZDoom is quite different. I've done sample sectors from 120 brightness to 10 to illustrate

 

1st, gradients in Builder. Pretty smooth until you get to 50 and then it's just dark. I have no issues with this.

Light_gradients_gzdoom_builder.jpg

 

Then in GZDoom, the difference between 110 and 100 seems to me far greater than any of the other increments of 10. And then between 100 and 70 there is very little variance. Which is annoying.

Light_gradiants_in_game.png

 

As someone who obsesses over lighting this has been giving me a headache. Does anyone have any insight into what causes this? I've mucked around with all of the settings in GZDoom but to no avail. Having fog on seems to make the issue worse so I've turned that off. Worst case I will just have to adjust my light levels in editor but I'm worried that that'll fix it for me but will look bad for everyone else.

 

Any help is much appreciated

Share this post


Link to post

There are different light modes you can set in GZDoom  like Doom, Dark, and others. Other players might choose a different mode than you, making it too dark or too bright. On top of that, different monitors and/or graphics cards can render things with different brightness. You can't control any of that, so just make it look right for you.

Share this post


Link to post

Fair enough. I'm probably being too picky and I'm learning to use point lighting more and more which doesn't have this issue so it's becoming less of a thing. I just noticed it today in a couple of areas where I was thinking "I'm sure I made this area brighter" and then going back and checking Builder, back to testing, back to Builder and so and so forth. Fortunately I'm only 3 1/2 levels into my wad. Unfortunately they average around 60,000 linedefs ...

Share this post


Link to post

Also, press F5 to go into options, then go to the "Appearance" tab and change the "Texture and flats brightness" setting value to 0. That way, you'll have the same feel of brightness in-game. 

Share this post


Link to post
On 15/04/2018 at 2:34 PM, leodoom85 said:

Also, press F5 to go into options, then go to the "Appearance" tab and change the "Texture and flats brightness" setting value to 0. That way, you'll have the same feel of brightness in-game. 

 

 

This +1.

 

I've never really understood why the GZDB default is to artificially brighten textures, it just makes it more difficult to get the lighting right.

 

Also @Bridgeburner56 you can define what light mode your map should use (e.g. Dark, Doom, Software etc.) in the Mapinfo file. People can change it once they've loaded the map if they really want, but 99% won't.

Share this post


Link to post
5 hours ago, Bauul said:

 

 

This +1.

 

I've never really understood why the GZDB default is to artificially brighten textures, it just makes it more difficult to get the lighting right.

 

Also @Bridgeburner56 you can define what light mode your map should use (e.g. Dark, Doom, Software etc.) in the Mapinfo file. People can change it once they've loaded the map if they really want, but 99% won't.

Yeah, I had no idea it did that. 

 

Cheers, that's quite helpful. I'm gearing the light levels around Doom light mode with no fog IIRC so being able to preset that will help avoid unnecessary bitching. Like you say if people want to force it into a different setting for personal preferences then it's up to them.

 

Also, love the avatar (assuming it's the eye from Train of Thought. Greatest album of all time) 

Share this post


Link to post
Posted (edited)
On 4/18/2018 at 5:05 PM, Bauul said:

I've never really understood why the GZDB default is to artificially brighten textures, it just makes it more difficult to get the lighting right.

I suspect it was a personal choice of the developer of the renderer in the editor. Perhaps they were thinking about being able to distinguish between different lighted areas more than making it look the same as what's in the game. It would make sense to have a game lighting toggle so you can quickly check or choose to edit with game lighting. Maybe the developer even thought of this and decided it would be up to the user to do this by testing in game, as it would be quite complicated to set up the editor to have the same lighting settings as the game.

Share this post


Link to post
50 minutes ago, alowe said:

I suspect it was a personal choice of the developer of the renderer in the editor. Perhaps they were thinking about being able to distinguish between different lighted areas more than making it look the same as what's in the game. It would make sense to have a game lighting toggle so you can quickly check or choose to edit with game lighting. Maybe the developer even thought of this and decided it would be up to the user to do this by testing in game, as it would be quite complicated to set up the editor to have the same lighting settings as the game.

Builder has a max brightness toggle which I use a lot because my maps are definitely on the darker side. There's enough of a discrepancy between builder and gzdoom regardless that you need to do in game checks on light levels anyway. Hence my original post 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×