Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Aquila Chrysaetos

GZDoom 3.x on HP Notebook

Recommended Posts

So this strange thing happens when I use any version of GZDoom later than 2.4.0.

I play for anywhere from 10 minutes to an hour and a half and the game seems to stop.

Except, it doesn't actually stop. It's like I paused the game, but the game proper is still running, but I only have a still image, forcing me to go to the console and quit.

What's really weird is this happens on a random basis and I'm not concrete on whether its an issue with my vid card (drivers, hardware, whatever) or something else entirely.

 

Specs of my machine:

Intel Celeron N3050 CPU 1.6 GHz

4 GB RAM

64-bit OS, x64 processor.

 

If it helps, my machine is an HP 15-f223wm Notebook.

 

Also, because I suspect it may simply be an issue of outdated drivers (What a shock that would be), I've found the latest graphics driver, but I'd like to know what may be causing this regardless.

Any insight from @Graf Zahl would be immensely appreciated.

Share this post


Link to post

Does it happen with the latest drivers? And which date were they released?

Share this post


Link to post

I remember reading recently that something like this can happen with Intel graphics chips when they get too hot. Apparently it's a driver bug.

 

Share this post


Link to post
Posted (edited)

The drivers I had before were from '15, the one I recently installed from '17.

As it happens, I was just playing GZDoom 3.4 pre (the dev build) and it was running fine, but I need to run exhaustive tests to be sure.

Appreciate the help, guys.

 

Instead of double-posting:

I ran a test in Epic 2 to see if the game would do that again (MAP01 has a spot that almost always does it) and it seems to have been fixed, so I do suspect it was an outdated driver.

However, I will post again if something changes.

Edited by Aquila Chrysaetos

Share this post


Link to post

Update bump.

This still occurs in GZDoom 3.4 pre 298, so it doesn't seem that outdated drivers were the problem.

Absolutely perplexing is that when I run it in a window, this problem takes longer to occur than fullscreen.

Since outdated drivers seemed like the most probable cause, I am stumped.

I appreciate your patience.

Share this post


Link to post
17 hours ago, Jerry.C said:

I remember reading recently that something like this can happen with Intel graphics chips when they get too hot. Apparently it's a driver bug.

 

@Aquila Chrysaetos did you read this post?

Share this post


Link to post
Posted (edited)

I don't know exactly what causes the issue but GZDoom is not the only program it happens with. If I run Overwatch on my Intel processor it happens - except a whole lot faster. It's happened with numerous other applications, too. This is not a GZDoom issue - it's an Intel issue - and all this time they haven't fixed it.

 

In short: Unless you find ways to keep your GPU running super cool, there's no way to avoid this issue - and that goes for any game.

 

For GZDoom, the best advice I can give you is run at a lower resolution (use the scaling factor feature if you need a larger window), turn off multisampling, and don't run tonemaps, bloom, or SSAO, as those tend to cook the GPU a lot faster than simple triangle rendering does.

 

Also, make sure that your frame rate is limited in some way, either with vid_vsync or vid_maxfps, or else any effort you make towards lowering the processing your GPU does will be for nothing.

Share this post


Link to post

@Rachael, I see now. Intel and ATI always seem to have these problems, now that I think about it. Thank you for your insight.

Since that's the case, I'll stick with GZD 2.4.0.

That's a bummer, but it answers my question.

Share this post


Link to post

I used to run gzdoom 3.1.0 on an HP notebook with similar specs. It ran fine mostly but after a month of use it went down to a crawl. Don't know why because my Notebook was pretty new. Zdoom ran perfectly. I'm guessing Gzdoom favors A little more powerful computers than that.

Share this post


Link to post

Delete the setting ini file in its folder so its settings go back to the dedault, you may have screwed them up.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×