Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SodaFueled

Low FPS in GZDoom

Recommended Posts

Hello everyone, I apologize in advance if this isn't the right place to submit this thread.

 

As the thread name suggests, I have have issues with poor framerates using the GZDoom engine. For the purpose of this test, I'm using Deus Vult's II map03 (a rather complex map as far as I can tell, but probably not the most complex in that map pack). Regardless of which rendering engine I use, the framerate is quite poor. Here's the result I got form the bench command:

 

Spoiler

Map MAP03: "Crouching Demon, Hidden Archvile",
x = 92.5292, y = -2178.4940, z = -983.4387, angle = 134.9121, pitch = 5.5811
Walls: 2005 (0 splits, 0 t-splits, 3315 vertices)
Flats: 84 (778 primitives, 4275 vertices)
Sprites: 1864, Decals=6, Portals: 1
W: Render=0.712, Setup=0.592, Clip=0.805
F: Render=0.203, Setup=0.022
S: Render=3.421, Setup=0.961
All=24.726, Render=5.274, Setup=2.915, BSP = 0.508, Portal=0.062, Drawcalls=2.292, Finish=14.038
DLight - Walls: 72 processed, 118 rendered - Flats: 0 processed, 0 rendered
Missing textures: 0 upper, 10 lower, 0.028 ms
36 fps

 

I get a similar result when using the software rendering engine, although the bench command seems to continue indefinitely and thus I can't provide a copy of it (though I'm open to suggestions on how to get a result like the one above).

 

I would also like to note that when using the OpenGL renderer and playing any wad, including the original ones, loading times for maps are considerably higher and that the screen often stops for a while whenever I receive damage for the first time after loading (whenever a new sprite is loaded?). Anytime I get hit afterwards it works fine, until I load a save file or start a new game. Neither of these problems are present in the software renderer. I've tried lowering the settings and though the framerate improves a bit it still lags from time to time.

 

For reference, I'm running GZDoom 3.3.0 on a Lenovo Y700, with an i7-6700 2.60GHz CPU, 12GB of Ram and a GTX 960M nVidia graphics card with 4GB of memory. The "Notebook switchable GPU" setting in GZDoom is set to "High-performance". I was under the impression this system should be able to run complex wads on high settings without issues; are my specs simply not good enough, or is the issue elsewhere? I would be grateful for any insight on what I can do to solve my issue. If more information is required please let me know.

Share this post


Link to post
Posted (edited)

Have you checked your energy settings in Windows? If you haven't, maybe a setting is pushing back your computer in order to save energy.

 

BTW, unless your GPU is really bad (which doesn't seem to be the case here) the OpenGL renderer is you best bet if you want to have good performance, since the software renderer pretty much ignores your dedicated card and puts all of the burden in your CPU.

 

No idea about the loading times, although the long loading times for the levels may be because you have the "Precache GL textures" option enabled.

Edited by KVELLER

Share this post


Link to post

The energy settings are definitely the first place to look. Every time I suffered from bad performance it was a throttled down system thanks to Windows not realizing what I did.

It's really shocking how badly this stuff is implemented. Any sane convention should tell that if the display goes fullscreen with some hardware acceleration being active it's a clear sign of "I want full power!" Apparently Windows does not agree.

 

Share this post


Link to post

Thank you for your replies. I took a look at energy settings, but everything is at full power. Disabling the pre-cached GL texture helped with load times, but everything else remains the same. After looking around a bit more I found a thread in the ZDoom forums that explains how this is an issue specific to laptops with modern Windows versions and nVidia graphic cards. There's a couple of work arounds but nothing that works for me. So I guess I'm stuck with this issue until I get a new computer in the far future.

Share this post


Link to post

Suffering the same problem. I run an Intel graphics card and the OpenGL was working amazingly up until recently. I've been hoping to get a new machine for a while since upgrading to Windows 10 from 8.5 did me no favors. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×