Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
paperdoll

Gzdoom OpenGl lag , need help

Recommended Posts

Hallo everyone!I got some problem:I used to have very high FPS with almost any mod on highest display setting,but since 2 months ago I upgrade my Nvidia new graphic driver,everything turns to bad,when I running Gzdoom's OpenGl mode,even with no mod and low display setting,the FPS couldn't keeping higher than 30!

This problem only happens to the version after 2.4.0 of Gzdoom,and also in Zandronum's OpenGl mode,Software mode and the version before 2.4.0 is ok as before but it's still a problem.I tried many ways to solve this problem like upgarde or downgrade my graphic card's driver but it doesn't work.

Follwing is my PC‘s hardware information:

inter(R) core(TM) i7-7700HQ cpu @2.80GHZ

RAM:16.0GB

system:X64

intel HD graphics 630

Nvidia Geforce GTX 1060

Opengl version:4.4

DirectX:9.0c

Waiting for your suggest!

Share this post


Link to post

Are you running Windows? If so, go into Device Manager, and go to Display Adapters. Right-click on your nVidia card, and go to Properties. Under the Driver tab, click Roll Back Driver. This will bring your graphics drivers back to the last version you had installed.

 

If that does not work, you can download the latest driver on nVidia's website, and when you run the installer for the drivers, make sure you check the option to do a clean installation.

Share this post


Link to post

Since you list both your main and integrated graphics hardware, have you made sure that it actually uses the main one?

Aside from that, both your GPUs should support OpenGL 4.6 (NVidia) or 4.5 (Intel), so are you really using the latest driver?

 

I'd recomment to first check the console for which GPU it reports in use and what OpenGL version is actually being used.

 

 

Share this post


Link to post
19 hours ago, R4L said:

Are you running Windows? If so, go into Device Manager, and go to Display Adapters. Right-click on your nVidia card, and go to Properties. Under the Driver tab, click Roll Back Driver. This will bring your graphics drivers back to the last version you had installed.

 

If that does not work, you can download the latest driver on nVidia's website, and when you run the installer for the drivers, make sure you check the option to do a clean installation.

I'm using win10 and tried this way, by some driver uninstall application, and got official graphic card drivers,both Nvidia and Intel,but it's not working

Share this post


Link to post
19 hours ago, Aquila Chrysaetos said:

 

thanks for that,I reset the energy settings,but it's doesn't work

Share this post


Link to post
17 hours ago, Jerry.C said:

Since you list both your main and integrated graphics hardware, have you made sure that it actually uses the main one?

Aside from that, both your GPUs should support OpenGL 4.6 (NVidia) or 4.5 (Intel), so are you really using the latest driver?

 

I'd recomment to first check the console for which GPU it reports in use and what OpenGL version is actually being used.

 

 

Actually my gtx1060 is runing GZDOOM as I start it,showed by Nvidia mannagemnet application.

following is my console infos:

os_window 10(or higher)(nt 10.0)build 16299

m_loaddefaults:load system default

using program directory for storage

w_initLinit wadfiles

adding (iwad and other stuffs)...

 

i_init:setting up machine state

cpu speed:2808GHZ

cpu vemdor id:genuineintel

name:inter(r) core(tm) i7-7700hq gpu 2.80ghz

family 6,model 158,stepping 9

features:sse2 sse3 ssse3 sse4.1 sse4.2 hyperthreading

 

i_intsound:initializing openal

opened device openal soft on d(realtek high definition audio)

efx enabled

 

renderer:opengl

v_init:allocate screen

s_init:setting up sound

st_init:init startup screen

checking cmd_line parameters..

s_initdata:load sound definitions

texman.init:init texture mannager.

parseteaminfo:load map difinitions

script parsing took 117.80 ms

r_init:init doom refresh subsystem

decallibrary:load decals

m_init:init menus

P_init:init playloop state

parsesbarinfo:loading custom status bar difinition

player 1 of 1(1 nodes)

i_initinput

i_startupkeyboard

i_startupxinput

i_startuprawps2

i_startupdirectinputjoystick

 

gl_vendor:nvidia corporation

gl_renderer:geforce gtx 1060/pcie/sse2

gl_version:4.6.0 nvidia 390.65 (core profile)

gl_shading_language_version:4.60 nvidia

 

and others like max textures...

Share this post


Link to post
Posted (edited)

Having a similar issue myself now after GZDoom with OpenGL was running great up until this past weekend. I'm on an Intel card and not sure how to respond to this. 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×