Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kristian Nebula

DOOM 2016 won't start, enters infinite black screen

Recommended Posts

Hi

 

So I just installed DOOM 2016 again, after 4 months and tried to start the game and it went into an infinite black screen and when looking at DOOMx64.exe after ctrl+alt+del it just says "no answer".

I checked various forums and tried to install it again, deleted some files suggested and tried different cmd parameters in the start to skip videos and +renderAPI 1 like suggested at Bethesda forums and still nothing. Just jamming in the black screen. Was there some update in the last four months during the time when I had it uninstalled which might have wrecked it because it worked fine in January when I last played it?

 

Anyone here have any tips on that? :)

 

Thanks

 

 

Share this post


Link to post

I was curious when this will appear here.

So, the official state is:

https://bethesda.net/community/topic/199115/black-screen-error-with-latest-patch-march-2018

 

and reinstal

Microsoft Visual C++ 2015 Redistributable Update 3 RC:
https://www.microsoft.com/en-us/download/details.aspx?id=52685

 

But, it didn't work for me.

 

Problem is realy in MVC++ cause my Doom works fine on wednesday, but stop worinkg on saturday. I installed and reinstalled MVC++ few version, tried command lines. Nothing helped. But I remembered that I installed battlefront 1 with other version of MVC++ on wednesday. I rollback my windows to time before install battlefront and doom now running properly, but my battlefront was kicked off from hdd by windows. So for sure if I install it back or something else problem will come back.

Share this post


Link to post

I tried installing also the MVC++ and it complained that it's unable to complete installation due to some error even I had removed any previous versions. Still looking at the add/remove programs options, it installed that version of MVC++.

 

I have the same problem with Quake Champions, it won't even start.. Nothing happens when I press play at Steam :D

Share this post


Link to post

After removing most of MVC++ my Origin program gone down. 

Ha, yesterday I installed Uplay, and Doom again doesn't work. Quake champions runs fine :/

 

EDIT: these are mine MVC++ installed, and today I installed latest nv drivers and Doom is running.

Untitled.jpg.20de46ad9ac0950804f4d2ec8bbeb889.jpg

As you see there are no 2015 rds

Edited by Teder

Share this post


Link to post
6 hours ago, Teder said:

After removing most of MVC++ my Origin program gone down. 

Ha, yesterday I installed Uplay, and Doom again doesn't work. Quake champions runs fine :/

 

EDIT: these are mine MVC++ installed, and today I installed latest nv drivers and Doom is running.

As you see there are no 2015 rds

 

Interesting. Currently I have only that one that id software/bethseda suggested to have. Gonna try install those too and see what happens :D

Share this post


Link to post

As you see 2015 version can't be installed. I didn't instal geforce experience neither.

Share this post


Link to post
5 minutes ago, Teder said:

As you see 2015 version can't be installed. I didn't instal geforce experience neither.

 

Got the same bug in the install complaining some unknown error when installing 2017... but it appeared in the installed programs list anyway after I deleted the 2015 version :D weird stuff. Time to try if DOOM works now, fingers crossed x)

Share this post


Link to post
Just now, Kristian Nebula said:

 

Got the same bug in the install complaining some unknown error when installing 2017... but it appeared in the installed programs list anyway after I deleted the 2015 version :D weird stuff. Time to try if DOOM works now, fingers crossed x)

:D yeah good luck!

Share this post


Link to post

:(

What gfx do u have?

For now I got 397.64 nvidia.

And about Quake champions? Still dead?

 

EDIT: yes, I found info that one guy deleted geforce experience and that helped.

Share this post


Link to post
7 minutes ago, Teder said:

:(

What gfx do u have?

For now I got 397.64 nvidia.

And about Quake champions? Still dead?

 

EDIT: yes, I found info that one guy deleted geforce experience and that helped.

 

I have Geforce GTX970 4GB Mini for Micro ATX motherboards... It has worked fine before and same drivers as you have. Quake Champions has been dead since I bought it in January :D I asked around Bethesda forums and they couldn't help me with it. Nothing they suggested worked.

 

Yesterday I tried to update my Windows 7 and it said the update isn't possible because some system file problem. Maybe I should wipe the sheet clean and install Windows again since the beginning but that would require so much work related to my music studio that it would take a couple of days and I just don't have the time to install everything again right now for the sake of one game :D

 

EDIT: At least Wolfensteins are working fine.. They just tend to get boring quite fast! :D

Share this post


Link to post

I reinstalled os 19 days ago. Doom was a first game I installed and worked fine until I installed battlefront, and yesterday uplay game.

 

EDIT: devs really have users in a deep...

I got QC since second beta.

Share this post


Link to post
Just now, Teder said:

I reinstalled os 19 days ago. Doom was a first game I installed and worked fine until I installed battlefront, and yesterday uplay game.

 

Ok. I will consider to reinstall os during my summer vacation if I can manage to do it in the middle of my summer tour as a music artist. :)

Share this post


Link to post

Bad is that I don't really now what helped to my doom. I unistalled almost all MVC++ than I installed 2013 and 2017 (2015 didn't want to install). And after all I reinstalled nv. One thing that I found is that some guy on steam forum turn off power management mode for optimal for Doom program settings.

I read almost all 15 pages https://steamcommunity.com/app/379720/discussions/0/1696043263502515818/

 

Share this post


Link to post

It seems I might be onto the source of the problem... A key windows file Trustedinstaller.exe was missing which I replaced with another one from my laptop that I use for my gigs. Now Windows Update works again, and the Visual C++ Redistributables install errors stopped and the install completed itself properly. Downloading DOOM, fingers crossed x)

 

EDIT: Got it working now, wohoo! :D I suspect that Quake Champions will also work now, reinstalling it tomorrow!

Edited by Kristian Nebula

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×