Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Dan50

Got the new version of GzDoom, how do I enable OpenGL mode?I

Recommended Posts

I want to check out the textures and stuff in this version but I forget the command line. 

Share this post


Link to post
Posted (edited)

You can go into the ini file and find "vid_renderer" and change the 0 to a 1.

It's easier in-game to go into the console (` by default) and type "vid_renderer 1" and that will set the renderer to GL, though you should also be able to do that directly in the video mode menu under options.

You will need to restart GZDoom if you do this in-game, too.

Share this post


Link to post

If you have more than one IWad in the folder, it should pop up with options when you begin. You can go with software or hardware, which is OpenGL. 

Share this post


Link to post

Hm, I keep getting an illegal access violation- tried to read address 0000000000000 error when trying to use the new "soft poly" renderer (or at least I think it's new, I haven't seen it in the video options menu before), Is that a bug, or is it because it requires an opengl version higher than what I have, or what

Share this post


Link to post
Posted (edited)

My first instinct is to ask what your version of GL is, @therektafire, because I think any version later than 2.4.0 needs 3.x or higher, though 4.4 would be preferred, but I can't be sure, so I'll try to get @Rachael's attention for your question.

For some reason, it seems I can't find what version of OpenGL GZDoom 3.x needs, which is why I speculate GL 3.x or higher, since GL 2 was dropped before GZD 3 was released.

 

Some further thought has revealed I can't be sure if this is a GL problem, because I remember the software poly renderer, and it's designed for software renderer specifically, which means I've no clue.

Edited by Aquila Chrysaetos

Share this post


Link to post
Posted (edited)

Well the version of opengl on the computer i was using is 3.1, so it should work (I had some opengl issues with Slade before but got those ironed out, it turns out I had a setting enabled that the crappy Intel hd that is has isn't compatible with or something so now the map editor renders everything fine). Maybe the soft poly renderer require something like 3.2 or higher, or maybe even 4, not sure.

Share this post


Link to post

 

3 hours ago, Aquila Chrysaetos said:

For some reason, it seems I can't find what version of OpenGL GZDoom 3.x needs, which is why I speculate GL 3.x or higher, since GL 2 was dropped before GZD 3 was released. 

 

The latest GZDoom still runs on OpenGL 2.x. But it doesn't run the GL 3.x features if you only have OpenGL 3.1. For that it requires OpenGL 3.3.

As I understand it, the only GL3 compatible hardware without a driver supporting OpenGL 3.3 is Intel HD3000 and Intel HD2000 and I can tell you from my own experience on an old laptop that the driver for these is not particularly good and often runs into errors where none should occur, so it makes sense not to support it.

 

Share this post


Link to post
3 minutes ago, Jerry.C said:

 

 

The latest GZDoom still runs on OpenGL 2.x. But it doesn't run the GL 3.x features if you only have OpenGL 3.1. For that it requires OpenGL 3.3.

As I understand it, the only GL3 compatible hardware without a driver supporting OpenGL 3.3 is Intel HD3000 and Intel HD2000 and I can tell you from my own experience on an old laptop that the driver for these is not particularly good and often runs into errors where none should occur, so it makes sense not to support it.

 

And I'm guessing the soft poly renderer requires 3.3 or higher? But if that's the case then why would it let me select it then, I dont see any of those other fancy chmancy features like AO and I imagine PBR wouldn't work either. What's weird though is that when I use that one the wad *loads* and i can go into the first map just fine but it crashes on the first frame I actually have control of doomguy. But i can see the initial spawn area before I take control which is weird because if that setting didn't work at all then surely it would crash before I even spawned initially...? Which is why I feel like it is kind of a bug at least in some way

Share this post


Link to post
17 minutes ago, therektafire said:

And I'm guessing the soft poly renderer requires 3.3 or higher?

Soft poly is a software renderer and thus is not dependent on any graphics card capabilities.

Share this post


Link to post
On samedi 9 juin 2018 at 6:42 PM, Aquila Chrysaetos said:

You can go into the ini file and find "vid_renderer" and change the 0 to a 1.

It's easier in-game to go into the console (` by default) and type "vid_renderer 1" and that will set the renderer to GL, though you should also be able to do that directly in the video mode menu under options.

You will need to restart GZDoom if you do this in-game, too.

Not with GZDoom 3.4.0

 


  • renderer can now be "live switched" between the Software renderer and Hardware-accelerated OpenGL modes

 

Share this post


Link to post

That's some really profound analysis from running it on a single computer. I think I just mirror most people's experience when telling you that it runs fine for me.

 

You haven't even told us anything relevant about your system.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×