Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
DynamiteKaitorn

SLAD3 .PK3 And MAPINFO issue

Question

For what ever reason, GZDooM 3.2.2 isn't capable of understanding the GameDefualts I have set for AirSupply and AirControl. I have attempted to set them as "AddDefaultMap" or "DefaultMap" but for whatever reason, they are loaded without errors but wont actually execute.

 

SLAD3DERP2.png.83667ea0c0e28dbc7875c0311cd2a179.png

 

What makes less sense is that this exact code works perfectly for my previously uploaded WAD. The only diff being that my previous wad had custom levels defined.

SLAD3DERP3.png.71501642a2d08c66b10f8abddb1be881.png

 

Any idea what is causing this issue?

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 1
20 hours ago, Edward850 said:

You cannot modify existing mapinfo entries. DefaultMap and AddDefaultMap only apply to new entries defined after them.

 

14 hours ago, DynamiteKaitorn said:

Still doesn't fully explain how it worked for TMoD EP 2 but not for this side-protect of mine.

After your DefaultMap entry, you need to have regular map entries for each map in your WAD/PK3. The DefaultMap entry will add its information to the map entries that follow it, so you don't have to have that information copied over and over for each map. If you don't have map entries after the DefaultMap entry, it will have no effect.

Share this post


Link to post
  • 0
Posted (edited)

I'm not sure I know the answer, but I do know you're using an out of date version of GZDoom. 3.4.0 is out now - https://zdoom.org/downloads

 

As for the solution to your problems, try merging the GameDefaults to one block, like so:

GameDefaults {
	AirSupply = 8008135
	AirControl = 0
	AnotherVariable = 133742069
}

 

Edited by Dragonfly

Share this post


Link to post
  • 0
43 minutes ago, Dragonfly said:

I'm not sure I know the answer, but I do know you're using an out of date version of GZDoom. 3.4.0 is out now - https://zdoom.org/downloads

 

As for the solution to your problems, try merging the GameDefaults to one block, like so:


GameDefaults {
	AirSupply = 8008135;
	AirControl = 0;
	AnotherVariable = 133742069;
}

 

 

The ";" causes an error when loading. "Unknown Property ";" found in map definition"

Share this post


Link to post
  • 0
7 hours ago, DynamiteKaitorn said:

 

The ";" causes an error when loading. "Unknown Property ";" found in map definition"

Languages like ACS and C use semicolons to separate commands, so it is too easy to forget to leave them off of the ends of lines in languages like MAPINFO or DECORATE. Just remove them, and the code should work.

Share this post


Link to post
  • 0
Posted (edited)
9 hours ago, Empyre said:

Languages like ACS and C use semicolons to separate commands, so it is too easy to forget to leave them off of the ends of lines in languages like MAPINFO or DECORATE. Just remove them, and the code should work.

 

Doesn't help that my default 'language' if you can call it that is CSS, heh. Apologies for the erroneous code example, I wasn't on a computer where I can test it. I've edited out the semicolons in my initial post. :)

Share this post


Link to post
  • 0

Your GameInfo looks fine, assuming that there one or more quit messages after that comma.

Unless you are making an IWAD, you should use DefaultMap instead of GameDefault. Also, put all the properties into one block, like Dragonfly suggested, but make that block DefaultMap.

Here is the MAPINFO ZDoom Wiki page, just in case you aren't already using it.

Share this post


Link to post
  • 0
Posted (edited)
5 hours ago, DynamiteKaitorn said:

Both DefaultMap AND AddDefaultMap with the same method and it STILL wont register the extended air supply... :l

You cannot modify existing mapinfo entries. DefaultMap and AddDefaultMap only apply to new entries defined after them.

Share this post


Link to post
  • 0
Posted (edited)

Just curious, if I made a dummy map, (for example, map entry 666 (ha ha >_>)) would it work outside of the dummy map? (Obviously I wanna make sure the dummy map is capable of being loaded... don't want it empty :P)

 

EDIT:

Well it will fix my issue... but it will only work for defined maps... guess I hit a limit with DooM? XD

Thanks for the help guys :3

Edited by DynamiteKaitorn

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×